summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-21 00:35:25 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-21 00:35:25 +0000
commit64b6e7331f492ae6647b09c26fe770cd5c326ced (patch)
tree4fed67ef72fbccac591e63b6bd4cb812dcd16fc6 /dev-java/jebl/jebl-0.5.3.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-64b6e7331f492ae6647b09c26fe770cd5c326ced.tar.gz
historical-64b6e7331f492ae6647b09c26fe770cd5c326ced.tar.bz2
historical-64b6e7331f492ae6647b09c26fe770cd5c326ced.zip
New package, dependency of sci-biology/beast-mcmc, import from java overlay, ebuild written by me
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'dev-java/jebl/jebl-0.5.3.ebuild')
-rw-r--r--dev-java/jebl/jebl-0.5.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/jebl/jebl-0.5.3.ebuild b/dev-java/jebl/jebl-0.5.3.ebuild
new file mode 100644
index 000000000000..a841558a59b1
--- /dev/null
+++ b/dev-java/jebl/jebl-0.5.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jebl/jebl-0.5.3.ebuild,v 1.1 2009/09/21 00:35:25 weaver Exp $
+
+EAPI="2"
+
+#ESVN_REPO_URI="https://jebl.svn.sourceforge.net/svnroot/jebl/trunk/jebl"
+#ESVN_REPO_URI="https://jebl.svn.sourceforge.net/svnroot/jebl/tags/${P//./_}"
+
+JAVA_PKG_IUSE="doc"
+EANT_BUILD_TARGET="dist"
+EANT_DOC_TARGET="document"
+
+#inherit subversion java-pkg-2 java-ant-2
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java Evolutionary Biology Library"
+HOMEPAGE="http://jebl.sourceforge.net/"
+#SRC_URI=""
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+CDEPEND=""
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+S="${WORKDIR}/${P//./_}"
+
+src_install() {
+ java-pkg_dojar dist/jebl.jar || die
+ java-pkg_dojar dist/jam.jar || die
+# use doc && java-pkg_dojavadoc doc/api
+}