summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-27 19:10:52 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-27 19:10:52 +0000
commit17dee6e7e917e4c4150a2182e10d3d78a482820e (patch)
tree105532dcf0226ee483d51df3521e68bccebdc5f0 /dev-lang/python
parentVersion bumped. (diff)
downloadhistorical-17dee6e7e917e4c4150a2182e10d3d78a482820e.tar.gz
historical-17dee6e7e917e4c4150a2182e10d3d78a482820e.tar.bz2
historical-17dee6e7e917e4c4150a2182e10d3d78a482820e.zip
disabling pkg_setup again after testing with stage2
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog5
-rw-r--r--dev-lang/python/Manifest4
-rw-r--r--dev-lang/python/python-2.3.3.ebuild7
3 files changed, 11 insertions, 5 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index ec7598908fe5..41870ce7b4f8 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.74 2004/01/26 12:04:53 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.75 2004/01/27 19:10:52 liquidx Exp $
+
+ 27 Jan 2004; Alastair Tse <liquidx@gentoo.org> python-2.3.3.ebuild:
+ disabling pkg_setup again after testing with stage2
26 Jan 2004; Alastair Tse <liquidx@gentoo.org> python-2.3.3.ebuild:
re-instating pkg_setup() warning/abort message. added apache mime.types to
diff --git a/dev-lang/python/Manifest b/dev-lang/python/Manifest
index 026856d1ba21..f8eeeda57efa 100644
--- a/dev-lang/python/Manifest
+++ b/dev-lang/python/Manifest
@@ -1,10 +1,10 @@
-MD5 a80a6122205c0a1b05ba8b5d8d3b94b5 ChangeLog 13796
+MD5 29cdcf44284abdcab9f51a2f3b06d844 ChangeLog 13921
MD5 8145ce0144332d6caca98fa5fb648741 metadata.xml 221
MD5 58b06d58bccd371fcbf1b781164c75a9 python-2.1.3-r1.ebuild 2345
MD5 f7959cf61958991a7e25f83a4e8b2ff8 python-2.2.1-r5.ebuild 2912
MD5 c70d578ef0b3e6358108691e8b88d458 python-2.2.2.ebuild 3027
MD5 e1f163ef92e80940f820c7759c8abb46 python-2.2.3-r5.ebuild 4347
-MD5 09bccf2f41054392dc2f3be04b332c13 python-2.3.3.ebuild 5624
+MD5 47aff33d86ee702f5e7a7cf4149533f6 python-2.3.3.ebuild 5798
MD5 c16ab4058ca2e01ed72ac31000e5700f files/depreorder.py 2239
MD5 f3f370c8d1382c1a7571cfc1cbb196d9 files/digest-python-2.1.3-r1 62
MD5 aa73c4258e3be099345a929ad6e01665 files/digest-python-2.2.1-r5 62
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index aede86041f46..c80bed8bc48c 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.9 2004/01/26 12:04:53 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.10 2004/01/27 19:10:52 liquidx Exp $
inherit flag-o-matic python
@@ -43,7 +43,10 @@ PROVIDE="virtual/python"
# add portage to DEPENDS otherwise it'll create a circular dependency
# NOTE: we don't need this any more as sys-apps/portage-2.0.49-r18 is
# already stable
-pkg_setup() {
+# NOTE2: OK, the reason this is _now_ disabled is because Gentoo 1.4
+# stage2 should upgrade fine to 2.3.3 even with the presence of
+# an old portage
+pkg_setup_disabled() {
if ! has_version ">=sys-apps/portage-2.0.49-r16"; then
eerror "Dependency Failed! Requires >=sys-apps/portage-2.0.49-r16"
eerror "Please run: emerge portage"