summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-02-11 11:43:54 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-02-11 11:43:54 +0000
commit4c5910f1a79a2d13f9ab04013778afd4a05388c8 (patch)
tree456fc0325f3ac8aabd51ddc32a16dd2effb03825 /dev-libs/cgicc
parentVersion bump; 1.0.3 stable on x86. Tidy old ebuilds. (diff)
downloadhistorical-4c5910f1a79a2d13f9ab04013778afd4a05388c8.tar.gz
historical-4c5910f1a79a2d13f9ab04013778afd4a05388c8.tar.bz2
historical-4c5910f1a79a2d13f9ab04013778afd4a05388c8.zip
Version bump; added IUSE='doc debug'.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-libs/cgicc')
-rw-r--r--dev-libs/cgicc/ChangeLog10
-rw-r--r--dev-libs/cgicc/cgicc-3.2.1.ebuild39
-rw-r--r--dev-libs/cgicc/cgicc-3.2.3.ebuild42
-rw-r--r--dev-libs/cgicc/files/digest-cgicc-3.2.31
-rw-r--r--dev-libs/cgicc/metadata.xml25
5 files changed, 94 insertions, 23 deletions
diff --git a/dev-libs/cgicc/ChangeLog b/dev-libs/cgicc/ChangeLog
index b700f6377aea..78ee97f8c5f4 100644
--- a/dev-libs/cgicc/ChangeLog
+++ b/dev-libs/cgicc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/cgicc
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cgicc/ChangeLog,v 1.5 2004/06/24 23:02:18 agriffis Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cgicc/ChangeLog,v 1.6 2005/02/11 11:43:54 ka0ttic Exp $
+
+*cgicc-3.2.3 (11 Feb 2005)
+
+ 11 Feb 2005; Aaron Walker <ka0ttic@gentoo.org> +metadata.xml,
+ cgicc-3.2.1.ebuild, +cgicc-3.2.3.ebuild:
+ Version bump; added IUSE='doc debug'.
14 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> cgicc-3.2.1.ebuild:
Don't assign default to S; header fix
diff --git a/dev-libs/cgicc/cgicc-3.2.1.ebuild b/dev-libs/cgicc/cgicc-3.2.1.ebuild
index e2c1ee882de9..0d67b2d19c67 100644
--- a/dev-libs/cgicc/cgicc-3.2.1.ebuild
+++ b/dev-libs/cgicc/cgicc-3.2.1.ebuild
@@ -1,36 +1,33 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cgicc/cgicc-3.2.1.ebuild,v 1.5 2004/06/24 23:02:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cgicc/cgicc-3.2.1.ebuild,v 1.6 2005/02/11 11:43:54 ka0ttic Exp $
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86"
DESCRIPTION="A C++ class library for writing CGI applications"
+HOMEPAGE="http://www.cgicc.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-HOMEPAGE="http://www.cgicc.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
IUSE=""
-DEPEND=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
- cd ${S}
-
# docs are included in html form, no need to depend on doxygen and regenerate them
- mv Makefile.in Makefile.in.orig
- sed -e 's|^SUBDIRS = cgicc doc support $(DEMO)|SUBDIRS = cgicc support $(DEMO)|' \
- -e 's|^DIST_SUBDIRS = cgicc doc support demo contrib|DIST_SUBDIRS = cgicc support demo contrib|' \
- -e 's|$(mkinstalldirs) $(distdir)/cgicc $(distdir)/doc $(distdir)/support|$(mkinstalldirs) $(distdir)/cgicc $(distdir)/support|' \
- Makefile.in.orig > Makefile.in
-}
-
-src_compile() {
- econf || die
- emake || die
+ sed -i \
+ -e 's|^\(SUBDIRS = cgicc\) doc\( support $(DEMO)\)|\1\2|' \
+ -e 's|^\(DIST_SUBDIRS = cgicc\) doc\(support demo contrib\)|\1\2|' \
+ -e 's|\($(mkdir_p) $(distdir)/cgicc\) $(distdir)/doc\( $(distdir)/support\)|\1\2|' \
+ ${S}/Makefile.in || die "sed Makefile.in failed"
}
src_install() {
dohtml -r doc/html/*
rm -rf doc
- make DESTDIR=${D} install || die
- dodoc AUTHORS ChangeLog COPYING COPYING.DOC COPYING.LIB INSTALL NEWS README README.WIN THANKS
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING COPYING.DOC COPYING.LIB INSTALL NEWS \
+ README README.WIN THANKS
}
diff --git a/dev-libs/cgicc/cgicc-3.2.3.ebuild b/dev-libs/cgicc/cgicc-3.2.3.ebuild
new file mode 100644
index 000000000000..f6e9c5bd6a60
--- /dev/null
+++ b/dev-libs/cgicc/cgicc-3.2.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cgicc/cgicc-3.2.3.ebuild,v 1.1 2005/02/11 11:43:54 ka0ttic Exp $
+
+DESCRIPTION="A C++ class library for writing CGI applications"
+HOMEPAGE="http://www.cgicc.org/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc debug"
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ # docs are included in html form, no need to depend on doxygen and regenerate them
+ sed -i \
+ -e 's|^\(SUBDIRS = cgicc\) doc\( support $(DEMO)\)|\1\2|' \
+ -e 's|^\(DIST_SUBDIRS = cgicc\) doc\(support demo contrib\)|\1\2|' \
+ -e 's|\($(mkdir_p) $(distdir)/cgicc\) $(distdir)/doc\( $(distdir)/support\)|\1\2|' \
+ ${S}/Makefile.in || die "sed Makefile.in failed"
+}
+
+src_compile() {
+ econf \
+ --disable-demos \
+ --enable-warnings \
+ $(use_enable debug debug-logging) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ use doc && dohtml -r doc/html/*
+ rm -rf doc
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING COPYING.DOC COPYING.LIB INSTALL NEWS \
+ README README.WIN THANKS
+}
diff --git a/dev-libs/cgicc/files/digest-cgicc-3.2.3 b/dev-libs/cgicc/files/digest-cgicc-3.2.3
new file mode 100644
index 000000000000..38fb3e0c01aa
--- /dev/null
+++ b/dev-libs/cgicc/files/digest-cgicc-3.2.3
@@ -0,0 +1 @@
+MD5 cd7a7a5a1fd186bd8f481c4e17354a0b cgicc-3.2.3.tar.bz2 445393
diff --git a/dev-libs/cgicc/metadata.xml b/dev-libs/cgicc/metadata.xml
new file mode 100644
index 000000000000..301a6f15debe
--- /dev/null
+++ b/dev-libs/cgicc/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ka0ttic@gentoo.org</email>
+ <name>Aaron Walker</name>
+ </maintainer>
+ <longdescription lang="en">
+GNU cgicc is an ANSI C++ compliant class library that greatly
+simplifies the creation of CGI applications for the World Wide
+Web. cgicc performs the following functions:
+
+ - Parses both GET and POST form data transparently
+ - Provides string, integer, floating-point and single- and
+ multiple-choice retrieval methods for form data
+ - Provides methods for saving and restoring CGI environments to aid
+ in application debugging
+ - Provides full on-the-fly HTML 4.0 generation capabilities, with support
+ for cookies
+ - Supports HTTP file upload
+ - Compatible with FastCGI
+ </longdescription>
+</pkgmetadata>
+