summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2011-05-29 16:04:51 +0000
committerThomas Sachau <tommy@gentoo.org>2011-05-29 16:04:51 +0000
commit58639974d31806c106a98a3589ad6c7091283ca2 (patch)
tree93848fc8d11ce7f3145976fdacde6be9b0d618a6 /dev-libs/eet
parentVersion bump, also fixes bug 368951. Remove old versions. Add multilib suppor... (diff)
downloadhistorical-58639974d31806c106a98a3589ad6c7091283ca2.tar.gz
historical-58639974d31806c106a98a3589ad6c7091283ca2.tar.bz2
historical-58639974d31806c106a98a3589ad6c7091283ca2.zip
Version bump
Package-Manager: portage-2.2.0_alpha37-r1/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/eet')
-rw-r--r--dev-libs/eet/ChangeLog7
-rw-r--r--dev-libs/eet/eet-1.4.1.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-libs/eet/ChangeLog b/dev-libs/eet/ChangeLog
index 9ddb34392419..acf1ce140a09 100644
--- a/dev-libs/eet/ChangeLog
+++ b/dev-libs/eet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/eet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/eet/ChangeLog,v 1.16 2011/02/25 19:35:52 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eet/ChangeLog,v 1.17 2011/05/29 16:04:51 tommy Exp $
+
+*eet-1.4.1 (29 May 2011)
+
+ 29 May 2011; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> +eet-1.4.1.ebuild:
+ Version bump
25 Feb 2011; Kevin McCarthy <signals@gentoo.org> eet-1.4.0.ebuild:
Update depends from media-libs/jpeg to virtual/jpeg
diff --git a/dev-libs/eet/eet-1.4.1.ebuild b/dev-libs/eet/eet-1.4.1.ebuild
new file mode 100644
index 000000000000..349d88794764
--- /dev/null
+++ b/dev-libs/eet/eet-1.4.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eet/eet-1.4.1.ebuild,v 1.1 2011/05/29 16:04:51 tommy Exp $
+
+EAPI=2
+
+inherit enlightenment
+
+DESCRIPTION="E file chunk reading/writing library"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Eet"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="debug examples gnutls ssl static-libs test +threads"
+
+RDEPEND=">=dev-libs/eina-1.0.0_beta
+ virtual/jpeg
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check
+ dev-util/lcov )"
+
+src_configure() {
+ local SSL_FLAGS=""
+
+ if use gnutls; then
+ if use ssl; then
+ ewarn "You have enabled both 'ssl' and 'gnutls', so we will use"
+ ewarn "gnutls and not openssl for cipher and signature support"
+ fi
+ SSL_FLAGS="
+ --enable-cipher
+ --enable-signature
+ --disable-openssl
+ --enable-gnutls"
+ elif use ssl; then
+ SSL_FLAGS="
+ --enable-cipher
+ --enable-signature
+ --enable-openssl
+ --disable-gnutls"
+ else
+ SSL_FLAGS="
+ --disable-cipher
+ --disable-signature
+ --disable-openssl
+ --disable-gnutls"
+ fi
+
+ export MY_ECONF="
+ $(use_enable !debug amalgamation)
+ $(use_enable debug assert)
+ $(use_enable doc)
+ $(use_enable test tests)
+ $(use_enable test coverage)
+ $(use_enable threads posix-threads)
+ ${SSL_FLAGS}
+ ${MY_ECONF}"
+
+ enlightenment_src_configure
+}
+
+src_install() {
+ enlightenment_src_install
+ rm -r src/examples/Makefile* || die
+ docinto examples
+ dodoc src/examples/* || die
+}