summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2011-01-14 02:38:55 +0000
committerRyan Hill <rhill@gentoo.org>2011-01-14 02:38:55 +0000
commitc5b234ce447bbc3b8dfa29f960fe2285e6bd54c2 (patch)
treeaa3027eeae8944225ecd6f5df282da7e1959cf4b /dev-libs/elfutils/elfutils-0.151.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-c5b234ce447bbc3b8dfa29f960fe2285e6bd54c2.tar.gz
historical-c5b234ce447bbc3b8dfa29f960fe2285e6bd54c2.tar.bz2
historical-c5b234ce447bbc3b8dfa29f960fe2285e6bd54c2.zip
Version bump.
Package-Manager: portage-2.2.0_alpha15/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/elfutils/elfutils-0.151.ebuild')
-rw-r--r--dev-libs/elfutils/elfutils-0.151.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/elfutils/elfutils-0.151.ebuild b/dev-libs/elfutils/elfutils-0.151.ebuild
new file mode 100644
index 000000000000..65b3ace074be
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.151.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.151.ebuild,v 1.1 2011/01/14 02:38:55 dirtyepic Exp $
+
+inherit eutils
+
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="https://fedorahosted.org/elfutils"
+SRC_URI="https://fedorahosted.org/releases/e/l/elfutils/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2-with-exceptions"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 lzma nls zlib elibc_glibc"
+
+# This pkg does not actually seem to compile currently in a uClibc
+# environment (xrealloc errs), but we need to ensure that glibc never
+# gets pulled in as a dep since this package does not respect virtual/libc
+RDEPEND="zlib? ( >=sys-libs/zlib-1.2.2.3 )
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( !prefix? ( >=sys-libs/glibc-2.7 ) )
+ nls? ( sys-devel/gettext )
+ >=sys-devel/flex-2.5.4a
+ sys-devel/m4
+ >=sys-devel/binutils-2.15.90.0.1
+ >=sys-devel/gcc-4.1.2
+ !dev-libs/libelf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.118-PaX-support.patch
+ epatch "${FILESDIR}"/${PN}-0.150-bashifications.patch #287130
+ find . -name Makefile.in -print0 | xargs -0 sed -i -e 's:-W\(error\|extra\)::g'
+ use test || sed -i -e 's: tests::' Makefile.in #226349
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --program-prefix="eu-" \
+ $(use_with zlib) \
+ $(use_with bzip2 bzlib) \
+ $(use_with lzma)
+
+ emake || die
+}
+
+src_test() {
+ env LD_LIBRARY_PATH="${S}/libelf:${S}/libebl:${S}/libdw:${S}/libasm" \
+ LC_ALL="C" \
+ emake -j1 check || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO
+}