summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-08-02 22:16:55 +0000
committerNed Ludd <solar@gentoo.org>2004-08-02 22:16:55 +0000
commitb094b04e295b2c0f4889dfa48a1567c59d6d5e07 (patch)
treeaca4b89ea95bad0b0f7b3b98e5d093b44de2d7dc /dev-libs/elfutils
parentVersion bump and -fPIC fixes. Closes bug #56026. Added -amd64. (diff)
downloadhistorical-b094b04e295b2c0f4889dfa48a1567c59d6d5e07.tar.gz
historical-b094b04e295b2c0f4889dfa48a1567c59d6d5e07.tar.bz2
historical-b094b04e295b2c0f4889dfa48a1567c59d6d5e07.zip
elfutils does not actually seem to compile currently in a uClibc environment (xrealloc errs), but we need to ensure that glibc never gets pulled in as a dep, since this package does not respect virtual/libc
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/ChangeLog7
-rw-r--r--dev-libs/elfutils/Manifest4
-rw-r--r--dev-libs/elfutils/elfutils-0.94-r1.ebuild14
3 files changed, 18 insertions, 7 deletions
diff --git a/dev-libs/elfutils/ChangeLog b/dev-libs/elfutils/ChangeLog
index 9b88b5e552b4..86d5b140d38f 100644
--- a/dev-libs/elfutils/ChangeLog
+++ b/dev-libs/elfutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/elfutils
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.38 2004/06/24 23:08:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.39 2004/08/02 22:16:55 solar Exp $
+
+ 02 Aug 2004; <solar@gentoo.org> elfutils-0.94-r1.ebuild:
+ elfutils does not actually seem to compile currently in a uClibc environment
+ (xrealloc errs), but we need to ensure that glibc never gets pulled in as a
+ dep, since this package does not respect virtual/libc
20 Apr 2004; <agriffis@gentoo.org> elfutils-0.94-r1.ebuild:
Add missing ia64 keyword
diff --git a/dev-libs/elfutils/Manifest b/dev-libs/elfutils/Manifest
index 0c8bcfcaf86a..138f7b30fadd 100644
--- a/dev-libs/elfutils/Manifest
+++ b/dev-libs/elfutils/Manifest
@@ -1,4 +1,4 @@
-MD5 bc134d354f086a902c358ead74be5ae7 elfutils-0.94-r1.ebuild 1412
-MD5 67b5c5c2382f10328262e2eb78e750a1 ChangeLog 4397
+MD5 f0234fb768969fef66b05ab565cf94d5 elfutils-0.94-r1.ebuild 1676
+MD5 0b537a60c3adaff16f4cee4721b03b6b ChangeLog 4667
MD5 25da57fec6a38ed0c69ec6682b595398 files/elfutils-0.94-alpha-mips-atime.diff 699
MD5 98e005817217428fef7c200faec78382 files/digest-elfutils-0.94-r1 65
diff --git a/dev-libs/elfutils/elfutils-0.94-r1.ebuild b/dev-libs/elfutils/elfutils-0.94-r1.ebuild
index 30a146bdac48..a3ba62a6bfbe 100644
--- a/dev-libs/elfutils/elfutils-0.94-r1.ebuild
+++ b/dev-libs/elfutils/elfutils-0.94-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.94-r1.ebuild,v 1.7 2004/06/24 23:08:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.94-r1.ebuild,v 1.8 2004/08/02 22:16:55 solar Exp $
-inherit eutils
+inherit eutils gnuconfig
DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
HOMEPAGE="http://www.redhat.com/"
@@ -11,9 +11,13 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="OpenSoftware"
SLOT="0"
KEYWORDS="x86 sparc amd64 ppc alpha mips ia64"
-IUSE="nls"
+IUSE="nls uclibc"
-DEPEND=">=sys-libs/glibc-2.3.2
+# This pkg does not actually seem to compile currently in a uClibc
+# environment (xrealloc errs), but we need to ensure that glibc never
+# gets pulled in as a dep since this package does not respect virtual/libc
+
+DEPEND="!uclibc? ( >=sys-libs/glibc-2.3.2 )
>=sys-devel/binutils-2.14.90.0.6
>=sys-devel/gcc-3.2.1-r6
!dev-libs/libelf"
@@ -28,6 +32,8 @@ src_unpack() {
done
use mips || use alpha && epatch ${FILESDIR}/${P}-alpha-mips-atime.diff
+
+ gnuconfig_update ${S}
}
src_compile() {