summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-15 22:23:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-15 22:23:55 +0000
commite50695c80f230623f7cacc8288d5e1d1aad32245 (patch)
tree059a7e9184996ef2ee6e52aa18483e86cc57a90d /dev-libs/libgcrypt
parentApply upstream patch to fix compilation with openssl-1.0.0. Bug #328487 (diff)
downloadhistorical-e50695c80f230623f7cacc8288d5e1d1aad32245.tar.gz
historical-e50695c80f230623f7cacc8288d5e1d1aad32245.tar.bz2
historical-e50695c80f230623f7cacc8288d5e1d1aad32245.zip
Delete older ebuilds.
Diffstat (limited to 'dev-libs/libgcrypt')
-rw-r--r--dev-libs/libgcrypt/files/libgcrypt-1.4.0-HMAC-SHA-384-512.patch20
-rw-r--r--dev-libs/libgcrypt/files/libgcrypt-1.4.3-HMAC-SHA-384-512.patch21
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild74
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.4.3-r1.ebuild71
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild42
5 files changed, 0 insertions, 228 deletions
diff --git a/dev-libs/libgcrypt/files/libgcrypt-1.4.0-HMAC-SHA-384-512.patch b/dev-libs/libgcrypt/files/libgcrypt-1.4.0-HMAC-SHA-384-512.patch
deleted file mode 100644
index 6841fce90a27..000000000000
--- a/dev-libs/libgcrypt/files/libgcrypt-1.4.0-HMAC-SHA-384-512.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- cipher/md.c.orig 2007-08-14 02:46:51.000000000 +1000
-+++ cipher/md.c 2008-11-06 19:05:37.000000000 +1100
-@@ -791,7 +791,7 @@
- if ( !algo )
- return GPG_ERR_DIGEST_ALGO; /* i.e. no algo enabled */
-
-- if ( keylen > 64 )
-+ if ( keylen > hd->ctx->macpads_Bsize )
- {
- helpkey = gcry_malloc_secure ( md_digest_length( algo ) );
- if ( !helpkey )
-@@ -799,7 +799,7 @@
- gcry_md_hash_buffer ( algo, helpkey, key, keylen );
- key = helpkey;
- keylen = md_digest_length( algo );
-- assert ( keylen <= 64 );
-+ assert ( keylen <= hd->ctx->macpads_Bsize );
- }
-
- memset ( hd->ctx->macpads, 0, 2*(hd->ctx->macpads_Bsize) );
diff --git a/dev-libs/libgcrypt/files/libgcrypt-1.4.3-HMAC-SHA-384-512.patch b/dev-libs/libgcrypt/files/libgcrypt-1.4.3-HMAC-SHA-384-512.patch
deleted file mode 100644
index e9146b9085a0..000000000000
--- a/dev-libs/libgcrypt/files/libgcrypt-1.4.3-HMAC-SHA-384-512.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- orig/libgcrypt-1.4.3/cipher/md.c 2008-09-12 15:43:52.000000000 +0200
-+++ libgcrypt-1.4.3/cipher/md.c 2008-11-05 19:52:32.000000000 +0100
-@@ -834,7 +834,7 @@ prepare_macpads( gcry_md_hd_t hd, const
- if ( !algo )
- return GPG_ERR_DIGEST_ALGO; /* i.e. no algo enabled */
-
-- if ( keylen > 64 )
-+ if ( keylen > hd->ctx->macpads_Bsize )
- {
- helpkey = gcry_malloc_secure ( md_digest_length( algo ) );
- if ( !helpkey )
-@@ -842,7 +842,7 @@ prepare_macpads( gcry_md_hd_t hd, const
- gcry_md_hash_buffer ( algo, helpkey, key, keylen );
- key = helpkey;
- keylen = md_digest_length( algo );
-- gcry_assert ( keylen <= 64 );
-+ gcry_assert ( keylen <= hd->ctx->macpads_Bsize );
- }
-
- memset ( hd->ctx->macpads, 0, 2*(hd->ctx->macpads_Bsize) );
-
diff --git a/dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild
deleted file mode 100644
index 238afe7f53c2..000000000000
--- a/dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild,v 1.12 2008/12/07 12:05:47 vapier Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
-HOMEPAGE="http://www.gnupg.org/"
-SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.bz2
- !bindist? ( idea? ( mirror://gentoo/${P}-idea.diff.bz2 ) )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="nls bindist idea"
-
-RDEPEND="nls? ( virtual/libintl )
- >=dev-libs/libgpg-error-1.5"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # http://marc.info/?l=gcrypt-devel&m=122591162816263&w=2
- epatch "${FILESDIR}"/${P}-HMAC-SHA-384-512.patch
-
- if use idea; then
- if use bindist; then
- elog "Skipping IDEA support to comply with binary distribution (bug #148907)."
- else
- ewarn "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html"
- epatch "${WORKDIR}/${P}-idea.diff"
- AT_M4DIR="m4" eautoreconf
- fi
- fi
-}
-
-src_compile() {
- # --disable-padlock-support for bug#201917
- econf \
- --disable-padlock-support \
- --disable-dependency-tracking \
- --with-pic \
- --enable-noexecstack \
- $(use_enable nls) \
- || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS BUGS ChangeLog NEWS README* THANKS TODO VERSION
-}
-
-pkg_postinst() {
- if use !bindist && use idea; then
- ewarn "-----------------------------------------------------------------------------------"
- ewarn "IDEA"
- ewarn "you have compiled ${PN} with support for the IDEA algorithm, this code"
- ewarn "is distributed under the GPL in countries where it is permitted to do so"
- ewarn "by law."
- ewarn
- ewarn "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html for more information."
- ewarn
- ewarn "If you are in a country where the IDEA algorithm is patented, you are permitted"
- ewarn "to use it at no cost for 'non revenue generating data transfer between private"
- ewarn "individuals'."
- ewarn
- ewarn "Countries where the patent applies are listed here"
- ewarn "http://en.wikipedia.org/wiki/International_Data_Encryption_Algorithm#Security"
- ewarn "-----------------------------------------------------------------------------------"
- fi
-}
diff --git a/dev-libs/libgcrypt/libgcrypt-1.4.3-r1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.4.3-r1.ebuild
deleted file mode 100644
index 4535fc9a79a0..000000000000
--- a/dev-libs/libgcrypt/libgcrypt-1.4.3-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.3-r1.ebuild,v 1.1 2008/11/06 08:10:02 dragonheart Exp $
-
-inherit autotools eutils
-
-DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
-HOMEPAGE="http://www.gnupg.org/"
-SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.bz2
- ftp://ftp.gnupg.org/gcrypt/${PN}/${P}.tar.bz2
- !bindist? ( idea? ( mirror://gentoo/${PN}-1.4.0-idea.diff.bz2 ) )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="bindist idea"
-
-RDEPEND=">=dev-libs/libgpg-error-1.5"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # http://marc.info/?l=gcrypt-devel&m=122591162816263&w=2
- epatch "${FILESDIR}"/${P}-HMAC-SHA-384-512.patch
-
- if use idea; then
- if use bindist; then
- elog "Skipping IDEA support to comply with binary distribution (bug #148907)."
- else
- ewarn "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html"
- epatch "${WORKDIR}/${PN}-1.4.0-idea.diff"
- AT_M4DIR="m4" eautoreconf
- fi
- fi
-}
-
-src_compile() {
- # --disable-padlock-support for bug #201917
- econf \
- --disable-padlock-support \
- --disable-dependency-tracking \
- --with-pic \
- --enable-noexecstack
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
-}
-
-pkg_postinst() {
- if use !bindist && use idea; then
- ewarn "-----------------------------------------------------------------------------------"
- ewarn "IDEA"
- ewarn "you have compiled ${PN} with support for the IDEA algorithm, this code"
- ewarn "is distributed under the GPL in countries where it is permitted to do so"
- ewarn "by law."
- ewarn
- ewarn "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html for more information."
- ewarn
- ewarn "If you are in a country where the IDEA algorithm is patented, you are permitted"
- ewarn "to use it at no cost for 'non revenue generating data transfer between private"
- ewarn "individuals'."
- ewarn
- ewarn "Countries where the patent applies are listed here"
- ewarn "http://en.wikipedia.org/wiki/International_Data_Encryption_Algorithm#Security"
- ewarn "-----------------------------------------------------------------------------------"
- fi
-}
diff --git a/dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild b/dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild
deleted file mode 100644
index 27a0ef0cbe56..000000000000
--- a/dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild,v 1.11 2009/12/13 18:03:39 armin76 Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
-HOMEPAGE="http://www.gnupg.org/"
-SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.bz2
- ftp://ftp.gnupg.org/gcrypt/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND=">=dev-libs/libgpg-error-1.5"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- [[ $(tc-arch) == x86 && $(gcc-version) == 4.1 ]] && replace-flags -O3 -O2
-}
-
-src_prepare() {
- epunt_cxx
-}
-
-src_configure() {
- # --disable-padlock-support for bug #201917
- econf \
- --disable-padlock-support \
- --disable-dependency-tracking \
- --with-pic \
- --enable-noexecstack
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
-}