summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-12 11:34:29 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-12 11:34:29 +0000
commit2ff1b6082f2a327077456f54164d83bdc1d0a6ee (patch)
treed86ac99b877f6802c28e97d545672a921d42ea97 /dev-libs/libpcre
parentChanged 'mpc' USE flag to 'musepack'. (diff)
downloadhistorical-2ff1b6082f2a327077456f54164d83bdc1d0a6ee.tar.gz
historical-2ff1b6082f2a327077456f54164d83bdc1d0a6ee.tar.bz2
historical-2ff1b6082f2a327077456f54164d83bdc1d0a6ee.zip
add epunt_cxx and change make to emake
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'dev-libs/libpcre')
-rw-r--r--dev-libs/libpcre/Manifest16
-rw-r--r--dev-libs/libpcre/libpcre-5.0.ebuild18
2 files changed, 17 insertions, 17 deletions
diff --git a/dev-libs/libpcre/Manifest b/dev-libs/libpcre/Manifest
index ddaf85c95ea6..395c63859097 100644
--- a/dev-libs/libpcre/Manifest
+++ b/dev-libs/libpcre/Manifest
@@ -1,15 +1,15 @@
-MD5 c1e212329f9083e2405b16dd382d6632 metadata.xml 259
MD5 db2c2e74d8d23be02f1b8a428b6f189e ChangeLog 7018
-MD5 e11933575b142a8990bda3881545b63e libpcre-4.5.ebuild 1106
+MD5 f6ce586d696bb0d61e8c532c6050b404 libpcre-5.0.ebuild 1415
MD5 59046451dd9a28a2a59c373b6b7f12c3 libpcre-4.2-r1.ebuild 852
-MD5 921eeb1aeb08a3174482a29bb57b65f0 libpcre-5.0.ebuild 1428
MD5 47ad7fd446e1df9f7b55008a9aa8bbc1 libpcre-4.4.ebuild 1008
-MD5 e8b4b76c398da338c2c88e5321435d78 files/digest-libpcre-4.4 61
+MD5 c1e212329f9083e2405b16dd382d6632 metadata.xml 259
+MD5 e11933575b142a8990bda3881545b63e libpcre-4.5.ebuild 1106
MD5 6f60a57bf3e47726ed16127d65ae834c files/digest-libpcre-5.0 61
-MD5 4e0522aaf9e2d5a196830b897f2341d2 files/digest-libpcre-4.5 61
MD5 bf62625896b04a15d6ca53e66f2c3e1e files/pcre-5.0-uclibc-tuple.patch 1624
-MD5 0e2abdb46d4bf2a27fd55cf72358d465 files/pcre-4.2-macos.patch 1505
-MD5 50222f90517286730bd924d2543a316b files/pcre-5.0-macos.patch 1041
+MD5 9aa6aa1ebfe1906cfd3ce45e47a58873 files/digest-libpcre-4.2-r1 61
+MD5 e8b4b76c398da338c2c88e5321435d78 files/digest-libpcre-4.4 61
+MD5 4e0522aaf9e2d5a196830b897f2341d2 files/digest-libpcre-4.5 61
MD5 1af02e35bc7fb89c7884027ff3a2a555 files/pcre-4.2-link.patch 717
MD5 42a3f4bf8ab591263bcc23343f99c035 files/pcre-4.4-uclibc-tuple.patch 1437
-MD5 9aa6aa1ebfe1906cfd3ce45e47a58873 files/digest-libpcre-4.2-r1 61
+MD5 0e2abdb46d4bf2a27fd55cf72358d465 files/pcre-4.2-macos.patch 1505
+MD5 50222f90517286730bd924d2543a316b files/pcre-5.0-macos.patch 1041
diff --git a/dev-libs/libpcre/libpcre-5.0.ebuild b/dev-libs/libpcre/libpcre-5.0.ebuild
index 1c66b73f9d34..37ade22ed2a3 100644
--- a/dev-libs/libpcre/libpcre-5.0.ebuild
+++ b/dev-libs/libpcre/libpcre-5.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-5.0.ebuild,v 1.10 2005/04/18 17:01:52 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-5.0.ebuild,v 1.11 2005/05/12 11:34:29 vapier Exp $
-inherit libtool flag-o-matic eutils gnuconfig
+inherit libtool flag-o-matic eutils
DESCRIPTION="Perl-compatible regular expression library"
HOMEPAGE="http://www.pcre.org/"
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-${PV}.tar.bz
LICENSE="BSD"
SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ppc-macos s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc x86"
IUSE=""
DEPEND=""
@@ -23,22 +23,23 @@ src_unpack() {
epatch "${FILESDIR}"/pcre-5.0-uclibc-tuple.patch
epatch "${FILESDIR}"/pcre-4.2-link.patch
use ppc-macos && epatch "${FILESDIR}"/pcre-5.0-macos.patch
+
# position-independent code must used for all shared objects.
append-flags -fPIC
elibtoolize
- gnuconfig_update
+ epunt_cxx
}
src_compile() {
econf --enable-utf8 || die
- make || die
+ emake || die
}
src_install() {
make DESTDIR="${D}" install || die
if use ppc-macos; then
- cd ${D}/usr/lib
+ cd "${D}"/usr/lib
for i in libpcre{,.0.0.1,.0} libpcreposix{,.0.0.0,.0}; do
mv $i $i.dylib
done
@@ -49,7 +50,6 @@ src_install() {
fi
dodoc AUTHORS INSTALL NON-UNIX-USE
- dodoc doc/*.txt
- dodoc doc/Tech.Notes
- dohtml -r doc
+ dodoc doc/*.txt doc/Tech.Notes
+ dohtml -r doc/*
}