summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-10-20 20:46:24 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-10-20 20:46:24 +0000
commit97c75a2ced93c5dd72749d324b2c223dcc5084ab (patch)
tree08bf055477b6465912d0f8e9f00ad76a8a0a0f7c /dev-libs/librelp/librelp-1.0.0.ebuild
parentCleanup (diff)
downloadhistorical-97c75a2ced93c5dd72749d324b2c223dcc5084ab.tar.gz
historical-97c75a2ced93c5dd72749d324b2c223dcc5084ab.tar.bz2
historical-97c75a2ced93c5dd72749d324b2c223dcc5084ab.zip
Version bump.
Package-Manager: portage-2.2_rc94/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/librelp/librelp-1.0.0.ebuild')
-rw-r--r--dev-libs/librelp/librelp-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/librelp/librelp-1.0.0.ebuild b/dev-libs/librelp/librelp-1.0.0.ebuild
new file mode 100644
index 000000000000..cacd312341e1
--- /dev/null
+++ b/dev-libs/librelp/librelp-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librelp/librelp-1.0.0.ebuild,v 1.1 2010/10/20 20:46:24 dev-zero Exp $
+
+EAPI="2"
+
+DESCRIPTION="An easy to use library for the RELP protocol."
+HOMEPAGE="http://www.librelp.com/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+LICENSE="GPL-3 doc? ( FDL-1.3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~sparc ~x86"
+IUSE="debug doc"
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog
+ use doc && dohtml doc/relp.html
+}