summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-03-28 23:45:49 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-03-28 23:45:49 +0000
commit5ee6994e223cf4f5fe8043353d4f166c28485459 (patch)
tree02641be22f3690dcee0273602dfec618d2f59afb /dev-libs/ossp-uuid
parentamd64/x86 stable, bug #215098 (diff)
downloadhistorical-5ee6994e223cf4f5fe8043353d4f166c28485459.tar.gz
historical-5ee6994e223cf4f5fe8043353d4f166c28485459.tar.bz2
historical-5ee6994e223cf4f5fe8043353d4f166c28485459.zip
Initial commit (bug #167649, ebuild written by me).
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-libs/ossp-uuid')
-rw-r--r--dev-libs/ossp-uuid/ChangeLog11
-rw-r--r--dev-libs/ossp-uuid/Manifest5
-rw-r--r--dev-libs/ossp-uuid/files/ossp-uuid-1.6.1-gentoo.patch94
-rw-r--r--dev-libs/ossp-uuid/metadata.xml8
-rw-r--r--dev-libs/ossp-uuid/ossp-uuid-1.6.1.ebuild78
5 files changed, 196 insertions, 0 deletions
diff --git a/dev-libs/ossp-uuid/ChangeLog b/dev-libs/ossp-uuid/ChangeLog
new file mode 100644
index 000000000000..5b79842f3790
--- /dev/null
+++ b/dev-libs/ossp-uuid/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-libs/ossp-uuid
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ossp-uuid/ChangeLog,v 1.1 2008/03/28 23:45:48 dev-zero Exp $
+
+*ossp-uuid-1.6.1 (28 Mar 2008)
+
+ 28 Mar 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +files/ossp-uuid-1.6.1-gentoo.patch, +metadata.xml,
+ +ossp-uuid-1.6.1.ebuild:
+ Initial commit (bug #167649, ebuild written by me).
+
diff --git a/dev-libs/ossp-uuid/Manifest b/dev-libs/ossp-uuid/Manifest
new file mode 100644
index 000000000000..e527ba797585
--- /dev/null
+++ b/dev-libs/ossp-uuid/Manifest
@@ -0,0 +1,5 @@
+AUX ossp-uuid-1.6.1-gentoo.patch 3843 RMD160 40b83245f4a8ba2876730ebf2885e904e881c605 SHA1 6a9b6ca909ea3cdce440f4b497c066d74207b572 SHA256 962be5931fe38c444f550077517d7708ef90daa346d272fd918867663caad756
+DIST uuid-1.6.1.tar.gz 544083 RMD160 50c28b159e8029b47913b61bd69f27bb724def36 SHA1 3f291ff94a3cdf0dac1db4a787bfd0f718dea1e9 SHA256 6522729b6914a4be752aa1dffb82f57c4f182b1a373d864eed8f2ec1e943215e
+EBUILD ossp-uuid-1.6.1.ebuild 1852 RMD160 81d85aeb8260c453b424c35bdcc5d2c4e066fd19 SHA1 563a2f6b85f953a8b6929ace608cce29a7ef7005 SHA256 39f0ae47844751652ffc0574f47ae80ff2dc8d9b827d92508f93db962c476e29
+MISC ChangeLog 432 RMD160 8c0078641ed86285b66576adb42fff27c80dd424 SHA1 2f3430c2e754a9c22d085499879ad1dd47328cd4 SHA256 0e727b9d79f4a3996a71511b91308852d38cb549e20bc508f55110ac8419b054
+MISC metadata.xml 234 RMD160 71429d1d4a30b5ab923cc277f1697e48cd5778cb SHA1 e4587261387a7dad22cdba0a6f2a928dc982c32a SHA256 3299defd0e5e3780bf8db22ac755b39ecc0d5ae97b62507f6795c1dd74b4949b
diff --git a/dev-libs/ossp-uuid/files/ossp-uuid-1.6.1-gentoo.patch b/dev-libs/ossp-uuid/files/ossp-uuid-1.6.1-gentoo.patch
new file mode 100644
index 000000000000..7da4049f3800
--- /dev/null
+++ b/dev-libs/ossp-uuid/files/ossp-uuid-1.6.1-gentoo.patch
@@ -0,0 +1,94 @@
+diff -Naur uuid-1.6.1.orig/Makefile.in uuid-1.6.1/Makefile.in
+--- uuid-1.6.1.orig/Makefile.in 2008-03-28 22:02:53.000000000 +0100
++++ uuid-1.6.1/Makefile.in 2008-03-28 22:03:16.000000000 +0100
+@@ -62,13 +62,13 @@
+ PHP = @PHP@
+ PG_CONFIG = @PG_CONFIG@
+
+-LIB_NAME = libuuid.la
++LIB_NAME = libossp-uuid.la
+ LIB_OBJS = uuid.lo uuid_md5.lo uuid_sha1.lo uuid_prng.lo uuid_mac.lo uuid_time.lo uuid_ui64.lo uuid_ui128.lo uuid_str.lo
+
+-DCE_NAME = libuuid_dce.la
++DCE_NAME = libossp-uuid_dce.la
+ DCE_OBJS = uuid_dce.lo $(LIB_OBJS)
+
+-CXX_NAME = libuuid++.la
++CXX_NAME = libossp-uuid++.la
+ CXX_OBJS = uuid++.lo $(LIB_OBJS)
+
+ PRG_NAME = uuid
+@@ -253,7 +253,7 @@
+ -@if [ ".$(WITH_CXX)" = .yes ]; then \
+ $(LIBTOOL) --mode=install $(SHTOOL) install -c -m 644 $(CXX_NAME) $(DESTDIR)$(libdir)/; \
+ fi
+- @$(LIBTOOL) --mode=install $(SHTOOL) install -c -s -m 755 uuid $(DESTDIR)$(bindir)/
++ @$(LIBTOOL) --mode=install $(SHTOOL) install -c -m 755 uuid $(DESTDIR)$(bindir)/
+ $(SHTOOL) install -c -m 644 $(S)/uuid.1 $(DESTDIR)$(mandir)/man1/
+ -@if [ ".$(WITH_PERL)" = .yes ]; then \
+ (cd $(S)/perl && $(MAKE) $(MFLAGS) install DESTDIR=$(DESTDIR)); \
+diff -Naur uuid-1.6.1.orig/php/config.m4 uuid-1.6.1/php/config.m4
+--- uuid-1.6.1.orig/php/config.m4 2008-03-28 22:02:53.000000000 +0100
++++ uuid-1.6.1/php/config.m4 2008-03-28 23:22:54.000000000 +0100
+@@ -33,10 +33,10 @@
+ if test "$PHP_UUID" != "no"; then
+ PHP_NEW_EXTENSION(uuid, uuid.c, $ext_shared)
+ AC_DEFINE(HAVE_UUID, 1, [Have OSSP uuid library])
+- PHP_ADD_LIBPATH([..], )
+- PHP_ADD_LIBRARY([uuid],, UUID_SHARED_LIBADD)
++ PHP_ADD_LIBRARY([ossp-uuid],, UUID_SHARED_LIBADD)
+ PHP_ADD_INCLUDE([..])
+ PHP_SUBST(UUID_SHARED_LIBADD)
++ LDFLAGS="$LDFLAGS -L../.libs"
+
+ dnl avoid linking conflict with a potentially existing uuid_create(3) in libc
+ AC_CHECK_FUNC(uuid_create,[
+diff -Naur uuid-1.6.1.orig/php/Makefile.local uuid-1.6.1/php/Makefile.local
+--- uuid-1.6.1.orig/php/Makefile.local 2008-03-28 22:02:53.000000000 +0100
++++ uuid-1.6.1/php/Makefile.local 2008-03-28 22:10:17.000000000 +0100
+@@ -42,7 +42,7 @@
+
+ test: build
+ @version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; \
+- $(PHP) -q -d "safe_mode=0" -d "extension_dir=./" uuid.ts $$version
++ $(PHP) -q -d "safe_mode=0" -d "extension_dir=./modules/" uuid.ts $$version
+
+ install: build
+ @version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; extdir="$(EXTDIR)"; \
+diff -Naur uuid-1.6.1.orig/php/uuid.ts uuid-1.6.1/php/uuid.ts
+--- uuid-1.6.1.orig/php/uuid.ts 2008-03-28 22:02:53.000000000 +0100
++++ uuid-1.6.1/php/uuid.ts 2008-03-28 22:10:37.000000000 +0100
+@@ -36,7 +36,7 @@
+
+ print "++ loading DSO uuid.so (low-level API)\n";
+ if (!extension_loaded('uuid')) {
+- dl('modules/uuid.so');
++ dl('uuid.so');
+ }
+
+ print "++ loading PHP uuid.php${php_version} (high-level API)\n";
+diff -Naur uuid-1.6.1.orig/uuid-config.in uuid-1.6.1/uuid-config.in
+--- uuid-1.6.1.orig/uuid-config.in 2008-03-28 22:02:53.000000000 +0100
++++ uuid-1.6.1/uuid-config.in 2008-03-28 22:03:06.000000000 +0100
+@@ -121,7 +121,7 @@
+ output_extra="$output_extra $uuid_ldflags"
+ ;;
+ --libs)
+- output="$output -luuid"
++ output="$output -lossp-uuid"
+ output_extra="$output_extra $uuid_libs"
+ ;;
+ * )
+diff -Naur uuid-1.6.1.orig/uuid.pc.in uuid-1.6.1/uuid.pc.in
+--- uuid-1.6.1.orig/uuid.pc.in 2008-03-28 22:02:53.000000000 +0100
++++ uuid-1.6.1/uuid.pc.in 2008-03-28 22:03:06.000000000 +0100
+@@ -36,7 +36,7 @@
+ Description: Universally Unique Identifier (UUID) Library
+ Version: @UUID_VERSION_RAW@
+ URL: http://www.ossp.org/pkg/lib/uuid/
+-Cflags: -I${includedir}
+-Libs: -L${libdir} -luuid
++Cflags: -I${includedir}/ossp
++Libs: -L${libdir} -lossp-uuid
+ Libs.private: @LIBS@
+
diff --git a/dev-libs/ossp-uuid/metadata.xml b/dev-libs/ossp-uuid/metadata.xml
new file mode 100644
index 000000000000..31c8b99f54a1
--- /dev/null
+++ b/dev-libs/ossp-uuid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-libs/ossp-uuid/ossp-uuid-1.6.1.ebuild b/dev-libs/ossp-uuid/ossp-uuid-1.6.1.ebuild
new file mode 100644
index 000000000000..29c4dcc72f00
--- /dev/null
+++ b/dev-libs/ossp-uuid/ossp-uuid-1.6.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ossp-uuid/ossp-uuid-1.6.1.ebuild,v 1.1 2008/03/28 23:45:48 dev-zero Exp $
+
+EAPI="1"
+
+PHP_EXT_NAME="uuid"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit eutils multilib php-ext-source-r1 depend.php
+
+MY_P="uuid-${PV}"
+
+DESCRIPTION="An ISO-C:1999 API and corresponding CLI for the generation of DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant UUID."
+HOMEPAGE="http://www.ossp.org/pkg/lib/uuid/"
+SRC_URI="ftp://ftp.ossp.org/pkg/lib/uuid/${MY_P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cxx php"
+
+DEPEND="php? ( dev-lang/php:5 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+need_php5_cli
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_compile() {
+ # Notes:
+ # * collides with e2fstools libs and includes if not moved around
+ # * perl-bindings are broken
+ # * pgsql-bindings need PostgreSQL-sources and are included since PostgreSQL 8.3
+ econf \
+ --includedir=/usr/include/ossp \
+ --with-dce \
+ --without-pgsql \
+ --without-perl \
+ --without-php \
+ $(use_with cxx) \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use php; then
+ cd php
+ php-ext-source-r1_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BINDINGS ChangeLog HISTORY NEWS OVERVIEW PORTING README SEEALSO THANKS TODO USERS
+
+ if use php ; then
+ cd php
+ php-ext-source-r1_src_install
+ insinto /usr/share/php5
+ newins uuid.php5 uuid.php
+ fi
+
+ mv "${D}/usr/$(get_libdir)/pkgconfig"/{,ossp-}uuid.pc
+ mv "${D}/usr/share/man/man3"/uuid.3{,ossp}
+ mv "${D}/usr/share/man/man3"/uuid++.3{,ossp}
+}
+
+src_test() {
+ emake check || die "emake check failed"
+ # Tests for the php-bindings would be available
+}