summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-11-07 22:34:50 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-11-07 22:34:50 +0000
commit0b913822c24f869a2e0dc4d7891e9ebf7e644cdf (patch)
tree83dc517c70fb23225de3e02a9869ae530bb6be9a /dev-libs/quantlib
parentStable on sparc (diff)
downloadhistorical-0b913822c24f869a2e0dc4d7891e9ebf7e644cdf.tar.gz
historical-0b913822c24f869a2e0dc4d7891e9ebf7e644cdf.tar.bz2
historical-0b913822c24f869a2e0dc4d7891e9ebf7e644cdf.zip
Version bump. Removed older version.
Package-Manager: portage-2.1.2_rc1-r1
Diffstat (limited to 'dev-libs/quantlib')
-rw-r--r--dev-libs/quantlib/ChangeLog9
-rw-r--r--dev-libs/quantlib/files/digest-quantlib-0.3.143
-rw-r--r--dev-libs/quantlib/quantlib-0.3.14.ebuild66
3 files changed, 77 insertions, 1 deletions
diff --git a/dev-libs/quantlib/ChangeLog b/dev-libs/quantlib/ChangeLog
index 63f6fd1dfed4..ff313f0ce6b0 100644
--- a/dev-libs/quantlib/ChangeLog
+++ b/dev-libs/quantlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/quantlib
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/ChangeLog,v 1.28 2006/10/30 19:33:23 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/ChangeLog,v 1.29 2006/11/07 22:34:50 dev-zero Exp $
+
+*quantlib-0.3.14 (07 Nov 2006)
+
+ 07 Nov 2006; Tiziano Müller <dev-zero@gentoo.org>
+ -files/0.3.13-boost_mt.patch, -files/0.3.13-destdir.patch,
+ -quantlib-0.3.13.ebuild, +quantlib-0.3.14.ebuild:
+ Version bump. Removed older version.
30 Oct 2006; Christian Faulhammer <opfer@gentoo.org>
quantlib-0.3.12.ebuild:
diff --git a/dev-libs/quantlib/files/digest-quantlib-0.3.14 b/dev-libs/quantlib/files/digest-quantlib-0.3.14
new file mode 100644
index 000000000000..adf302d39b8e
--- /dev/null
+++ b/dev-libs/quantlib/files/digest-quantlib-0.3.14
@@ -0,0 +1,3 @@
+MD5 0f9b75124cb5ac5dec4e5715498f3cc4 QuantLib-0.3.14.tar.gz 1881768
+RMD160 53829652e0f35d761a03c5b6fa1bd3aa3bef36ce QuantLib-0.3.14.tar.gz 1881768
+SHA256 ac4160ca19cf7d714b2273ee642cadfc4a563b452aa1ca6dc6f13c9321027f67 QuantLib-0.3.14.tar.gz 1881768
diff --git a/dev-libs/quantlib/quantlib-0.3.14.ebuild b/dev-libs/quantlib/quantlib-0.3.14.ebuild
new file mode 100644
index 000000000000..e164d9dbd8a3
--- /dev/null
+++ b/dev-libs/quantlib/quantlib-0.3.14.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/quantlib-0.3.14.ebuild,v 1.1 2006/11/07 22:34:50 dev-zero Exp $
+
+inherit autotools eutils
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+MY_P=QuantLib-${PV}
+DESCRIPTION="A comprehensive software framework for quantitative finance"
+HOMEPAGE="http://www.quantlib.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="BSD"
+IUSE="doc emacs examples"
+
+RDEPEND="dev-libs/boost"
+DEPEND="sys-devel/libtool
+ emacs? ( virtual/emacs )
+ doc? ( app-doc/doxygen )
+ ${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's/qlintro.tex quantlibheader.tex //' \
+ Docs/Makefile.in || die "sed failed"
+
+ eautoconf
+}
+
+src_compile() {
+ use emacs ||
+ sed -i -e "s/^EMACS=.*/EMACS=no/" configure || die "sed failed"
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc ; then
+ cd "${S}/Docs"
+ emake docs-online || die "emake docs-html failed"
+ fi
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc *.txt
+
+ if use doc ; then
+ cd "${S}/Docs"
+ dohtml html-online/*
+ fi
+
+ if use examples ; then
+ cd "${S}/Examples"
+ insinto /usr/share/doc/${PF}/examples
+ doins *.txt
+ for example in $(ls -d */); do
+ doins ${example%%/}/*.{cpp,h,txt}
+ done
+ fi
+}