summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-16 10:12:25 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-16 10:12:25 +0000
commit4baef3f2fe2775e51d1fde5258cd11cad64dd805 (patch)
tree8f1e8b7c24bfcc2678fb848e5a70c66cfafa2784 /dev-libs
parentFix slot-deps on gtk+ and other libs (diff)
downloadhistorical-4baef3f2fe2775e51d1fde5258cd11cad64dd805.tar.gz
historical-4baef3f2fe2775e51d1fde5258cd11cad64dd805.tar.bz2
historical-4baef3f2fe2775e51d1fde5258cd11cad64dd805.zip
Fix slot-deps on gtk+ and other libs
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgdata/ChangeLog6
-rw-r--r--dev-libs/libgdata/libgdata-0.6.4.ebuild10
-rw-r--r--dev-libs/libgdata/libgdata-0.6.5.ebuild8
-rw-r--r--dev-libs/libgdata/libgdata-0.6.6.ebuild4
-rw-r--r--dev-libs/libgdata/libgdata-0.8.0.ebuild4
-rw-r--r--dev-libs/libgweather/ChangeLog6
-rw-r--r--dev-libs/libgweather/libgweather-2.30.2.ebuild10
-rw-r--r--dev-libs/libgweather/libgweather-2.30.3.ebuild8
-rw-r--r--dev-libs/libunique/ChangeLog6
-rw-r--r--dev-libs/libunique/libunique-1.0.8.ebuild6
-rw-r--r--dev-libs/libunique/libunique-1.1.6.ebuild6
11 files changed, 43 insertions, 31 deletions
diff --git a/dev-libs/libgdata/ChangeLog b/dev-libs/libgdata/ChangeLog
index 02914bb15b40..2b1f5ca8f504 100644
--- a/dev-libs/libgdata/ChangeLog
+++ b/dev-libs/libgdata/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libgdata
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/ChangeLog,v 1.25 2011/03/12 15:47:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/ChangeLog,v 1.26 2011/03/16 10:11:45 nirbheek Exp $
+
+ 16 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> libgdata-0.6.4.ebuild,
+ libgdata-0.6.5.ebuild, libgdata-0.6.6.ebuild, libgdata-0.8.0.ebuild:
+ Fix slot-deps on gtk+ and other libs
12 Mar 2011; Raúl Porcel <armin76@gentoo.org> libgdata-0.8.0.ebuild:
alpha/arm/ia64/sparc stable wrt #353436
diff --git a/dev-libs/libgdata/libgdata-0.6.4.ebuild b/dev-libs/libgdata/libgdata-0.6.4.ebuild
index fada27cfbcf1..5e8429296eba 100644
--- a/dev-libs/libgdata/libgdata-0.6.4.ebuild
+++ b/dev-libs/libgdata/libgdata-0.6.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/libgdata-0.6.4.ebuild,v 1.12 2010/10/24 13:29:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/libgdata-0.6.4.ebuild,v 1.13 2011/03/16 10:11:45 nirbheek Exp $
EAPI="2"
@@ -15,9 +15,9 @@ KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
IUSE="doc gnome" # introspection
# gtk+ is needed for gdk
-RDEPEND=">=dev-libs/glib-2.19
- >=x11-libs/gtk+-2
- >=dev-libs/libxml2-2
+RDEPEND=">=dev-libs/glib-2.19:2
+ >=x11-libs/gtk+-2:2
+ >=dev-libs/libxml2-2:2
>=net-libs/libsoup-2.26.1:2.4
gnome? ( >=net-libs/libsoup-gnome-2.26.1:2.4 )"
DEPEND="${RDEPEND}
diff --git a/dev-libs/libgdata/libgdata-0.6.5.ebuild b/dev-libs/libgdata/libgdata-0.6.5.ebuild
index 03be15bb12b4..7b5ed855bc44 100644
--- a/dev-libs/libgdata/libgdata-0.6.5.ebuild
+++ b/dev-libs/libgdata/libgdata-0.6.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/libgdata-0.6.5.ebuild,v 1.2 2010/10/24 13:29:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/libgdata-0.6.5.ebuild,v 1.3 2011/03/16 10:11:45 nirbheek Exp $
EAPI="3"
GCONF_DEBUG="yes"
@@ -16,9 +16,9 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc gnome +introspection"
# gtk+ is needed for gdk
-RDEPEND=">=dev-libs/glib-2.19
+RDEPEND=">=dev-libs/glib-2.19:2
>=x11-libs/gtk+-2:2
- >=dev-libs/libxml2-2
+ >=dev-libs/libxml2-2:2
>=net-libs/libsoup-2.26.1:2.4
gnome? ( >=net-libs/libsoup-gnome-2.26.1:2.4 )
introspection? ( >=dev-libs/gobject-introspection-0.9.7 )"
diff --git a/dev-libs/libgdata/libgdata-0.6.6.ebuild b/dev-libs/libgdata/libgdata-0.6.6.ebuild
index c7201502c671..d63cf73d0b10 100644
--- a/dev-libs/libgdata/libgdata-0.6.6.ebuild
+++ b/dev-libs/libgdata/libgdata-0.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/libgdata-0.6.6.ebuild,v 1.2 2011/01/23 17:35:17 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/libgdata-0.6.6.ebuild,v 1.3 2011/03/16 10:11:45 nirbheek Exp $
EAPI="3"
GCONF_DEBUG="yes"
@@ -18,7 +18,7 @@ IUSE="doc gnome +introspection"
# gtk+ is needed for gdk
RDEPEND=">=dev-libs/glib-2.19:2
>=x11-libs/gtk+-2:2
- >=dev-libs/libxml2-2
+ >=dev-libs/libxml2-2:2
>=net-libs/libsoup-2.26.1:2.4
gnome? ( >=net-libs/libsoup-gnome-2.26.1:2.4 )
introspection? ( >=dev-libs/gobject-introspection-0.9.7 )"
diff --git a/dev-libs/libgdata/libgdata-0.8.0.ebuild b/dev-libs/libgdata/libgdata-0.8.0.ebuild
index 5797e725840c..28b3e63fd7af 100644
--- a/dev-libs/libgdata/libgdata-0.8.0.ebuild
+++ b/dev-libs/libgdata/libgdata-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/libgdata-0.8.0.ebuild,v 1.5 2011/03/12 15:47:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/libgdata-0.8.0.ebuild,v 1.6 2011/03/16 10:11:45 nirbheek Exp $
EAPI="3"
GCONF_DEBUG="yes"
@@ -20,7 +20,7 @@ RDEPEND=">=dev-libs/glib-2.19:2
|| (
>=x11-libs/gdk-pixbuf-2.14:2
>=x11-libs/gtk+-2.14:2 )
- >=dev-libs/libxml2-2
+ >=dev-libs/libxml2-2:2
>=net-libs/libsoup-2.26.1:2.4[introspection?]
gnome? ( >=net-libs/libsoup-gnome-2.26.1:2.4[introspection?] )
introspection? ( >=dev-libs/gobject-introspection-0.9.7 )"
diff --git a/dev-libs/libgweather/ChangeLog b/dev-libs/libgweather/ChangeLog
index fd9d24915227..adb1b2f7f960 100644
--- a/dev-libs/libgweather/ChangeLog
+++ b/dev-libs/libgweather/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libgweather
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.74 2011/01/30 18:01:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.75 2011/03/16 10:12:04 nirbheek Exp $
+
+ 16 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ libgweather-2.30.2.ebuild, libgweather-2.30.3.ebuild:
+ Fix slot-deps on gtk+ and other libs
30 Jan 2011; Raúl Porcel <armin76@gentoo.org> libgweather-2.30.3.ebuild:
alpha/arm/ia64/sh/sparc stable wrt #348987
diff --git a/dev-libs/libgweather/libgweather-2.30.2.ebuild b/dev-libs/libgweather/libgweather-2.30.2.ebuild
index b4105e08905b..5df80c2cfa3a 100644
--- a/dev-libs/libgweather/libgweather-2.30.2.ebuild
+++ b/dev-libs/libgweather/libgweather-2.30.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-2.30.2.ebuild,v 1.10 2011/01/15 19:53:39 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-2.30.2.ebuild,v 1.11 2011/03/16 10:12:04 nirbheek Exp $
EAPI="2"
GCONF_DEBUG="no"
@@ -17,11 +17,11 @@ IUSE="python doc"
# libsoup-gnome is to be used because libsoup[gnome] might not
# get libsoup-gnome installed by the time ${P} is built
-RDEPEND=">=x11-libs/gtk+-2.11
- >=dev-libs/glib-2.13
- >=gnome-base/gconf-2.8
+RDEPEND=">=x11-libs/gtk+-2.11:2
+ >=dev-libs/glib-2.13:2
+ >=gnome-base/gconf-2.8:2
>=net-libs/libsoup-gnome-2.25.1:2.4
- >=dev-libs/libxml2-2.6.0
+ >=dev-libs/libxml2-2.6.0:2
python? (
>=dev-python/pygobject-2
>=dev-python/pygtk-2 )
diff --git a/dev-libs/libgweather/libgweather-2.30.3.ebuild b/dev-libs/libgweather/libgweather-2.30.3.ebuild
index 5fd860da32cc..0144497a1720 100644
--- a/dev-libs/libgweather/libgweather-2.30.3.ebuild
+++ b/dev-libs/libgweather/libgweather-2.30.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-2.30.3.ebuild,v 1.7 2011/01/30 18:01:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-2.30.3.ebuild,v 1.8 2011/03/16 10:12:05 nirbheek Exp $
EAPI="2"
GCONF_DEBUG="no"
@@ -19,10 +19,10 @@ IUSE="python doc"
# libsoup-gnome is to be used because libsoup[gnome] might not
# get libsoup-gnome installed by the time ${P} is built
RDEPEND=">=x11-libs/gtk+-2.11:2
- >=dev-libs/glib-2.13
- >=gnome-base/gconf-2.8
+ >=dev-libs/glib-2.13:2
+ >=gnome-base/gconf-2.8:2
>=net-libs/libsoup-gnome-2.25.1:2.4
- >=dev-libs/libxml2-2.6.0
+ >=dev-libs/libxml2-2.6.0:2
>=sys-libs/timezone-data-2010k
python? (
>=dev-python/pygobject-2
diff --git a/dev-libs/libunique/ChangeLog b/dev-libs/libunique/ChangeLog
index 938bacc9067f..ae881db421e1 100644
--- a/dev-libs/libunique/ChangeLog
+++ b/dev-libs/libunique/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libunique
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libunique/ChangeLog,v 1.35 2011/02/09 21:06:42 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libunique/ChangeLog,v 1.36 2011/03/16 10:12:25 nirbheek Exp $
+
+ 16 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ libunique-1.0.8.ebuild, libunique-1.1.6.ebuild:
+ Fix slot-deps on gtk+ and other libs
09 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
libunique-1.0.8.ebuild, libunique-1.1.6.ebuild:
diff --git a/dev-libs/libunique/libunique-1.0.8.ebuild b/dev-libs/libunique/libunique-1.0.8.ebuild
index 81bc066775f2..c1ffb4cb41f1 100644
--- a/dev-libs/libunique/libunique-1.0.8.ebuild
+++ b/dev-libs/libunique/libunique-1.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libunique/libunique-1.0.8.ebuild,v 1.20 2011/02/09 21:06:42 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libunique/libunique-1.0.8.ebuild,v 1.21 2011/03/16 10:12:25 nirbheek Exp $
EAPI="2"
@@ -14,8 +14,8 @@ SLOT="1"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-solaris"
IUSE="dbus debug doc"
-RDEPEND=">=dev-libs/glib-2.12.0
- >=x11-libs/gtk+-2.11.0
+RDEPEND=">=dev-libs/glib-2.12.0:2
+ >=x11-libs/gtk+-2.11.0:2
x11-libs/libX11
dbus? ( >=dev-libs/dbus-glib-0.70 )"
DEPEND="${RDEPEND}
diff --git a/dev-libs/libunique/libunique-1.1.6.ebuild b/dev-libs/libunique/libunique-1.1.6.ebuild
index 9d86282614fd..c679fa809085 100644
--- a/dev-libs/libunique/libunique-1.1.6.ebuild
+++ b/dev-libs/libunique/libunique-1.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libunique/libunique-1.1.6.ebuild,v 1.14 2011/02/09 21:06:42 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libunique/libunique-1.1.6.ebuild,v 1.15 2011/03/16 10:12:25 nirbheek Exp $
EAPI="2"
@@ -14,8 +14,8 @@ SLOT="1"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-solaris"
IUSE="dbus doc +introspection"
-RDEPEND=">=dev-libs/glib-2.12
- >=x11-libs/gtk+-2.11[introspection?]
+RDEPEND=">=dev-libs/glib-2.12:2
+ >=x11-libs/gtk+-2.11:2[introspection?]
x11-libs/libX11
dbus? ( >=dev-libs/dbus-glib-0.70 )"
DEPEND="${RDEPEND}