summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-08-07 05:22:07 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-08-07 05:22:07 +0000
commitf814f98b0a509631ada900f255081c0bbff16efd (patch)
tree1f7f1eb0a2f3ee5a465827f92ae70df512140fa4 /dev-lisp/cmucl
parentdev-lisp/cl-rsm-gen-prog (diff)
downloadhistorical-f814f98b0a509631ada900f255081c0bbff16efd.tar.gz
historical-f814f98b0a509631ada900f255081c0bbff16efd.tar.bz2
historical-f814f98b0a509631ada900f255081c0bbff16efd.zip
boo-ya ka-sha!
Diffstat (limited to 'dev-lisp/cmucl')
-rw-r--r--dev-lisp/cmucl/Manifest18
-rw-r--r--dev-lisp/cmucl/cmucl-19a.ebuild112
-rw-r--r--dev-lisp/cmucl/files/19a/README.Gentoo31
-rw-r--r--dev-lisp/cmucl/files/19a/herald-save.lisp-gentoo.patch19
-rw-r--r--dev-lisp/cmucl/files/19a/install-clc.lisp55
-rw-r--r--dev-lisp/cmucl/files/19a/site-init.lisp.in58
-rw-r--r--dev-lisp/cmucl/files/digest-cmucl-19a3
7 files changed, 288 insertions, 8 deletions
diff --git a/dev-lisp/cmucl/Manifest b/dev-lisp/cmucl/Manifest
index 8b973b6d0b90..4e47b62765a5 100644
--- a/dev-lisp/cmucl/Manifest
+++ b/dev-lisp/cmucl/Manifest
@@ -1,16 +1,18 @@
-MD5 8f0849ab792a63ef81e036ee02f636e6 cmucl-18e-r2.ebuild 3195
MD5 b93215965e34d54ca6e9fd5431bac594 cmucl-18e-r4.ebuild 2888
+MD5 4ff684176feb40c39ed5d5929f1422cb cmucl-19a.ebuild 3081
MD5 637141c1d7519ba02ab16ba8073f86f4 cmucl-18e-r1.ebuild 3327
-MD5 485e34143c90280ddfaacdc2309ffe35 cmucl-18e.ebuild 2669
-MD5 294fa84eedbaa4115ecc5c47200f48cc ChangeLog 1746
MD5 29904b2e98286ec168bc9c87b0f3b0ac cmucl-18e-r3.ebuild 3411
+MD5 8f0849ab792a63ef81e036ee02f636e6 cmucl-18e-r2.ebuild 3195
+MD5 294fa84eedbaa4115ecc5c47200f48cc ChangeLog 1746
+MD5 485e34143c90280ddfaacdc2309ffe35 cmucl-18e.ebuild 2669
MD5 929688a2167434e2a4f0169de47e7428 metadata.xml 1107
-MD5 3e3791768309ef2b15c4e342b300980b files/digest-cmucl-18e 205
-MD5 3e3791768309ef2b15c4e342b300980b files/digest-cmucl-18e-r1 205
-MD5 df309c5d109052b9c57d79bb4aac5871 files/digest-cmucl-18e-r2 137
MD5 df309c5d109052b9c57d79bb4aac5871 files/digest-cmucl-18e-r3 137
+MD5 3e3791768309ef2b15c4e342b300980b files/digest-cmucl-18e 205
MD5 df309c5d109052b9c57d79bb4aac5871 files/digest-cmucl-18e-r4 137
+MD5 e42b98430cb83b99c437195f3667196d files/digest-cmucl-19a 239
+MD5 df309c5d109052b9c57d79bb4aac5871 files/digest-cmucl-18e-r2 137
+MD5 3e3791768309ef2b15c4e342b300980b files/digest-cmucl-18e-r1 205
+MD5 997a2bfdcd98bc978f6c3b79ba8f2264 files/18e/README.Gentoo 848
+MD5 190f38f6f6f33f3e1ceee848d2583573 files/18e/site-init.lisp.in 1935
MD5 379cf3aca883a7097c0410f96be55378 files/18e/install-clc.lisp-gentoo.patch 1294
MD5 306ba9e5615290fb688a46f7c0efdc07 files/18e/herald-save.lisp-gentoo.patch 751
-MD5 190f38f6f6f33f3e1ceee848d2583573 files/18e/site-init.lisp.in 1935
-MD5 997a2bfdcd98bc978f6c3b79ba8f2264 files/18e/README.Gentoo 848
diff --git a/dev-lisp/cmucl/cmucl-19a.ebuild b/dev-lisp/cmucl/cmucl-19a.ebuild
new file mode 100644
index 000000000000..d5604f24da21
--- /dev/null
+++ b/dev-lisp/cmucl/cmucl-19a.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-19a.ebuild,v 1.1 2004/08/07 05:22:07 mkennedy Exp $
+
+inherit common-lisp-common eutils
+
+DEB_PV=1
+MY_PV=${PV}-release-20040728
+
+DESCRIPTION="CMU Common Lisp is an implementation of ANSI Common Lisp"
+HOMEPAGE="http://www.cons.org/cmucl/
+ http://packages.debian.org/unstable/devel/cmucl.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${MY_PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${MY_PV}-${DEB_PV}.diff.gz
+ ftp://ftp.common-lisp.net/pub/project/cmucl/release/${PV}/${PN}-${PV}-x86-linux.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc lesstif"
+
+DEPEND="dev-lisp/common-lisp-controller
+ doc? ( virtual/tetex )
+ lesstif? ( x11-libs/lesstif )
+ !lesstif? ( x11-libs/openmotif )"
+
+PROVIDE="virtual/commonlisp"
+
+S=${WORKDIR}/cmucl-${MY_PV}.orig
+
+src_unpack() {
+ unpack ${A}
+ epatch cmucl_${MY_PV}-${DEB_PV}.diff
+ epatch ${FILESDIR}/${PV}/herald-save.lisp-gentoo.patch
+}
+
+src_compile() {
+ # non-x86 maintainers, add to the the following and verify
+
+ if use lesstif || test -d /usr/X11R6/include/lesstif; then
+ sed -i -e 's,-I/usr/X11R6/include,-I/usr/X11R6/include/lesstif,g' \
+ -e 's,-L/usr/X11R6/lib,-L/usr/X11R6/lib/lesstif -L/usr/X11R6/lib,g' \
+ src/motif/server/Config.x86
+ fi
+
+ PATH=${WORKDIR}/bin:$PATH CMUCLCORE=${WORKDIR}/lib/cmucl/lib/lisp.core make || die
+
+ if use doc; then
+ make -C src/docs
+ fi
+}
+
+src_install() {
+ insinto /usr/lib/cmucl/include
+ doins src/lisp/*.h target/lisp/*.h target/lisp/*.map target/lisp/*.nm
+ insinto /usr/lib/cmucl
+ cp target/lisp/lisp.core lisp-dist.core
+ doins lisp-dist.core
+
+ dodoc target/lisp/lisp.{nm,map}
+ doman src/general-info/{cmucl,lisp}.1
+
+ dobin target/lisp/lisp
+ dobin own-work/Demos/lisp-start
+
+ insinto /usr/lib/cmucl
+ doins ${FILESDIR}/${PV}/install-clc.lisp
+ exeinto /usr/lib/common-lisp/bin
+ cp own-work/cmucl-script.sh cmucl.sh
+ doexe cmucl.sh
+
+ insinto /etc/common-lisp/cmucl
+ sed "s,@PF@,${PF},g" <${FILESDIR}/${PV}/site-init.lisp.in >site-init.lisp
+ doins site-init.lisp
+ dosym /etc/common-lisp/cmucl/site-init.lisp /usr/lib/cmucl/site-init.lisp
+
+ dodir /etc/env.d
+ cat >${D}/etc/env.d/50cmucl <<EOF
+# CMUCLLIB=/usr/lib/cmucl
+EOF
+ [ -f /etc/lisp-config.lisp ] || touch ${D}/etc/lisp-config.lisp
+
+ insinto /usr/share/doc/${P}/html/Basic-tutorial
+ doins own-work/tutorials/Basic-tutorial/*
+ insinto /usr/share/doc/${P}/html/Clos
+ doins own-work/tutorials/Clos/*
+ docinto notes
+ dodoc own-work/tutorials/notes/*
+
+ insinto /usr/lib/cmucl
+ doins own-work/hemlock11.*
+
+ if use doc; then
+ dodoc src/docs/*/*.{ps,pdf}
+ fi
+
+ exeinto /usr/lib/cmucl
+ doexe target/motif/server/motifd
+ insinto /usr/lib/cmucl/subsystems/
+ doins target/interface/clm-library.x86f
+
+ keepdir /usr/lib/common-lisp/cmucl
+ impl-save-timestamp-hack cmucl || die
+}
+
+pkg_postinst() {
+ standard-impl-postinst cmucl
+}
+
+pkg_prerm() {
+ standard-impl-postrm cmucl /usr/bin/lisp
+}
diff --git a/dev-lisp/cmucl/files/19a/README.Gentoo b/dev-lisp/cmucl/files/19a/README.Gentoo
new file mode 100644
index 000000000000..885807587fb5
--- /dev/null
+++ b/dev-lisp/cmucl/files/19a/README.Gentoo
@@ -0,0 +1,31 @@
+
+* README.Gentoo -- Gentoo Specific Notes for dev-lisp/cmucl
+
+** About dev-lisp/cmucl
+
+The dev-lisp/cmucl ebuild in portage aim to provide a port of
+Debian's package of CMUCL. Thus the Gentoo CMUCL port should be
+binary compatible with the Debian port.
+
+** Linux Miscellaneous Binary Support
+
+You can have your compiled Lisp .x86f files automatically executed
+like any other binary by executing the following command:
+
+ echo ':lisp:E::x86f::/usr/bin/lisp-start:' \
+ >/proc/sys/fs/binfmt_misc/register
+
+Note: you need kernel support for this. A good place to put the
+above command is in your /etc/conf.d/localstart.
+
+** Credit
+
+This Gentoo package, like many other Gentoo packages in the dev-lisp
+category, benifit from the Debian Project's work.
+
+ -- Matthew Kennedy <mkennedy@gentoo.org>
+
+
+Local Variables: ***
+mode: outline ***
+End: ***
diff --git a/dev-lisp/cmucl/files/19a/herald-save.lisp-gentoo.patch b/dev-lisp/cmucl/files/19a/herald-save.lisp-gentoo.patch
new file mode 100644
index 000000000000..b1a54bfb3ceb
--- /dev/null
+++ b/dev-lisp/cmucl/files/19a/herald-save.lisp-gentoo.patch
@@ -0,0 +1,19 @@
+diff -ur cmucl-19a-release-20040728.orig.orig/src/code/save.lisp cmucl-19a-release-20040728.orig/src/code/save.lisp
+--- cmucl-19a-release-20040728.orig.orig/src/code/save.lisp 2004-06-29 16:24:46.000000000 -0500
++++ cmucl-19a-release-20040728.orig/src/code/save.lisp 2004-08-03 11:18:05.286348696 -0500
+@@ -289,11 +289,9 @@
+ ))
+
+ (setf (getf *herald-items* :bugs)
+- '("For support see http://www.cons.org/cmucl/support.html Send bug reports to the debian BTS."
+- terpri
+- "or to "
+- "pvaneynd@debian.org" terpri
+- "type (help) for help, (quit) to exit, and (demo) to see the demos" terpri
++ '("For support see http://www.cons.org/cmucl/support.html" terpri
++ "Send bug reports to http://bugs.gentoo.org" terpri
++ "Type (help) for help or (quit) to exit." terpri
+ terpri
+ "Loaded subsystems:"))
+
+Only in cmucl-19a-release-20040728.orig/src/code: save.lisp~
diff --git a/dev-lisp/cmucl/files/19a/install-clc.lisp b/dev-lisp/cmucl/files/19a/install-clc.lisp
new file mode 100644
index 000000000000..23642b16ffee
--- /dev/null
+++ b/dev-lisp/cmucl/files/19a/install-clc.lisp
@@ -0,0 +1,55 @@
+;;; -*- Mode: LISP; Package: CL-USER -*-
+;;;
+;;; Copyright Peter Van Eynde, 2001
+;;;
+;;; License: LGPL v2
+;;;
+(in-package "COMMON-LISP-USER")
+
+(unless (ignore-errors
+ (load "/usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp"))
+ (unix:unix-exit 1))
+
+;; (unless (ignore-errors
+ (common-lisp-controller:init-common-lisp-controller
+ "/usr/lib/common-lisp/cmucl/"
+ :version 3)
+;; t)
+;; (format t "~%Error during init of common-lisp-controller~%")
+;; (unix:unix-exit 1))
+
+(in-package :common-lisp-controller)
+
+(defun send-clc-command (command package)
+ (let ((process
+ (ext:run-program "/usr/bin/clc-send-command"
+ (list
+ (ecase command
+ (:recompile "recompile")
+ (:remove "remove"))
+ (format nil "~A" package)
+ "cmucl"
+ "--quiet")
+ :wait t)))
+ (if (= (ext:process-exit-code process)
+ 0)
+ ;; no error
+ (values)
+ (error "An error happend during ~A of ~A for ~A~%Please see /usr/share/doc/common-lisp-controller/REPORTING-BUGS.gz"
+ (ecase command
+ (:recompile "recompilation")
+ (:remove "removal"))
+ package
+ "cmucl"))))
+
+(in-package "COMMON-LISP-USER")
+
+(unless (ignore-errors
+ ;; it loaded, configure it for common-lisp-controller use:
+ (format t "~%Saving to new-lisp.core...")
+ (ext:gc :full t)
+ (setf ext:*batch-mode* nil)
+ (ext:save-lisp "new-lisp.core"
+ :purify t))
+ (unix:unix-exit 1))
+
diff --git a/dev-lisp/cmucl/files/19a/site-init.lisp.in b/dev-lisp/cmucl/files/19a/site-init.lisp.in
new file mode 100644
index 000000000000..ad145414ca43
--- /dev/null
+++ b/dev-lisp/cmucl/files/19a/site-init.lisp.in
@@ -0,0 +1,58 @@
+;;; -*- Mode: Lisp; Package: System -*-
+;;;
+;;; **********************************************************************
+;;; This code was written as part of the CMU Common Lisp project at
+;;; Carnegie Mellon University, and has been placed in the public domain.
+;;;
+
+;;; Heavy modifications by Peter Van Eynde
+
+;;; More modifications for Gentoo by Matthew Kennedy
+;;; <mkennedy@gentoo.org>
+
+(in-package "SYSTEM")
+
+(if (probe-file "/etc/lisp-config.lisp")
+ (load "/etc/lisp-config.lisp")
+ (format t "~%;;; Warning: There is no /etc/lisp-config.lisp file (which should have been created during emerge"))
+
+;;; If you have sources installed on your system, un-comment the following form
+;;; and change it to point to the source location. This will allow the Hemlock
+;;; "Edit Definition" command and the debugger to find sources for functions in
+;;; the core.
+(setf (ext:search-list "target:")
+ '(
+ "/usr/share/common-lisp/source/cmucl/" ; object dir
+ ))
+
+(setf (ext:search-list "library:") '("/usr/lib/cmucl/"))
+;;; for safety...
+
+;;; optional extentions to the lisp image: delete if you
+;;; don't like them :-).
+(in-package :common-lisp-user)
+
+;;; newbie functions, delete if you don't like them
+
+(defun help ()
+ (format t "~
+Welcome to the Gentoo GNU/Linux port of CMUCL.
+
+If you aren't running this with ILISP (see: app-emacs/ilisp or
+app-xemacs/ilisp) in Emacs, or don't intend to use Hemlock
+(see: dev-lisp/cmucl-source) then you deserve to lose. :-)
+
+The CMUCL REPL does not have GNU Readline-like support, however
+you may wish to install rlwap (see: app-misc/rlwrap) to achieve
+the same effect.
+
+If you think you found a bug, please use http://bugs.gentoo.org
+
+Read the documentation in /usr/share/doc/@PF@.
+
+(quit) exit Lisp
+(describe 'foo) gives information about foo
+(inspect '*foo*) interactively inspects *foo*
+(apropos \"foo\") briefly describe all symbols which match \"foo\"
+"))
+
diff --git a/dev-lisp/cmucl/files/digest-cmucl-19a b/dev-lisp/cmucl/files/digest-cmucl-19a
new file mode 100644
index 000000000000..02081ab3d5fa
--- /dev/null
+++ b/dev-lisp/cmucl/files/digest-cmucl-19a
@@ -0,0 +1,3 @@
+MD5 6b37fe4815935af73f0efd1312e6a969 cmucl_19a-release-20040728.orig.tar.gz 4456803
+MD5 a1b0e25d77646e6f83a0c723f2e46b14 cmucl_19a-release-20040728-1.diff.gz 1500168
+MD5 8d2afba837c28149944d3edd02af8b86 cmucl-19a-x86-linux.tar.bz2 7237512