summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-11-23 17:37:26 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-11-23 17:37:26 +0000
commit66b34aa4b92175e8ce2a41a6e866b31016480960 (patch)
tree0d9b25613542fd4b11bb15931d12b9bc44d215f2 /dev-lisp/ecls
parentadd missing pycrypto dependency (diff)
downloadhistorical-66b34aa4b92175e8ce2a41a6e866b31016480960.tar.gz
historical-66b34aa4b92175e8ce2a41a6e866b31016480960.tar.bz2
historical-66b34aa4b92175e8ce2a41a6e866b31016480960.zip
New upstream version; Removed old ebuilds.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-lisp/ecls')
-rw-r--r--dev-lisp/ecls/ecls-0.9h.ebuild (renamed from dev-lisp/ecls/ecls-0.9f_p1.ebuild)6
-rw-r--r--dev-lisp/ecls/files/0.9f_p1-headers-gentoo.patch36
-rw-r--r--dev-lisp/ecls/files/0.9h-headers-gentoo.patch36
-rw-r--r--dev-lisp/ecls/files/digest-ecls-0.9f_p11
-rw-r--r--dev-lisp/ecls/files/digest-ecls-0.9h1
5 files changed, 40 insertions, 40 deletions
diff --git a/dev-lisp/ecls/ecls-0.9f_p1.ebuild b/dev-lisp/ecls/ecls-0.9h.ebuild
index 0d36c3346817..dda51324df75 100644
--- a/dev-lisp/ecls/ecls-0.9f_p1.ebuild
+++ b/dev-lisp/ecls/ecls-0.9h.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9f_p1.ebuild,v 1.3 2005/06/07 01:44:37 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9h.ebuild,v 1.1 2005/11/23 17:35:06 mkennedy Exp $
inherit eutils
DESCRIPTION="ECL is an embeddable Common Lisp implementation."
-SRC_URI="mirror://sourceforge/ecls/ecl-${PV:0:4}-patch-${PV:6}.tgz"
+SRC_URI="mirror://sourceforge/ecls/ecl-${PV}.tgz"
HOMEPAGE="http://ecls.sourceforge.net/"
SLOT="0"
LICENSE="BSD LGPL-2"
-KEYWORDS="x86 ~ppc ~amd64 ~sparc"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
DEPEND="X? ( virtual/x11 )
=dev-libs/gmp-4*
diff --git a/dev-lisp/ecls/files/0.9f_p1-headers-gentoo.patch b/dev-lisp/ecls/files/0.9f_p1-headers-gentoo.patch
deleted file mode 100644
index a2c4911b0ff6..000000000000
--- a/dev-lisp/ecls/files/0.9f_p1-headers-gentoo.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --exclude 'Makefile*' --exclude '*~' -ur ecl-0.9f.orig/src/h/ecl.h ecl-0.9f/src/h/ecl.h
---- ecl-0.9f.orig/src/h/ecl.h 2004-11-29 18:46:38.000000000 -0600
-+++ ecl-0.9f/src/h/ecl.h 2004-11-29 21:13:29.099069235 -0600
-@@ -13,6 +13,9 @@
- See file '../Copyright' for full details.
- */
-
-+#ifndef __ECL_H__
-+#define __ECL_H__
-+
- #ifndef _MSC_VER
- #include <sys/param.h> /* includes <sys/signal.h> and <sys/types.h> */
- #else
-@@ -54,3 +57,5 @@
- #ifdef LOCATIVE
- #include <unify.h>
- #endif
-+
-+#endif
-diff --exclude 'Makefile*' --exclude '*~' -ur ecl-0.9f.orig/src/h/object.h ecl-0.9f/src/h/object.h
---- ecl-0.9f.orig/src/h/object.h 2004-11-29 18:46:38.000000000 -0600
-+++ ecl-0.9f/src/h/object.h 2004-11-29 21:13:07.333474284 -0600
-@@ -22,8 +22,13 @@
- Integer and boolean types (see config.h)
- */
-
-+#ifndef TRUE
- #define TRUE 1 /* boolean true value */
-+#endif
-+
-+#ifndef FALSE
- #define FALSE 0 /* boolean false value */
-+#endif
-
- #define CHAR_CODE_LIMIT 256 /* ASCII character code limit */
-
diff --git a/dev-lisp/ecls/files/0.9h-headers-gentoo.patch b/dev-lisp/ecls/files/0.9h-headers-gentoo.patch
new file mode 100644
index 000000000000..0e08ec9e1040
--- /dev/null
+++ b/dev-lisp/ecls/files/0.9h-headers-gentoo.patch
@@ -0,0 +1,36 @@
+diff -ur ecl-0.9h.orig/src/h/ecl.h ecl-0.9h/src/h/ecl.h
+--- ecl-0.9h.orig/src/h/ecl.h 2005-08-12 11:26:42.000000000 -0500
++++ ecl-0.9h/src/h/ecl.h 2005-08-13 13:10:59.000000000 -0500
+@@ -13,6 +13,9 @@
+ See file '../Copyright' for full details.
+ */
+
++#ifndef __ECL_H__
++#define __ECL_H__
++
+ #ifndef _MSC_VER
+ #include <sys/param.h> /* includes <sys/signal.h> and <sys/types.h> */
+ #else
+@@ -69,3 +72,5 @@
+ #endif
+
+ typedef void (*ecl_init_function_t)(cl_object block);
++
++#endif
+diff -ur ecl-0.9h.orig/src/h/object.h ecl-0.9h/src/h/object.h
+--- ecl-0.9h.orig/src/h/object.h 2005-08-12 11:26:42.000000000 -0500
++++ ecl-0.9h/src/h/object.h 2005-08-13 13:18:03.000000000 -0500
+@@ -22,8 +22,13 @@
+ Integer and boolean types (see config.h)
+ */
+
++#ifndef TRUE
+ #define TRUE 1 /* boolean true value */
++#endif
++
++#ifndef FALSE
+ #define FALSE 0 /* boolean false value */
++#endif
+
+ #define CHAR_CODE_LIMIT 256 /* ASCII character code limit */
+
diff --git a/dev-lisp/ecls/files/digest-ecls-0.9f_p1 b/dev-lisp/ecls/files/digest-ecls-0.9f_p1
deleted file mode 100644
index 977f3eed7f23..000000000000
--- a/dev-lisp/ecls/files/digest-ecls-0.9f_p1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8e11f1aff5ec25b042859fea207fff91 ecl-0.9f-patch-1.tgz 4305574
diff --git a/dev-lisp/ecls/files/digest-ecls-0.9h b/dev-lisp/ecls/files/digest-ecls-0.9h
new file mode 100644
index 000000000000..8af0a8549c2d
--- /dev/null
+++ b/dev-lisp/ecls/files/digest-ecls-0.9h
@@ -0,0 +1 @@
+MD5 d02ae5ce7fa48fe534666ce853aaa27e ecl-0.9h.tgz 4324629