summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-19 12:49:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-19 12:49:26 +0000
commit778485411e86b8d7c7d9b3844e89efefbb48e118 (patch)
treeb3159ed3445adb944469dacf2dec00a6909a9548 /dev-ml/bin-prot
parentamd64/x86 stable, bug #285403 (diff)
downloadhistorical-778485411e86b8d7c7d9b3844e89efefbb48e118.tar.gz
historical-778485411e86b8d7c7d9b3844e89efefbb48e118.tar.bz2
historical-778485411e86b8d7c7d9b3844e89efefbb48e118.zip
Initial import, ebuild by Guillaume Horel <guillaume.horel@gmail.com>, bug #281276
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/bin-prot')
-rw-r--r--dev-ml/bin-prot/ChangeLog11
-rw-r--r--dev-ml/bin-prot/Manifest14
-rw-r--r--dev-ml/bin-prot/bin-prot-1.2.18.ebuild44
-rw-r--r--dev-ml/bin-prot/metadata.xml5
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-ml/bin-prot/ChangeLog b/dev-ml/bin-prot/ChangeLog
new file mode 100644
index 000000000000..a65bb35f6a24
--- /dev/null
+++ b/dev-ml/bin-prot/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/bin-prot
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.1 2009/09/19 12:49:26 aballier Exp $
+
+*bin-prot-1.2.18 (19 Sep 2009)
+
+ 19 Sep 2009; Alexis Ballier <aballier@gentoo.org> +bin-prot-1.2.18.ebuild,
+ +metadata.xml:
+ Initial import, ebuild by Guillaume Horel <guillaume.horel@gmail.com>, bug
+ #281276
+
diff --git a/dev-ml/bin-prot/Manifest b/dev-ml/bin-prot/Manifest
new file mode 100644
index 000000000000..0d96916b8a59
--- /dev/null
+++ b/dev-ml/bin-prot/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST bin-prot-1.2.18.tar.gz 78720 RMD160 16a5fb8d144ebf45e3e0b7498dd4d720d937504d SHA1 171ad8eb593447977451eb7bed87acbc31118d3d SHA256 e782de67fd2bc7e2400209a1fd354b785e331d1abc06b6e0f85c3ac8f7850ef9
+EBUILD bin-prot-1.2.18.ebuild 1016 RMD160 218ac64fd687cfe570da5b98c459baa2fb0cce6d SHA1 80545db9d261859ab547b899cbb8b9c38af7501a SHA256 64922bc7bc77189df5e3e471b2290057e1d5cb1c4102d0d138446755d32d1ba1
+MISC ChangeLog 419 RMD160 0dc928cf900895cf44d7247a9385fc9a9a2073f5 SHA1 06ca82e36d2c72ab69b2e0c0e65d58072c06cea6 SHA256 d6e2dc7fafced5f5f999f5aa1c3a5fa44d9c369f0523310808dbe3bddc43525d
+MISC metadata.xml 155 RMD160 dfaa057e679b01302a807c75a32a910098b26809 SHA1 94024f83dcacbb53e92be090dd0f994ec93dc90d SHA256 118048376ebb76f57628b0819f3de4856e73959c2578c88715d37ea2d1e0af81
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAkq001wACgkQvFcC4BYPU0rLkQCglkxmbMhZ2KQKvWFeWZYLivcp
+cZ4An1myc+WQE0S+Iew6vJ3Z/q+iqaHT
+=ubpb
+-----END PGP SIGNATURE-----
diff --git a/dev-ml/bin-prot/bin-prot-1.2.18.ebuild b/dev-ml/bin-prot/bin-prot-1.2.18.ebuild
new file mode 100644
index 000000000000..16c49a909112
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-1.2.18.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-1.2.18.ebuild,v 1.1 2009/09/19 12:49:26 aballier Exp $
+
+EAPI="2"
+
+inherit findlib
+
+DESCRIPTION="Automated code generation for converting OCaml values to/from a type-safe binary protocol"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+S=${WORKDIR}/${P}/lib
+
+RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt]
+ dev-ml/type-conv"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )
+ doc? ( virtual/latex-base )"
+
+src_compile() {
+ emake -j1 CFLAGS="${CFLAGS}" || die
+}
+
+src_test() {
+ cd "${S}/../lib_test"
+ emake -j1 || die
+ ./test_runner || die
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die "make install failed"
+ dodoc ../README.txt ../Changelog
+ if use doc; then
+ cd ../doc
+ pdflatex README.tex
+ dodoc README.pdf
+ fi
+}
diff --git a/dev-ml/bin-prot/metadata.xml b/dev-ml/bin-prot/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/bin-prot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>