summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-07-06 18:38:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-07-06 18:38:27 +0000
commit1a7c4f62b60f1c6115d4d356a3de324d525812bd (patch)
tree712d7b84778e6b83ff32fbbe531e97bf2b841768 /dev-ml/core
parentremove old (diff)
downloadhistorical-1a7c4f62b60f1c6115d4d356a3de324d525812bd.tar.gz
historical-1a7c4f62b60f1c6115d4d356a3de324d525812bd.tar.bz2
historical-1a7c4f62b60f1c6115d4d356a3de324d525812bd.zip
remove old
Package-Manager: portage-2.2.0_alpha43/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/core')
-rw-r--r--dev-ml/core/ChangeLog7
-rw-r--r--dev-ml/core/core-0.6.0.ebuild51
-rw-r--r--dev-ml/core/core-0.7.0_beta1.ebuild53
-rw-r--r--dev-ml/core/files/core-0.6.0-ocaml312.patch22
-rw-r--r--dev-ml/core/files/core-0.7.0_beta1-ocaml312.patch27
5 files changed, 6 insertions, 154 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
index 5c2826565aab..d7fcdbf1e92d 100644
--- a/dev-ml/core/ChangeLog
+++ b/dev-ml/core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.4 2011/06/25 18:57:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.5 2011/07/06 18:26:59 aballier Exp $
+
+ 06 Jul 2011; Alexis Ballier <aballier@gentoo.org> -core-0.6.0.ebuild,
+ -files/core-0.6.0-ocaml312.patch, -core-0.7.0_beta1.ebuild,
+ -files/core-0.7.0_beta1-ocaml312.patch:
+ remove old
*core-0.7.0 (25 Jun 2011)
diff --git a/dev-ml/core/core-0.6.0.ebuild b/dev-ml/core/core-0.6.0.ebuild
deleted file mode 100644
index b2a094a5eb2a..000000000000
--- a/dev-ml/core/core-0.6.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-0.6.0.ebuild,v 1.2 2010/11/11 20:09:18 aballier Exp $
-
-EAPI="2"
-inherit findlib eutils
-
-DESCRIPTION="Jane Street's alternative to the standard library"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://www.janestreet.com/ocaml/${P}.tgz"
-
-LICENSE="LGPL-2.1-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt]
- dev-ml/res
- dev-ml/sexplib
- dev-ml/bin-prot
- dev-ml/fieldslib
- dev-ml/pcre-ocaml"
-DEPEND="${RDEPEND}
- test? (
- dev-ml/ounit
- dev-ml/type-conv
- )"
-
-src_prepare() {
- has_version '>=dev-lang/ocaml-3.12' && epatch "${FILESDIR}/${P}-ocaml312.patch"
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- cd "${S}/extended_test"
- ocamlfind ocamlc -package bigarray,oUnit,type-conv,sexplib,bin_prot,res,fieldslib,pcre,threads -thread -dtypes -I ../extended -I ../lib yes.ml -o yes.exe || die
- for i in lib extended ; do
- cd "${S}/${i}_test"
- emake || die
- ./test_runner.exe || die
- done
-}
-
-src_install() {
- findlib_src_preinst
- emake install || die "make install failed"
- dodoc README
-}
diff --git a/dev-ml/core/core-0.7.0_beta1.ebuild b/dev-ml/core/core-0.7.0_beta1.ebuild
deleted file mode 100644
index 3fde16a3b04d..000000000000
--- a/dev-ml/core/core-0.7.0_beta1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-0.7.0_beta1.ebuild,v 1.1 2011/02/24 20:12:10 aballier Exp $
-
-EAPI="2"
-inherit findlib eutils multilib
-
-MY_P=${P/_/\~}
-DESCRIPTION="Jane Street's alternative to the standard library"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://www.janestreet.com/ocaml/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug +ocamlopt test"
-
-RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
- dev-ml/res
- >=dev-ml/sexplib-5.2.0
- dev-ml/bin-prot
- dev-ml/fieldslib"
-DEPEND="${RDEPEND}
- test? ( >=dev-ml/ounit-1.0.2 )"
-
-S=${WORKDIR}/${PN}
-
-oasis_use_enable() {
- echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
-}
-
-src_prepare() {
- has_version '>=dev-lang/ocaml-3.12' && epatch "${FILESDIR}/${P}-ocaml312.patch"
-}
-
-src_configure() {
- ./configure --prefix usr \
- --libdir /usr/$(get_libdir) \
- --docdir /usr/share/doc/${PF}/html \
- --destdir "${D}" \
- $(oasis_use_enable debug debug) \
- $(oasis_use_enable ocamlopt is_native) \
- || die
-}
-
-src_test() {
- LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
-}
-
-src_install() {
- findlib_src_install
- dodoc README || die
-}
diff --git a/dev-ml/core/files/core-0.6.0-ocaml312.patch b/dev-ml/core/files/core-0.6.0-ocaml312.patch
deleted file mode 100644
index 9ed10d1eb1ea..000000000000
--- a/dev-ml/core/files/core-0.6.0-ocaml312.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- janest-core-0.6.0.orig/lib/core_gc.mli
-+++ janest-core-0.6.0/lib/core_gc.mli
-@@ -71,6 +71,8 @@
-
- top_heap_words : int;
- (** Maximum size reached by the major heap, in words. *)
-+
-+ stack_size : int;
- }
- include Binable.S with type binable = t
- include Sexpable.S with type sexpable = t
---- janest-core-0.6.0.orig/lib/core_gc.ml
-+++ janest-core-0.6.0/lib/core_gc.ml
-@@ -54,6 +54,7 @@
- fragments : pretty_int;
- compactions : pretty_int;
- top_heap_words : pretty_int;
-+ stack_size : pretty_int;
- } with bin_io, sexp
- type binable = t
- type sexpable = t
-
diff --git a/dev-ml/core/files/core-0.7.0_beta1-ocaml312.patch b/dev-ml/core/files/core-0.7.0_beta1-ocaml312.patch
deleted file mode 100644
index 56dae5b0c4ea..000000000000
--- a/dev-ml/core/files/core-0.7.0_beta1-ocaml312.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -cr lib.orig/core_gc.ml lib/core_gc.ml
-*** lib.orig/core_gc.ml Sat Dec 11 00:11:49 2010
---- lib/core_gc.ml Sat Feb 19 12:19:33 2011
-***************
-*** 86,91 ****
---- 86,92 ----
- fragments : int;
- compactions : int;
- top_heap_words : int;
-+ stack_size : int;
- } with bin_io, sexp
- type binable = t
- type sexpable = t
-diff -cr lib.orig/core_gc.mli lib/core_gc.mli
-*** lib.orig/core_gc.mli Sat Dec 11 00:11:49 2010
---- lib/core_gc.mli Sat Feb 19 12:19:55 2011
-***************
-*** 103,108 ****
---- 103,110 ----
-
- top_heap_words : int;
- (** Maximum size reached by the major heap, in words. *)
-+
-+ stack_size : int;
- }
- include Binable.S with type binable = t
- include Sexpable.S with type sexpable = t