summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-05-06 23:13:23 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-05-06 23:13:23 +0000
commit7737ddc6ef5959fca85e11306c899e83a0d3b7ab (patch)
treefdd6a8975f30739890c96d4fdd96f5e6bf5c8eec /dev-perl/RPM
parenteclassed (diff)
downloadhistorical-7737ddc6ef5959fca85e11306c899e83a0d3b7ab.tar.gz
historical-7737ddc6ef5959fca85e11306c899e83a0d3b7ab.tar.bz2
historical-7737ddc6ef5959fca85e11306c899e83a0d3b7ab.zip
missing updates
Diffstat (limited to 'dev-perl/RPM')
-rw-r--r--dev-perl/RPM/RPM-0.32-r1.ebuild31
1 files changed, 10 insertions, 21 deletions
diff --git a/dev-perl/RPM/RPM-0.32-r1.ebuild b/dev-perl/RPM/RPM-0.32-r1.ebuild
index 9e7285e241ad..8b79bd76a6a9 100644
--- a/dev-perl/RPM/RPM-0.32-r1.ebuild
+++ b/dev-perl/RPM/RPM-0.32-r1.ebuild
@@ -1,29 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPM/RPM-0.32-r1.ebuild,v 1.1 2002/05/04 02:45:39 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPM/RPM-0.32-r1.ebuild,v 1.2 2002/05/06 23:13:23 seemant Exp $
-S=${WORKDIR}/Perl-${P}
+. /usr/portage/eclass/inherit.eclass || die
+inherit perl-module
+
+MY_P=Perl-${P}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="RPM:: module for perl"
-SRC_URI="http://www.cpan.org/authors/id/RJRAY/Perl-${P}.tar.gz"
+SRC_URI="http://www.cpan.org/authors/id/RJRAY/${MY_P}.tar.gz"
-DEPEND="virtual/glibc >=sys-devel/perl-5 app-arch/rpm"
+DEPEND="${DEPEND} app-arch/rpm"
LICENSE="Artistic | GPL-2"
SLOT="0"
-src_compile() {
- OPTIMIZE="$CFLAGS" perl Makefile.PL /usr
- make || die
-}
-
-src_install () {
- eval `perl '-V:installarchlib'`
- mkdir -p ${D}/$installarchlib
-
- make \
- PREFIX=${D}/usr \
- INSTALLMAN3DIR=${D}/usr/share/man/man3 \
- INSTALLMAN1DIR=${D}/usr/share/man/man1 \
- install || die
-
- dodoc ChangeLog MANIFEST README ToDo
-}
+export OPTIMIZE="${CFLAGS}"
+mydoc="ToDo"