summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-07-28 10:19:16 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-07-28 10:19:16 +0000
commitc7f00385066f7c204f05fe28245b9322faea4b1b (patch)
tree881fa6a404aa0b866531e1d6a1fcfead00b08d55 /dev-python/mmpython
parentFixed dependencies on slang-1.4.* for bug #141947 (diff)
downloadhistorical-c7f00385066f7c204f05fe28245b9322faea4b1b.tar.gz
historical-c7f00385066f7c204f05fe28245b9322faea4b1b.tar.bz2
historical-c7f00385066f7c204f05fe28245b9322faea4b1b.zip
fixing compile problems due to mising stdint.h (#128314) thanks to Håvard Wall.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'dev-python/mmpython')
-rw-r--r--dev-python/mmpython/ChangeLog7
-rw-r--r--dev-python/mmpython/files/digest-mmpython-0.4.72
-rw-r--r--dev-python/mmpython/files/digest-mmpython-0.4.92
-rw-r--r--dev-python/mmpython/files/mmpython-0.4.9-missing_stdint_headers.patch20
-rw-r--r--dev-python/mmpython/mmpython-0.4.7.ebuild10
-rw-r--r--dev-python/mmpython/mmpython-0.4.9.ebuild10
6 files changed, 46 insertions, 5 deletions
diff --git a/dev-python/mmpython/ChangeLog b/dev-python/mmpython/ChangeLog
index f23de96f9990..dc441902f7e7 100644
--- a/dev-python/mmpython/ChangeLog
+++ b/dev-python/mmpython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mmpython
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mmpython/ChangeLog,v 1.24 2006/04/01 15:09:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mmpython/ChangeLog,v 1.25 2006/07/28 10:19:16 liquidx Exp $
+
+ 28 Jul 2006; Alastair Tse <liquidx@gentoo.org>
+ +files/mmpython-0.4.9-missing_stdint_headers.patch, mmpython-0.4.9.ebuild:
+ fixing compile problems due to mising stdint.h (#128314) thanks to Håvard
+ Wall.
01 Apr 2006; Aron Griffis <agriffis@gentoo.org> mmpython-0.4.9.ebuild:
Mark 0.4.9 ~ia64
diff --git a/dev-python/mmpython/files/digest-mmpython-0.4.7 b/dev-python/mmpython/files/digest-mmpython-0.4.7
index fd7b3d9ac81c..7fb4bab3bcbb 100644
--- a/dev-python/mmpython/files/digest-mmpython-0.4.7
+++ b/dev-python/mmpython/files/digest-mmpython-0.4.7
@@ -1 +1,3 @@
MD5 fbd0fb7bc855e0b9f31485c9f9c256a7 mmpython-0.4.7.tar.gz 123884
+RMD160 371189092d0cf617889ccbe3d41d94ae5597d518 mmpython-0.4.7.tar.gz 123884
+SHA256 2228fb7b02a926638151335f0aa651fedf57cf5663eb4ef254c8fa3f4707cabe mmpython-0.4.7.tar.gz 123884
diff --git a/dev-python/mmpython/files/digest-mmpython-0.4.9 b/dev-python/mmpython/files/digest-mmpython-0.4.9
index 38855d64f908..8bf7f21949d2 100644
--- a/dev-python/mmpython/files/digest-mmpython-0.4.9
+++ b/dev-python/mmpython/files/digest-mmpython-0.4.9
@@ -1 +1,3 @@
MD5 f95699c2f4249d21105d7977a15d5dcc mmpython-0.4.9.tar.gz 127953
+RMD160 d7096d74dfea2e0b0c7fae0b8d50d0306b578b30 mmpython-0.4.9.tar.gz 127953
+SHA256 6d0ece18d422bc9f2d987efb3b4e24f8a66cdc8e3d011aa52b59cb40c85b212c mmpython-0.4.9.tar.gz 127953
diff --git a/dev-python/mmpython/files/mmpython-0.4.9-missing_stdint_headers.patch b/dev-python/mmpython/files/mmpython-0.4.9-missing_stdint_headers.patch
new file mode 100644
index 000000000000..2db6ae9e0462
--- /dev/null
+++ b/dev-python/mmpython/files/mmpython-0.4.9-missing_stdint_headers.patch
@@ -0,0 +1,20 @@
+--- disc/ifomodule.c~ 2004-07-17 10:46:52.000000000 +0200
++++ disc/ifomodule.c 2006-04-11 07:59:38.030697690 +0200
+@@ -8,6 +8,7 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <assert.h>
++#include <stdint.h>
+
+ #include <dvdread/dvd_reader.h>
+ #include <dvdread/ifo_types.h>
+--- disc/cdrommodule.c~ 2003-06-23 21:26:16.000000000 +0200
++++ disc/cdrommodule.c 2006-04-11 07:58:02.463087444 +0200
+@@ -36,6 +36,7 @@
+ #include "Python.h"
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
++#include <stdint.h>
+
+ #ifdef __linux__
+ #include <linux/cdrom.h>
diff --git a/dev-python/mmpython/mmpython-0.4.7.ebuild b/dev-python/mmpython/mmpython-0.4.7.ebuild
index a30160efe600..8d17d649ed8d 100644
--- a/dev-python/mmpython/mmpython-0.4.7.ebuild
+++ b/dev-python/mmpython/mmpython-0.4.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mmpython/mmpython-0.4.7.ebuild,v 1.5 2005/08/07 13:25:52 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mmpython/mmpython-0.4.7.ebuild,v 1.6 2006/07/28 10:19:16 liquidx Exp $
-inherit distutils
+inherit eutils distutils
DESCRIPTION="Media metadata retrieval framework for Python."
HOMEPAGE="http://sourceforge.net/projects/mmpython/"
@@ -15,3 +15,9 @@ IUSE="dvd"
DEPEND="${DEPEND}
dvd? ( >=media-libs/libdvdread-0.9.3 >=media-video/lsdvd-0.10 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-0.4.9-missing_stdint_headers.patch
+} \ No newline at end of file
diff --git a/dev-python/mmpython/mmpython-0.4.9.ebuild b/dev-python/mmpython/mmpython-0.4.9.ebuild
index a30e9ca7e375..1ed6d81751df 100644
--- a/dev-python/mmpython/mmpython-0.4.9.ebuild
+++ b/dev-python/mmpython/mmpython-0.4.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mmpython/mmpython-0.4.9.ebuild,v 1.2 2006/04/01 15:09:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mmpython/mmpython-0.4.9.ebuild,v 1.3 2006/07/28 10:19:16 liquidx Exp $
-inherit distutils
+inherit eutils distutils
DESCRIPTION="Media metadata retrieval framework for Python."
HOMEPAGE="http://sourceforge.net/projects/mmpython/"
@@ -15,3 +15,9 @@ IUSE="dvd"
DEPEND="${DEPEND}
dvd? ( >=media-libs/libdvdread-0.9.3 >=media-video/lsdvd-0.10 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-missing_stdint_headers.patch
+} \ No newline at end of file