summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-01-12 21:15:24 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-01-12 21:15:24 +0000
commitde339cfbc769e244776bd5efdbe0ef3b69859751 (patch)
tree4fac14a7ebe5417e6c1bb58759e446fbfb8cbe5d /dev-python/optik
parentxmms crossfade 0.2.9.. Initial ebuild (diff)
downloadhistorical-de339cfbc769e244776bd5efdbe0ef3b69859751.tar.gz
historical-de339cfbc769e244776bd5efdbe0ef3b69859751.tar.bz2
historical-de339cfbc769e244776bd5efdbe0ef3b69859751.zip
command-line parsing library for Python, initial ebuild
Diffstat (limited to 'dev-python/optik')
-rw-r--r--dev-python/optik/files/digest-optik-1.21
-rw-r--r--dev-python/optik/optik-1.2.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/optik/files/digest-optik-1.2 b/dev-python/optik/files/digest-optik-1.2
new file mode 100644
index 000000000000..af98fb94e4b0
--- /dev/null
+++ b/dev-python/optik/files/digest-optik-1.2
@@ -0,0 +1 @@
+MD5 93de9c3e331b9dd2a79d1d404214696e Optik-1.2.tar.gz 32768
diff --git a/dev-python/optik/optik-1.2.ebuild b/dev-python/optik/optik-1.2.ebuild
new file mode 100644
index 000000000000..626dcdb09f32
--- /dev/null
+++ b/dev-python/optik/optik-1.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Ollie Rutherfurd <oliver@rutherfurd.net>
+# $Header $
+
+S="${WORKDIR}/Optik-1.2"
+
+DESCRIPTION="Optik is a powerful, flexible, easy-to-use command-line parsing library for Python."
+SRC_URI="http://prdownloads.sourceforge.net/optik/Optik-${PV}.tar.gz"
+HOMEPAGE="http://optik.sourceforge.net/"
+
+DEPEND="virtual/python"
+
+src_install () {
+ cd ${S}
+ python setup.py install --prefix=${D}/usr || die
+ dodoc *.txt
+}
+
+
+