summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-02-14 12:57:15 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-02-14 12:57:15 +0000
commit4059b59946794b9aece5c4ab3742b4adb3c53013 (patch)
tree45f868237a6574662e068bfe567440a874afdabd /dev-python/pyds
parentversion bump (diff)
downloadhistorical-4059b59946794b9aece5c4ab3742b4adb3c53013.tar.gz
historical-4059b59946794b9aece5c4ab3742b4adb3c53013.tar.bz2
historical-4059b59946794b9aece5c4ab3742b4adb3c53013.zip
version bump. also add patch (#41254) thanks to <jerf jerf.org>
Diffstat (limited to 'dev-python/pyds')
-rw-r--r--dev-python/pyds/ChangeLog7
-rw-r--r--dev-python/pyds/Manifest7
-rw-r--r--dev-python/pyds/files/digest-pyds-0.7.01
-rw-r--r--dev-python/pyds/files/pyds-0.6.5-py2.3.patch19
-rw-r--r--dev-python/pyds/pyds-0.6.5.ebuild9
-rw-r--r--dev-python/pyds/pyds-0.7.0.ebuild30
6 files changed, 69 insertions, 4 deletions
diff --git a/dev-python/pyds/ChangeLog b/dev-python/pyds/ChangeLog
index 7b01c962223d..a858264d4fa2 100644
--- a/dev-python/pyds/ChangeLog
+++ b/dev-python/pyds/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyds
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds/ChangeLog,v 1.2 2004/01/18 12:36:05 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds/ChangeLog,v 1.3 2004/02/14 12:57:15 liquidx Exp $
+
+*pyds-0.7.0 (14 Feb 2004)
+
+ 14 Feb 2004; Alastair Tse <liquidx@gentoo.org> pyds-0.7.0.ebuild:
+ version bump. also add patch (#41254) thanks to <jerf jerf.org>
18 Jan 2004; Alastair Tse <liquidx@gentoo.org> pyds-0.6.5.ebuild:
moving dev-python/Cheetah to dev-python/cheetah
diff --git a/dev-python/pyds/Manifest b/dev-python/pyds/Manifest
index 859c5a202f32..37eb863a2867 100644
--- a/dev-python/pyds/Manifest
+++ b/dev-python/pyds/Manifest
@@ -1,4 +1,7 @@
-MD5 f4ad8c01a7fdfffb2942b82cfa7b2836 ChangeLog 451
+MD5 99327bcd8e68587fd7f098f4d8307482 ChangeLog 613
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
-MD5 ace41eb20f91ee39a9c6226dc8534102 pyds-0.6.5.ebuild 745
+MD5 3c6498aea4e17351fbda3e043fada6b6 pyds-0.6.5.ebuild 829
+MD5 4ad736d793e8a05df26a6c87380a0015 pyds-0.7.0.ebuild 745
MD5 0cfd4d73a24797f841459714fb787030 files/digest-pyds-0.6.5 62
+MD5 3a582b6b5901641f1a0165b05c3fc78b files/digest-pyds-0.7.0 62
+MD5 94e7c2cab795b8d9754f8f58efe71178 files/pyds-0.6.5-py2.3.patch 614
diff --git a/dev-python/pyds/files/digest-pyds-0.7.0 b/dev-python/pyds/files/digest-pyds-0.7.0
new file mode 100644
index 000000000000..19c2e76345cb
--- /dev/null
+++ b/dev-python/pyds/files/digest-pyds-0.7.0
@@ -0,0 +1 @@
+MD5 69c252e83cc50c273e87435f41f1fb43 PyDS-0.7.0.tar.gz 596230
diff --git a/dev-python/pyds/files/pyds-0.6.5-py2.3.patch b/dev-python/pyds/files/pyds-0.6.5-py2.3.patch
new file mode 100644
index 000000000000..39877b4f60c5
--- /dev/null
+++ b/dev-python/pyds/files/pyds-0.6.5-py2.3.patch
@@ -0,0 +1,19 @@
+--- DownstreamTool.py 2003-10-07 05:15:01.000000000 -0400
++++ /usr/lib/python2.3/site-packages/PyDS/DownstreamTool.py 2004-02-10 16:05:19.000000000 -0500
+@@ -36,6 +36,7 @@
+ import urllib
+ import gzip
+ import mimetypes
++import urlparse
+
+ import PyDS.Tool
+
+@@ -74,6 +75,8 @@
+ for h in self.cache._getUrlHeaders(theurl):
+ apply(self.addheader, h)
+ self.message += _('<br>adding Header "%s: %s"') % h
++ urlpieces = urlparse.urlparse(url[1])
++ url = (urlpieces[1], url[1])
+ res = urllib.URLopener.open_http(self, url, data)
+ self.message = self.message.replace('%', '%%')
+ if self.verbose:
diff --git a/dev-python/pyds/pyds-0.6.5.ebuild b/dev-python/pyds/pyds-0.6.5.ebuild
index 0ed0424ccce9..1b1ca28ced63 100644
--- a/dev-python/pyds/pyds-0.6.5.ebuild
+++ b/dev-python/pyds/pyds-0.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds/pyds-0.6.5.ebuild,v 1.2 2004/01/18 12:36:05 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds/pyds-0.6.5.ebuild,v 1.3 2004/02/14 12:57:15 liquidx Exp $
inherit distutils
@@ -28,3 +28,10 @@ RDEPEND="media-libs/jpeg
>=dev-python/soappy-0.10.1"
S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/PyDS
+ epatch ${FILESDIR}/${P}-py2.3.patch
+}
+
diff --git a/dev-python/pyds/pyds-0.7.0.ebuild b/dev-python/pyds/pyds-0.7.0.ebuild
new file mode 100644
index 000000000000..b40e6731bcb5
--- /dev/null
+++ b/dev-python/pyds/pyds-0.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds/pyds-0.7.0.ebuild,v 1.1 2004/02/14 12:57:15 liquidx Exp $
+
+inherit distutils
+
+MY_P="PyDS-${PV}"
+
+DESCRIPTION="Python Desktop Server"
+HOMEPAGE="http://pyds.muensterland.org/"
+SRC_URI="http://simon.bofh.ms/~gb/${MY_P}.tar.gz"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="media-libs/jpeg
+ sys-libs/zlib
+ >=dev-lang/python-2.2.2
+ >=dev-python/medusa-0.5.4
+ >=dev-db/metakit-2.4.9.2
+ >=dev-python/cheetah-0.9.15
+ >=dev-python/pyxml-0.8.2
+ >=dev-python/pyrex-0.5
+ >=dev-python/docutils-0.3
+ >=dev-python/Imaging-1.1.3
+ >=dev-python/soappy-0.10.1"
+
+S=${WORKDIR}/${MY_P}