summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-19 11:42:17 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-19 11:42:17 +0000
commit5db544b19e2f9d2671b017f2da3d8a9aea5cc2f1 (patch)
treea1a478c70e3a3a13302abbd5100992356775ac37 /dev-python/pygtk
parentNew version for GNOME 2.24. New APIs have been wrapped (notably GIO) and code... (diff)
downloadhistorical-5db544b19e2f9d2671b017f2da3d8a9aea5cc2f1.tar.gz
historical-5db544b19e2f9d2671b017f2da3d8a9aea5cc2f1.tar.bz2
historical-5db544b19e2f9d2671b017f2da3d8a9aea5cc2f1.zip
New version for GNOME 2.24. Wrap more APIs, support GTK-2.14 and bug fixes.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64
Diffstat (limited to 'dev-python/pygtk')
-rw-r--r--dev-python/pygtk/ChangeLog8
-rw-r--r--dev-python/pygtk/pygtk-2.13.0.ebuild75
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index 4a4b01f2c8f7..88d6c7248fa0 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygtk
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.189 2008/09/25 14:05:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.190 2008/10/19 11:42:17 eva Exp $
+
+*pygtk-2.13.0 (19 Oct 2008)
+
+ 19 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org> +pygtk-2.13.0.ebuild:
+ New version for GNOME 2.24. Wrap more APIs, support GTK-2.14 and bug
+ fixes.
25 Sep 2008; Jeroen Roovers <jer@gentoo.org> pygtk-2.12.1-r2.ebuild:
Stable for HPPA (bug #236971).
diff --git a/dev-python/pygtk/pygtk-2.13.0.ebuild b/dev-python/pygtk/pygtk-2.13.0.ebuild
new file mode 100644
index 000000000000..e05e89975bcd
--- /dev/null
+++ b/dev-python/pygtk/pygtk-2.13.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.13.0.ebuild,v 1.1 2008/10/19 11:42:17 eva Exp $
+
+inherit eutils flag-o-matic gnome.org python virtualx
+
+DESCRIPTION="GTK+2 bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/pango-1.16.0
+ >=dev-libs/atk-1.12.0
+ >=x11-libs/gtk+-2.13.6
+ >=gnome-base/libglade-2.5.0
+ >=dev-lang/python-2.4.4-r5
+ >=dev-python/pycairo-1.0.2
+ >=dev-python/pygobject-2.15.3
+ !arm? ( dev-python/numeric )"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ >=dev-util/pkgconfig-0.9"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix declaration of codegen in .pc
+ epatch "${FILESDIR}/${P}-fix-codegen-location.patch"
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+}
+
+src_compile() {
+ use hppa && append-flags -ffunction-sections
+ econf $(use_enable doc docs) --enable-thread
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
+
+ if use examples; then
+ rm examples/Makefile*
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ cd tests
+ Xemake check-local || die "tests failed"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/gtk-2.0
+ rm -f "${ROOT}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.{py,pth}
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+}