summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-22 14:26:54 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-22 14:26:54 +0000
commit405c37947d59812ffa42783088eb80bd7bc220f6 (patch)
tree33f932b6356613cc848cc83e280279d9f9cffbd4 /dev-python/python-memcached
parentVersion bump. (diff)
downloadhistorical-405c37947d59812ffa42783088eb80bd7bc220f6.tar.gz
historical-405c37947d59812ffa42783088eb80bd7bc220f6.tar.bz2
historical-405c37947d59812ffa42783088eb80bd7bc220f6.zip
Manifests
Package-Manager: portage-2.1.11.62/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/python-memcached')
-rw-r--r--dev-python/python-memcached/ChangeLog8
-rw-r--r--dev-python/python-memcached/python-memcached-1.48-r1.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/python-memcached/ChangeLog b/dev-python/python-memcached/ChangeLog
index 9c04973872fb..daa7be679d16 100644
--- a/dev-python/python-memcached/ChangeLog
+++ b/dev-python/python-memcached/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-memcached
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-memcached/ChangeLog,v 1.24 2013/05/22 07:24:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-memcached/ChangeLog,v 1.25 2013/05/22 14:26:54 idella4 Exp $
+
+*python-memcached-1.48-r1 (22 May 2013)
+
+ 22 May 2013; Ian Delaney <idella4@gentoo.org>
+ +python-memcached-1.48-r1.ebuild:
+ revbump, migrate -> distutils-r1, closes Bug #469856 by kensington
*python-memcached-1.50 (22 May 2013)
diff --git a/dev-python/python-memcached/python-memcached-1.48-r1.ebuild b/dev-python/python-memcached/python-memcached-1.48-r1.ebuild
new file mode 100644
index 000000000000..9d096c2d058f
--- /dev/null
+++ b/dev-python/python-memcached/python-memcached-1.48-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-memcached/python-memcached-1.48-r1.ebuild,v 1.1 2013/05/22 14:26:54 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python memcached client"
+HOMEPAGE="http://www.tummy.com/Community/software/python-memcached/ http://pypi.python.org/pypi/python-memcached"
+SRC_URI="ftp://ftp.tummy.com/pub/python-memcached/old-releases/${P}.tar.gz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( net-misc/memcached )"
+RDEPEND=""
+
+MULTIBUILD_JOBS="1"
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" > /dev/null
+ cp memcache.py memcache_test.py || die
+ sed -ie "s/11211/11219/" memcache_test.py || die
+ memcached -u portage -d -p 11219 -l localhost -P "${T}/memcached.pid"
+ "${PYTHON}" memcache_test.py || die
+ kill "$(<"${T}/memcached.pid")"
+ rm "${T}/memcached.pid"
+ rm memcache_test.py*
+ popd > /dev/null
+}