summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-23 11:22:47 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-23 11:22:47 +0000
commit1ba2e31f97853a7df737987582e2e0e0e12de40c (patch)
tree19c5e6d3e8dccc1c7bceb84aaebc1a527610e379 /dev-python/sip
parentPatch to build against Qt-4.7. Bug #338497. Migrated to qt4-r2 (diff)
downloadhistorical-1ba2e31f97853a7df737987582e2e0e0e12de40c.tar.gz
historical-1ba2e31f97853a7df737987582e2e0e0e12de40c.tar.bz2
historical-1ba2e31f97853a7df737987582e2e0e0e12de40c.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/files/sip-4.8.2-python-3.patch11
-rw-r--r--dev-python/sip/sip-4.10.ebuild73
-rw-r--r--dev-python/sip/sip-4.11.ebuild73
3 files changed, 0 insertions, 157 deletions
diff --git a/dev-python/sip/files/sip-4.8.2-python-3.patch b/dev-python/sip/files/sip-4.8.2-python-3.patch
deleted file mode 100644
index 344026641f69..000000000000
--- a/dev-python/sip/files/sip-4.8.2-python-3.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- sipdistutils.py
-+++ sipdistutils.py
-@@ -29,7 +29,7 @@
- out.append(os.path.join(self.build_temp, o))
- return out
-
-- raise RuntimeError, "cannot parse SIP-generated '%s'" % sbf
-+ raise RuntimeError("cannot parse SIP-generated '%s'" % sbf)
-
- def _find_sip(self):
- import sipconfig
diff --git a/dev-python/sip/sip-4.10.ebuild b/dev-python/sip/sip-4.10.ebuild
deleted file mode 100644
index 5f521a26cfb7..000000000000
--- a/dev-python/sip/sip-4.10.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.10.ebuild,v 1.6 2010/07/06 18:41:15 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils python toolchain-funcs
-
-MY_P=${P/_pre/-snapshot-}
-
-DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 sip )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="debug doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --bindir=${EPREFIX}/usr/bin
- --destdir=${EPREFIX}$(python_get_sitedir)
- --incdir=${EPREFIX}$(python_get_includedir)
- --sipdir=${EPREFIX}/usr/share/sip
- $(use debug && echo '--debug')
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
- LFLAGS='${LDFLAGS}'
- STRIP=true"
- echo ${myconf}
- eval ${myconf}
- }
- python_execute_function -s configuration
-}
-
-src_install() {
- python_src_install
-
- dodoc ChangeLog NEWS || die
-
- if use doc; then
- dohtml -r doc/html/* || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
-
- ewarn 'When updating sip, you usually need to recompile packages that'
- ewarn 'depend on sip, such as PyQt4 and qscintilla-python. If you have'
- ewarn 'app-portage/gentoolkit installed you can find these packages with'
- ewarn '`equery d sip` and `equery d PyQt4`.'
-}
-
-pkg_postrm() {
- python_mod_cleanup sipconfig.py sipdistutils.py
-}
diff --git a/dev-python/sip/sip-4.11.ebuild b/dev-python/sip/sip-4.11.ebuild
deleted file mode 100644
index bf9f83ccaace..000000000000
--- a/dev-python/sip/sip-4.11.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.11.ebuild,v 1.1 2010/09/01 08:58:37 hwoarang Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils python toolchain-funcs
-
-MY_P=${P/_pre/-snapshot-}
-
-DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 sip )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="debug doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-4.9.3-darwin.patch"
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --bindir=${EPREFIX}/usr/bin
- --destdir=${EPREFIX}$(python_get_sitedir)
- --incdir=${EPREFIX}$(python_get_includedir)
- --sipdir=${EPREFIX}/usr/share/sip
- $(use debug && echo '--debug')
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
- LFLAGS='${LDFLAGS}'
- STRIP=true"
- echo ${myconf}
- eval ${myconf}
- }
- python_execute_function -s configuration
-}
-
-src_install() {
- python_src_install
-
- dodoc NEWS || die
-
- if use doc; then
- dohtml -r doc/html/* || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
-
- ewarn 'When updating sip, you usually need to recompile packages that'
- ewarn 'depend on sip, such as PyQt4 and qscintilla-python. If you have'
- ewarn 'app-portage/gentoolkit installed you can find these packages with'
- ewarn '`equery d sip` and `equery d PyQt4`.'
-}
-
-pkg_postrm() {
- python_mod_cleanup sipconfig.py sipdistutils.py
-}