summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Thode <prometheanfire@gentoo.org>2013-09-17 19:07:01 +0000
committerMatt Thode <prometheanfire@gentoo.org>2013-09-17 19:07:01 +0000
commitc10c2098d4a89109ea346cba27f2dd0720aca3fe (patch)
tree36296d057ac971a262e9449ffcafc020a6a09948 /dev-python/testrepository/testrepository-0.0.17.ebuild
parentAdd explicit dep on python-exec:0 since the package wraps the script manually. (diff)
downloadhistorical-c10c2098d4a89109ea346cba27f2dd0720aca3fe.tar.gz
historical-c10c2098d4a89109ea346cba27f2dd0720aca3fe.tar.bz2
historical-c10c2098d4a89109ea346cba27f2dd0720aca3fe.zip
testrepository adding
Package-Manager: portage-2.1.12.2/cvs/Linux x86_64 Manifest-Sign-Key: 0x2471EB3E40AC5AC3
Diffstat (limited to 'dev-python/testrepository/testrepository-0.0.17.ebuild')
-rw-r--r--dev-python/testrepository/testrepository-0.0.17.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/testrepository/testrepository-0.0.17.ebuild b/dev-python/testrepository/testrepository-0.0.17.ebuild
new file mode 100644
index 000000000000..55c443fca940
--- /dev/null
+++ b/dev-python/testrepository/testrepository-0.0.17.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testrepository/testrepository-0.0.17.ebuild,v 1.1 2013/09/17 19:06:54 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A repository of test results."
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test"
+#tests suck
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+ dev-python/testresources[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" setup.py nosetests || die
+}