summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-05-26 18:47:48 +0000
committerMarien Zwart <marienz@gentoo.org>2006-05-26 18:47:48 +0000
commit134b9389205399f725d2359462fcb710e626fe89 (patch)
tree65248b9423acc14dc1fe9f08ae23f4b492ffbc70 /dev-python/twisted
parentStable on ppc64 (diff)
downloadhistorical-134b9389205399f725d2359462fcb710e626fe89.tar.gz
historical-134b9389205399f725d2359462fcb710e626fe89.tar.bz2
historical-134b9389205399f725d2359462fcb710e626fe89.zip
Version bump.
Package-Manager: portage-2.1_rc2-r3
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog7
-rw-r--r--dev-python/twisted/files/digest-twisted-2.2.02
-rw-r--r--dev-python/twisted/files/digest-twisted-2.4.03
-rw-r--r--dev-python/twisted/twisted-2.4.0.ebuild110
4 files changed, 121 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 2114db052721..7f8ecce42a9c 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.69 2006/05/25 14:09:20 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.70 2006/05/26 18:42:12 marienz Exp $
+
+*twisted-2.4.0 (26 May 2006)
+
+ 26 May 2006; Marien Zwart <marienz@gentoo.org> +twisted-2.4.0.ebuild:
+ Version bump.
25 May 2006; Michael Hanselmann <hansmi@gentoo.org> twisted-2.0.1.ebuild:
Stable on ppc.
diff --git a/dev-python/twisted/files/digest-twisted-2.2.0 b/dev-python/twisted/files/digest-twisted-2.2.0
index 7dfbc15cf5bb..12337b77cc2b 100644
--- a/dev-python/twisted/files/digest-twisted-2.2.0
+++ b/dev-python/twisted/files/digest-twisted-2.2.0
@@ -1 +1,3 @@
MD5 4a9305e69cdcf01a594c4fe1ea1efc05 Twisted-2.2.0.tar.bz2 1285316
+RMD160 c11353da93878721c8549a0594363b9d8ee38e12 Twisted-2.2.0.tar.bz2 1285316
+SHA256 537ec738c23ced2ec4a9b7f7124c2cd9bded1308331442ced0f3de7cd7562387 Twisted-2.2.0.tar.bz2 1285316
diff --git a/dev-python/twisted/files/digest-twisted-2.4.0 b/dev-python/twisted/files/digest-twisted-2.4.0
new file mode 100644
index 000000000000..8ffcaca36b46
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-2.4.0
@@ -0,0 +1,3 @@
+MD5 042a57f65fe919a9234047d7ce8c43f1 TwistedCore-2.4.0.tar.bz2 1213389
+RMD160 2ee341412675d2ef4582ae595adf49ce254eb88b TwistedCore-2.4.0.tar.bz2 1213389
+SHA256 114f8ecf2625916f6cd65099d4321243f2b56704dddb0c96b30f6b991db484d2 TwistedCore-2.4.0.tar.bz2 1213389
diff --git a/dev-python/twisted/twisted-2.4.0.ebuild b/dev-python/twisted/twisted-2.4.0.ebuild
new file mode 100644
index 000000000000..a522cd939b92
--- /dev/null
+++ b/dev-python/twisted/twisted-2.4.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.4.0.ebuild,v 1.1 2006/05/26 18:42:12 marienz Exp $
+
+inherit eutils distutils versionator
+
+MY_P=TwistedCore-${PV}
+
+DESCRIPTION="An asynchronous networking framework written in Python"
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/Twisted/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="gtk serial crypt"
+
+DEPEND=">=dev-lang/python-2.3
+ >=net-zope/zopeinterface-3.0.1
+ serial? ( dev-python/pyserial )
+ crypt? ( >=dev-python/pyopenssl-0.5.1 )
+ gtk? ( >=dev-python/pygtk-1.99 )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CREDITS INSTALL NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Give a load-sensitive test a better chance of succeeding.
+ epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
+
+ # Pass valid arguments to "head" in the zsh completion function.
+ epatch "${FILESDIR}/${PN}-2.1.0-zsh-head.patch"
+
+ # Remove a mostly-empty file with a syntax error ("???" placeholder)
+ rm twisted/test/stdio_test_halfclose.py
+}
+
+src_install() {
+ distutils_src_install
+
+ # get rid of this to prevent collision-protect from killing us. it
+ # is regenerated in pkg_postinst.
+ rm "${D}/usr/$(get_libdir)"/python*/site-packages/twisted/plugins/dropin.cache
+
+ # weird pattern to avoid installing the index.xhtml page
+ doman doc/man/*.?
+ insinto /usr/share/doc/${PF}
+ doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
+
+ # workaround for a possible portage bug
+ mkdir -p "${D}/etc/conf.d/"
+ newconfd "${FILESDIR}/twistd.conf" twistd
+ newinitd "${FILESDIR}/twistd.init" twistd
+
+ # zsh completion
+ insinto /usr/share/zsh/site-functions/
+ doins twisted/python/_twisted_zsh_stub
+}
+
+update_plugin_cache() {
+ python_version
+ local tpath="${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/twisted"
+ # we have to remove the cache or removed plugins won't be removed
+ # from the cache (http://twistedmatrix.com/bugs/issue926)
+ [[ -e "${tpath}/plugins/dropin.cache" ]] && rm -f "${tpath}/plugins/dropin.cache"
+ if [[ -e "${tpath}/plugin.py" ]]; then
+ # twisted is still installed, update.
+ # we have to use getPlugIns here for <=twisted-2.0.1 compatibility
+ einfo "Regenerating plugin cache"
+ python -c "from twisted.plugin import IPlugin, getPlugIns;list(getPlugIns(IPlugin))"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ update_plugin_cache
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ update_plugin_cache
+}
+
+src_test() {
+ python_version
+
+ if has_version ">=dev-lang/python-2.3"; then
+ "${python}" setup.py install --root="${T}/tests" --no-compile || die
+ else
+ "${python}" setup.py install --root="${T}/tests" || die
+ fi
+
+ cd "${T}/tests/usr/$(get_libdir)/python${PYVER}/site-packages/" || die
+
+ # prevent it from pulling in plugins from already installed
+ # twisted packages
+ rm twisted/plugins/__init__.py || die
+
+ # an empty file doesn't work because the tests check for
+ # docstrings in all packages
+ echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
+
+ PYTHONPATH=. "${T}"/tests/usr/bin/trial twisted || die "trial failed"
+ cd "${S}"
+ rm -rf "${T}/tests"
+}