summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-03-09 15:44:42 +0000
committerMart Raudsepp <leio@gentoo.org>2008-03-09 15:44:42 +0000
commit093a14ae2cbc39002d385ce71c14867d91a8be85 (patch)
treea8355d017d97c6841496ca19a7d97679fefef543 /dev-python
parentRemove the pcre security vulnerable versions that I can right now (diff)
downloadhistorical-093a14ae2cbc39002d385ce71c14867d91a8be85.tar.gz
historical-093a14ae2cbc39002d385ce71c14867d91a8be85.tar.bz2
historical-093a14ae2cbc39002d385ce71c14867d91a8be85.zip
Remove now redundant version
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygobject/pygobject-2.14.0-r1.ebuild80
-rw-r--r--dev-python/pygtk/files/pygtk-2.12.0-extrafuncs.patch24
-rw-r--r--dev-python/pygtk/pygtk-2.12.0-r1.ebuild95
3 files changed, 0 insertions, 199 deletions
diff --git a/dev-python/pygobject/pygobject-2.14.0-r1.ebuild b/dev-python/pygobject/pygobject-2.14.0-r1.ebuild
deleted file mode 100644
index 65741aa645f0..000000000000
--- a/dev-python/pygobject/pygobject-2.14.0-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.0-r1.ebuild,v 1.1 2007/12/27 18:04:50 eva Exp $
-
-WANT_AUTOMAKE=1.8
-inherit gnome2 python autotools
-
-DESCRIPTION="GLib's GObject library bindings for Python"
-HOMEPAGE="http://www.pygtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc examples"
-
-# glib higher dep than in configure.in comes from a runtime version check and ensures that
-# timeout_add_seconds is available for any packages that depend on pygobject and use it
-# python high dep for a fixed python-config, as aclocal.m4/configure in the tarball requires it to function properly
-RDEPEND=">=dev-lang/python-2.4.4-r5
- >=dev-libs/glib-2.13.5
- !<dev-python/pygtk-2.9"
-DEPEND="${RDEPEND}
- doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
- >=dev-util/pkgconfig-0.12.0"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-pkg_setup() {
- # activate libffi when bug #199850 is solved
- G2CONF="${G2CONF} $(use_enable doc docs) --without-libffi"
-}
-
-src_unpack() {
- gnome2_src_unpack
-
- # fix bug #147285 - Robin H. Johnson <robbat2@gentoo.org>
- # this is caused by upstream's automake-1.8 lacking some Gentoo-specific
- # patches (for tmpfs amongst other things). Upstreams hit by this should
- # move to newer automake versions ideally.
- # eautomake
-
- # fix bug #198875 and bug #194632
- epatch "${FILESDIR}/${P}-libffi-magic.patch"
-
- # uncomment above eautomake when eautoreconf isn't needed anymore
- cp aclocal.m4 old.m4
- AT_M4DIR="." eautoreconf
-
- # disable pyc compiling
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
-}
-
-src_install() {
- gnome2_src_install
-
- if use examples; then
- insinto /usr/share/doc/${P}
- doins -r examples
- fi
-
- python_version
- mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py \
- "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py-2.0
- mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth \
- "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth-2.0
-}
-
-pkg_postinst() {
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
- alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
- python_mod_compile "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
-}
-
-pkg_postrm() {
- python_version
- python_mod_cleanup
-}
diff --git a/dev-python/pygtk/files/pygtk-2.12.0-extrafuncs.patch b/dev-python/pygtk/files/pygtk-2.12.0-extrafuncs.patch
deleted file mode 100644
index b68d581b719f..000000000000
--- a/dev-python/pygtk/files/pygtk-2.12.0-extrafuncs.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN pygtk-2.12.0.orig/gtk/Makefile.am pygtk-2.12.0/gtk/Makefile.am
---- pygtk-2.12.0.orig/gtk/Makefile.am 2007-09-15 11:00:42.000000000 -0400
-+++ pygtk-2.12.0/gtk/Makefile.am 2007-12-22 11:17:35.000000000 -0500
-@@ -138,7 +138,7 @@ nodist__gtk_la_SOURCES = gtk.c gdk.c
- if BUILD_GTK
- pygtkexec_LTLIBRARIES += _gtk.la
- defs_DATA += $(GDK_DEFS) $(GDK_TYPES_DEFS) $(GTK_DEFS) $(GTK_TYPES_DEFS) \
-- gdk.defs gtk.defs gdk-types.defs gtk-types.defs
-+ gdk.defs gtk.defs gdk-types.defs gtk-types.defs gtk-extrafuncs.defs
- endif
-
- # libglade module
-diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN pygtk-2.12.0.orig/gtk/Makefile.in pygtk-2.12.0/gtk/Makefile.in
---- pygtk-2.12.0.orig/gtk/Makefile.in 2007-09-16 07:44:03.000000000 -0400
-+++ pygtk-2.12.0/gtk/Makefile.in 2007-12-22 11:26:52.000000000 -0500
-@@ -47,7 +47,7 @@ host_triplet = @host@
- @HAVE_GTK_2_12_TRUE@am__append_7 = gtk-2.12-types.defs
- @BUILD_GTK_TRUE@am__append_8 = _gtk.la
- @BUILD_GTK_TRUE@am__append_9 = $(GDK_DEFS) $(GDK_TYPES_DEFS) $(GTK_DEFS) $(GTK_TYPES_DEFS) \
--@BUILD_GTK_TRUE@ gdk.defs gtk.defs gdk-types.defs gtk-types.defs
-+@BUILD_GTK_TRUE@ gdk.defs gtk.defs gdk-types.defs gtk-types.defs gtk-extrafuncs.defs
-
- @BUILD_LIBGLADE_TRUE@am__append_10 = glade.la
- @BUILD_LIBGLADE_TRUE@am__append_11 = $(LIBGLADE_DEFS)
diff --git a/dev-python/pygtk/pygtk-2.12.0-r1.ebuild b/dev-python/pygtk/pygtk-2.12.0-r1.ebuild
deleted file mode 100644
index 3053615195aa..000000000000
--- a/dev-python/pygtk/pygtk-2.12.0-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.12.0-r1.ebuild,v 1.1 2007/12/22 16:34:49 dang Exp $
-
-NEED_PYTHON=2.3.5
-
-inherit gnome.org python flag-o-matic eutils
-
-DESCRIPTION="GTK+2 bindings for Python"
-HOMEPAGE="http://www.pygtk.org/"
-
-DOC_FILE="pygtk2reference-2.9.0.tar.bz2"
-SRC_URI="${SRC_URI}
- doc? ( mirror://gnome/sources/pygtk2reference/2.9/${DOC_FILE} )"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc examples opengl"
-
-RDEPEND=">=dev-libs/glib-2.8.0
- >=x11-libs/pango-1.16.0
- >=dev-libs/atk-1.12.0
- >=x11-libs/gtk+-2.11.6
- >=gnome-base/libglade-2.5.0
- >=dev-lang/python-2.4.4-r5
- >=dev-python/pycairo-1.0.2
- >=dev-python/pygobject-2.14
- !arm? ( dev-python/numeric )
- opengl? ( virtual/opengl
- dev-python/pyopengl
- >=x11-libs/gtkglarea-1.99
- )"
-
-DEPEND="${RDEPEND}
- doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
- >=dev-util/pkgconfig-0.9"
-
-# Tests fail (missing display)
-RESTRICT="test"
-
-src_unpack() {
- unpack ${A}
- use doc || sed -e 's/\(SUBDIRS =.*\) docs$/\1/' -i "${S}"/Makefile.am
-
- # disable pyc compiling
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s $(type -P true) "${S}"/py-compile
-
- # Install gtk-extrafuncs.def bug#202140
- epatch "${FILESDIR}"/${P}-extrafuncs.patch
-}
-
-src_compile() {
- use hppa && append-flags -ffunction-sections
- econf $(use_enable doc docs) --enable-thread || die
- # possible problems with parallel builds (#45776)
- emake -j1 || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
-
- if use examples; then
- rm examples/Makefile*
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-
- if use doc; then
- insinto /usr/share/gtk-doc/html/pygtk
- cd "${WORKDIR}"/pygtk2reference
- doins -r cursors icons images
- fi
-}
-
-src_test() {
- cd tests
- make check-local || die "tests failed"
-}
-
-pkg_postinst() {
- python_version
- python_mod_optimize /usr/share/pygtk/2.0/codegen /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
-}
-
-pkg_postrm() {
- python_version
- python_mod_cleanup /usr/share/pygtk/2.0/codegen
- python_mod_cleanup
- rm -f "${ROOT}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.{py,pth}
- alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
-}