summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-12-26 00:56:22 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-12-26 00:56:22 +0000
commitb5392095fd3528467766869df177811efffc5bd0 (patch)
tree49711dac916e970c7ade0c59c9cece7d4a8d7c77 /dev-python
parentBumping commons-digester (diff)
downloadhistorical-b5392095fd3528467766869df177811efffc5bd0.tar.gz
historical-b5392095fd3528467766869df177811efffc5bd0.tar.bz2
historical-b5392095fd3528467766869df177811efffc5bd0.zip
version bump
Package-Manager: portage-2.1.4_rc11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt/ChangeLog7
-rw-r--r--dev-python/PyQt/PyQt-3.17.4.ebuild56
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.17.43
-rw-r--r--dev-python/PyQt4/ChangeLog7
-rw-r--r--dev-python/PyQt4/PyQt4-4.3.3.ebuild53
-rw-r--r--dev-python/PyQt4/files/digest-PyQt4-4.3.33
6 files changed, 127 insertions, 2 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index 9ee5d512d535..5da093740af9 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.99 2007/12/05 14:50:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.100 2007/12/26 00:53:05 caleb Exp $
+
+*PyQt-3.17.4 (26 Dec 2007)
+
+ 26 Dec 2007; Caleb Tennis <caleb@gentoo.org> +PyQt-3.17.4.ebuild:
+ version bump
05 Dec 2007; Raúl Porcel <armin76@gentoo.org> PyQt-3.17.3.ebuild:
alpha/sparc stable wrt #200630
diff --git a/dev-python/PyQt/PyQt-3.17.4.ebuild b/dev-python/PyQt/PyQt-3.17.4.ebuild
new file mode 100644
index 000000000000..20c33af21ca1
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.17.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.17.4.ebuild,v 1.1 2007/12/26 00:53:05 caleb Exp $
+
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt3/GPL/${MY_P}.tar.gz"
+#SRC_URI="http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt3/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+
+RDEPEND="=x11-libs/qt-3*
+ >=dev-python/sip-4.7.3
+ x11-libs/qscintilla"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages \
+ -b /usr/bin \
+ -v /usr/share/sip \
+ -n /usr/include \
+ -o /usr/$(get_libdir) \
+ -w -y qt-mt"
+ use debug && myconf="${myconf} -u"
+
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README README.Linux THANKS
+ use doc && dohtml doc/PyQt.html
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/PyQt/files/digest-PyQt-3.17.4 b/dev-python/PyQt/files/digest-PyQt-3.17.4
new file mode 100644
index 000000000000..21e3b8c48677
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.17.4
@@ -0,0 +1,3 @@
+MD5 0dffe4bc87a1102d61ee972bb868c65a PyQt-x11-gpl-3.17.4.tar.gz 803925
+RMD160 77b1ca96465ae737545fbdd1f63bd06bb089a74b PyQt-x11-gpl-3.17.4.tar.gz 803925
+SHA256 1931400062d432af229a6862e5fbd6554e7b16b70a5ea87478d026ce8979e65c PyQt-x11-gpl-3.17.4.tar.gz 803925
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 434776c2de32..940c8be87510 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.20 2007/11/28 12:56:37 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.21 2007/12/26 00:56:22 caleb Exp $
+
+*PyQt4-4.3.3 (26 Dec 2007)
+
+ 26 Dec 2007; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.3.3.ebuild:
+ version bump
28 Nov 2007; Caleb Tennis <caleb@gentoo.org> -PyQt4-4.2.ebuild,
-PyQt4-4.3.ebuild:
diff --git a/dev-python/PyQt4/PyQt4-4.3.3.ebuild b/dev-python/PyQt4/PyQt4-4.3.3.ebuild
new file mode 100644
index 000000000000..18b686846c8f
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.3.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.3.3.ebuild,v 1.1 2007/12/26 00:56:22 caleb Exp $
+
+inherit distutils qt4
+
+MY_P=PyQt-x11-gpl-${PV}
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc examples"
+
+RDEPEND="=x11-libs/qt-4*
+ >=dev-python/sip-4.7.3"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S=${WORKDIR}/${MY_P}
+
+QT4_BUILT_WITH_USE_CHECK="zlib"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:^[ \t]*check_license():# check_license():" "${S}"/configure.py
+ sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" "${S}"/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin -v /usr/share/sip"
+ use debug && myconf="${myconf} -u"
+
+ "${python}" configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS
+ use doc && dohtml -r doc/html/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/PyQt4/files/digest-PyQt4-4.3.3 b/dev-python/PyQt4/files/digest-PyQt4-4.3.3
new file mode 100644
index 000000000000..d19802957b9b
--- /dev/null
+++ b/dev-python/PyQt4/files/digest-PyQt4-4.3.3
@@ -0,0 +1,3 @@
+MD5 a2ead359f57d84c24bdd10de387e80b4 PyQt-x11-gpl-4.3.3.tar.gz 6191266
+RMD160 8d25e15d8529b6a0f08b112f00a85a4b87b5ff88 PyQt-x11-gpl-4.3.3.tar.gz 6191266
+SHA256 d36383e40a983f4d5d53b38bb85409e55a82e3aac0d7296abe68d913befa1e55 PyQt-x11-gpl-4.3.3.tar.gz 6191266