summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-02-01 19:47:10 +0000
committerNick Hadaway <raker@gentoo.org>2003-02-01 19:47:10 +0000
commitb6977add3462fe21cfed383eca5cff9db8f4d39e (patch)
tree9dba1d8e554ee21d6057c31db0b1a7ccd112eed5 /dev-python
parentFixed kerberos detection (diff)
downloadhistorical-b6977add3462fe21cfed383eca5cff9db8f4d39e.tar.gz
historical-b6977add3462fe21cfed383eca5cff9db8f4d39e.tar.bz2
historical-b6977add3462fe21cfed383eca5cff9db8f4d39e.zip
Version bump.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxPython/ChangeLog7
-rw-r--r--dev-python/wxPython/files/digest-wxPython-2.4.0.21
-rw-r--r--dev-python/wxPython/wxPython-2.4.0.2.ebuild75
3 files changed, 82 insertions, 1 deletions
diff --git a/dev-python/wxPython/ChangeLog b/dev-python/wxPython/ChangeLog
index 61c796c9cd06..1f35dd2790dc 100644
--- a/dev-python/wxPython/ChangeLog
+++ b/dev-python/wxPython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wxPython
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.18 2003/01/15 18:58:23 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.19 2003/02/01 19:47:10 raker Exp $
+
+*wxPython-2.4.0.2 (01 Feb 2003)
+
+ 01 Feb 2003; Nick Hadaway <raker@gentoo.org> wxPython-2.4.0.2.ebuild :
+ Version bump. Bug fixes.
*wxPython-2.4.0.1 (12 Jan 2003)
diff --git a/dev-python/wxPython/files/digest-wxPython-2.4.0.2 b/dev-python/wxPython/files/digest-wxPython-2.4.0.2
new file mode 100644
index 000000000000..7e366a3f648f
--- /dev/null
+++ b/dev-python/wxPython/files/digest-wxPython-2.4.0.2
@@ -0,0 +1 @@
+MD5 217a2cfe79b280b4cd2d7f32c24339f6 wxPythonSrc-2.4.0.2.tar.gz 11700089
diff --git a/dev-python/wxPython/wxPython-2.4.0.2.ebuild b/dev-python/wxPython/wxPython-2.4.0.2.ebuild
new file mode 100644
index 000000000000..3f3fd21fa3b5
--- /dev/null
+++ b/dev-python/wxPython/wxPython-2.4.0.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.0.2.ebuild,v 1.1 2003/02/01 19:47:10 raker Exp $
+
+MY_P="${P/-/Src-}"
+S="${WORKDIR}/${MY_P}/${PN}"
+DESCRIPTION="A blending of the wxWindows C++ class library with Python."
+SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.gz"
+HOMEPAGE="http://www.wxpython.org/"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+IUSE="opengl gtk2"
+
+DEPEND=">=dev-lang/python-2.1
+ >=dev-libs/glib-1.2
+ >=x11-libs/gtk+-1.2
+ =x11-libs/wxGTK-2.4.0*
+ opengl? ( >=dev-python/PyOpenGL-2.0.0.44 )"
+
+pkg_setup() {
+ # xfree should not install these, remove until the fixed
+ # xfree is in main use.
+ rm -f /usr/X11R6/include/{zconf.h,zlib.h}
+}
+
+src_compile() {
+ # create links so the build doesnt fail
+ for d in ogl stc xrc gizmos ; do
+ ln -s ${S}/../contrib/ ${S}/contrib/${d}/contrib
+ done
+
+ #Other possible configuration variables are BUILD_OGL and BUILD_STC.
+ #BUILD_OGL builds the Object Graphics Library extension module.
+ #BUILD_STC builds the wxStyledTextCtrl (the Scintilla wrapper) extension module.
+ #Both these variable are enabled by default. To disable them set equal to zero
+ #and add to myconf.
+ local myconf=""
+ if [ `use opengl` ]; then
+ myconf="${myconf} BUILD_GLCANVAS=1"
+ else
+ myconf="${myconf} BUILD_GLCANVAS=0"
+ patch -p1 < ${FILESDIR}/wxPython-2.3.3.1-noglcanvas.diff \
+ || die "patch failed"
+ fi
+ if [ `use gtk2` ]; then
+ myconf="${myconf} WXPORT=gtk2"
+ else
+ myconf="${myconf} WXPORT=gtk"
+ fi
+
+ python setup.py ${myconf} build || die "build failed"
+}
+
+src_install() {
+ #Other possible configuration variables are BUILD_OGL and BUILD_STC.
+ #BUILD_OGL builds the Object Graphics Library extension module.
+ #BUILD_STC builds the wxStyledTextCtrl (the Scintilla wrapper) extension module.
+ #Both these variable are enabled by default. To disable them set equal to zero
+ #and add to myconf.
+ local myconf=""
+ if [ `use opengl` ]; then
+ myconf="${myconf} BUILD_GLCANVAS=1"
+ else
+ myconf="${myconf} BUILD_GLCANVAS=0"
+ fi
+ if [ `use gtk2` ]; then
+ myconf="${myconf} WXPORT=gtk2"
+ else
+ myconf="${myconf} WXPORT=gtk"
+ fi
+
+ python setup.py ${myconf} install --prefix=/usr --root=${D} || die
+}