summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-02-28 20:37:47 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-02-28 20:37:47 +0000
commitb8620019a9a5879638195e73b466e692eb6921d6 (patch)
treec05e36f8274bed3a7c2163aae9e3c172ee3de3c3 /dev-python
parentx86 stable, bug #209201 (diff)
downloadhistorical-b8620019a9a5879638195e73b466e692eb6921d6.tar.gz
historical-b8620019a9a5879638195e73b466e692eb6921d6.tar.bz2
historical-b8620019a9a5879638195e73b466e692eb6921d6.zip
Version bump (bug #209920).
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/astng/ChangeLog9
-rw-r--r--dev-python/astng/astng-0.17.2.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/dev-python/astng/ChangeLog b/dev-python/astng/ChangeLog
index febed7fdb7fb..d4214be45fcd 100644
--- a/dev-python/astng/ChangeLog
+++ b/dev-python/astng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/astng
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.20 2007/06/24 20:35:14 dev-zero Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.21 2008/02/28 20:37:47 dev-zero Exp $
+
+*astng-0.17.2 (28 Feb 2008)
+
+ 28 Feb 2008; Tiziano Müller <dev-zero@gentoo.org> +astng-0.17.2.ebuild:
+ Version bump (bug #209920).
24 Jun 2007; Tiziano Müller <dev-zero@gentoo.org>
-files/astng-0.16.0-revert-test.patch, -astng-0.16.0.ebuild,
diff --git a/dev-python/astng/astng-0.17.2.ebuild b/dev-python/astng/astng-0.17.2.ebuild
new file mode 100644
index 000000000000..055e41a17e3d
--- /dev/null
+++ b/dev-python/astng/astng-0.17.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.17.2.ebuild,v 1.1 2008/02/28 20:37:47 dev-zero Exp $
+
+NEED_PYTHON="2.3"
+
+inherit distutils eutils multilib
+
+DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
+SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz"
+HOMEPAGE="http://www.logilab.org/projects/astng/"
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-python/logilab-common-0.13-r1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/logilab-${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Skip a failing test.
+ epatch "${FILESDIR}/${PN}-0.16.1-skip-gobject-test.patch"
+}
+
+src_install() {
+ distutils_src_install
+ python_version
+ # we need to remove this file because it collides with the one
+ # from logilab-common (which we depend on).
+ rm "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/logilab/__init__.py"
+}
+
+src_test() {
+ python_version
+
+ # Do a temporary install.
+ local spath="usr/$(get_libdir)/python${PYVER}/site-packages/"
+
+ # This is a hack to make tests work without installing to the live
+ # filesystem. We copy part of the logilab site-packages to a temporary
+ # dir, install there, and run from there.
+ mkdir -p "${T}/test/${spath}/logilab"
+ cp -r "/${spath}/logilab/common" "${T}/test/${spath}/logilab" \
+ || die "copying logilab-common failed!"
+
+ "${python}" setup.py install --root="${T}/test" || die "test copy failed"
+
+ # Use a hacked up copy of pytest that exits nonzero on failure.
+ sed -e 's/exitafter=False/exitafter=True/' \
+ < "/usr/bin/pytest" > "${T}/pytest" || die "sed failed"
+
+ # Pytest picks up tests relative to the current dir, so cd in.
+ pushd "${T}/test/${spath}/logilab/astng" >/dev/null
+ PYTHONPATH="${T}/test/${spath}" "${python}" "${T}/pytest" -v \
+ || die "tests failed"
+ popd >/dev/null
+ rm -rf "${T}/test"
+}