summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-14 00:17:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-14 00:17:28 +0000
commit5e0b1d9f174adcf834dea3b0c6faec4396000e32 (patch)
tree61619b39f79fe8a0f788482e38ee961484465799 /dev-ruby/attic
parentVersion bump per bug #294934. (diff)
downloadhistorical-5e0b1d9f174adcf834dea3b0c6faec4396000e32.tar.gz
historical-5e0b1d9f174adcf834dea3b0c6faec4396000e32.tar.bz2
historical-5e0b1d9f174adcf834dea3b0c6faec4396000e32.zip
Initial import of attic needed ultimately for rudy.
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/attic')
-rw-r--r--dev-ruby/attic/ChangeLog10
-rw-r--r--dev-ruby/attic/Manifest15
-rw-r--r--dev-ruby/attic/attic-0.5.0.ebuild38
-rw-r--r--dev-ruby/attic/files/attic-0.5.0-fixes.patch44
-rw-r--r--dev-ruby/attic/metadata.xml5
5 files changed, 112 insertions, 0 deletions
diff --git a/dev-ruby/attic/ChangeLog b/dev-ruby/attic/ChangeLog
new file mode 100644
index 000000000000..da6d438563cd
--- /dev/null
+++ b/dev-ruby/attic/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/attic
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/attic/ChangeLog,v 1.1 2010/02/14 00:17:26 flameeyes Exp $
+
+*attic-0.5.0 (14 Feb 2010)
+
+ 14 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org> +attic-0.5.0.ebuild,
+ +files/attic-0.5.0-fixes.patch, +metadata.xml:
+ Initial import of attic needed ultimately for rudy.
+
diff --git a/dev-ruby/attic/Manifest b/dev-ruby/attic/Manifest
new file mode 100644
index 000000000000..6c12f1d33c17
--- /dev/null
+++ b/dev-ruby/attic/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX attic-0.5.0-fixes.patch 1046 RMD160 387a515546973501697c2d85452e77623030f26e SHA1 c313f4eb84bd0c80569ee455f5223e25e10bcf20 SHA256 a3b4f362854f2595ec43face0dc4efa1a678af9ab8c4e6c95c030437ad175f89
+DIST attic-git-0.5.0.tgz 6780 RMD160 a74adaf73ceeede4797a7b8756650cbc455fa6e0 SHA1 e133d9cad055fcb5be10b56869035124ff52d0fb SHA256 5d7d402e4f194b7afca7f43a640e786f258d29dd401cbd8e4202f03357bbd51e
+EBUILD attic-0.5.0.ebuild 880 RMD160 bac5b2b52a446bf4e34320d48ff6e5d4f32ff86a SHA1 db6654cc25e5ff389b217bc4ea9f88d67fb0ef06 SHA256 9c2dc1d9ec9bb3d653503217dbf5e83f95c63c61a78f0db03d0200e20f2533c0
+MISC ChangeLog 413 RMD160 b3492b3df5cda253ee6851ccfa938898071a6faf SHA1 db7ab44aebc7c7b9cadb223588826b4f0c7bf211 SHA256 3036af1e9e8a0d068c460703f5b817d8cfe843ad4c000c5d3d23fc16bf180439
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.14 (GNU/Linux)
+
+iEYEARECAAYFAkt3QRoACgkQAiZjviIA2XgGvQCg0AF0ETHYdxahu8tXy2GH3gdt
+pIIAoKLDkEdNgX4PM/2Qug67Lneue1NB
+=sC4n
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/attic/attic-0.5.0.ebuild b/dev-ruby/attic/attic-0.5.0.ebuild
new file mode 100644
index 000000000000..905a0eb52317
--- /dev/null
+++ b/dev-ruby/attic/attic-0.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/attic/attic-0.5.0.ebuild,v 1.1 2010/02/14 00:17:26 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A place for Ruby objects to hide instance variables"
+HOMEPAGE="http://solutious.com/"
+
+SRC_URI="http://github.com/delano/${PN}/tarball/${P} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/delano-${PN}-cda0a77"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend test dev-ruby/tryouts
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-fixes.patch
+}
+
+each_ruby_test() {
+ ${RUBY} -S sergeant || die "tests failed"
+}
diff --git a/dev-ruby/attic/files/attic-0.5.0-fixes.patch b/dev-ruby/attic/files/attic-0.5.0-fixes.patch
new file mode 100644
index 000000000000..cde7b5a07b39
--- /dev/null
+++ b/dev-ruby/attic/files/attic-0.5.0-fixes.patch
@@ -0,0 +1,44 @@
+diff --git a/Rakefile b/Rakefile
+index eebef10..3a8edfc 100644
+--- a/Rakefile
++++ b/Rakefile
+@@ -1,7 +1,6 @@
+ require 'rubygems'
+ require 'rake/clean'
+ require 'rake/gempackagetask'
+-require 'hanna/rdoctask'
+ require 'fileutils'
+ include FileUtils
+
+@@ -65,6 +64,11 @@ end
+
+
+ # RUBY DOCS TASK ==================================
++begin
++ require 'hanna/rdoctask'
++rescue LoadError
++ require 'rake/rdoctask'
++end
+
+ Rake::RDocTask.new do |t|
+ t.rdoc_dir = 'doc'
+diff --git a/try/30_nometaclass_tryouts.rb b/try/30_nometaclass_tryouts.rb
+index 0a07843..94f3ea8 100644
+--- a/try/30_nometaclass_tryouts.rb
++++ b/try/30_nometaclass_tryouts.rb
+@@ -30,13 +30,13 @@ tryouts "Basics" do
+ :any.metaclass?
+ end
+
+- dream [:@___attic_name]
++ dream ["@___attic_name"]
+ drill "A Symbol's attic vars appear in all_instance_variables" do
+ Symbol.extend Attic
+ Symbol.attic :name
+ a, b = :symbol1, :symbol2
+ a.name = :roger
+- a.all_instance_variables
++ a.all_instance_variables.collect { |x| x.to_s }
+ end
+
+ dream []
diff --git a/dev-ruby/attic/metadata.xml b/dev-ruby/attic/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/attic/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>