summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-04-23 15:42:54 +0000
committerTom William Payne <twp@gentoo.org>2003-04-23 15:42:54 +0000
commit1fd15dc840f8703ee96368599d03e1f501445bed (patch)
treec1cd089a1573cf77dbc4b61a8e5bb020624d4ac9 /dev-ruby/http-access2
parentold files -> buh bye (diff)
downloadhistorical-1fd15dc840f8703ee96368599d03e1f501445bed.tar.gz
historical-1fd15dc840f8703ee96368599d03e1f501445bed.tar.bz2
historical-1fd15dc840f8703ee96368599d03e1f501445bed.zip
Initial commit.
Diffstat (limited to 'dev-ruby/http-access2')
-rw-r--r--dev-ruby/http-access2/ChangeLog9
-rw-r--r--dev-ruby/http-access2/http-access2-0j.ebuild22
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/http-access2/ChangeLog b/dev-ruby/http-access2/ChangeLog
new file mode 100644
index 000000000000..8f3d194404f1
--- /dev/null
+++ b/dev-ruby/http-access2/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-ruby/http-access2
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http-access2/ChangeLog,v 1.1 2003/04/23 15:41:26 twp Exp $
+
+*http-access2-0j (23 Apr 2003)
+
+ 23 Apr 2003; Tom Payne <twp@gentoo.org> http-access2-0j.ebuild :
+
+ Initial version.
diff --git a/dev-ruby/http-access2/http-access2-0j.ebuild b/dev-ruby/http-access2/http-access2-0j.ebuild
new file mode 100644
index 000000000000..308d359bfdcf
--- /dev/null
+++ b/dev-ruby/http-access2/http-access2-0j.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http-access2/http-access2-0j.ebuild,v 1.1 2003/04/23 15:41:26 twp Exp $
+
+MY_PV=`echo ${PV} | tr -d 0`
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="HTTP accessing library"
+HOMEPAGE="http://rrr.jin.gr.jp/doc/http-access2/"
+SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/contrib/${MY_P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=">=dev-lang/ruby-1.6"
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ local sitelibdir=`ruby -r rbconfig -e 'print Config::CONFIG["sitelibdir"]'`
+ insinto ${sitelibdir}
+ doins lib/*.rb
+ insinto ${sitelibdir}/http-access2
+ doins lib/http-access2/*.rb
+}