summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-09 12:52:32 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-09 12:52:32 +0000
commit03ead5773872f44cbdcf84fa270a2a7880495f87 (patch)
tree2a6db23db648add10012d36d98edbbdc06decb67 /dev-ruby/multi_json
parentRemove old versions. (diff)
downloadhistorical-03ead5773872f44cbdcf84fa270a2a7880495f87.tar.gz
historical-03ead5773872f44cbdcf84fa270a2a7880495f87.tar.bz2
historical-03ead5773872f44cbdcf84fa270a2a7880495f87.zip
Version bump.
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/ChangeLog7
-rw-r--r--dev-ruby/multi_json/multi_json-1.2.0.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/multi_json/ChangeLog b/dev-ruby/multi_json/ChangeLog
index 63b605348d66..b84a7f709de7 100644
--- a/dev-ruby/multi_json/ChangeLog
+++ b/dev-ruby/multi_json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/multi_json
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.16 2012/04/09 12:37:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.17 2012/04/09 12:44:10 graaff Exp $
+
+*multi_json-1.2.0 (09 Apr 2012)
+
+ 09 Apr 2012; Hans de Graaff <graaff@gentoo.org> +multi_json-1.2.0.ebuild:
+ Version bump.
09 Apr 2012; Hans de Graaff <graaff@gentoo.org> -multi_json-0.0.4.ebuild,
-multi_json-1.0.2.ebuild, -multi_json-1.0.3.ebuild:
diff --git a/dev-ruby/multi_json/multi_json-1.2.0.ebuild b/dev-ruby/multi_json/multi_json-1.2.0.ebuild
new file mode 100644
index 000000000000..fff5a1041af8
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.2.0.ebuild,v 1.1 2012/04/09 12:44:10 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="http://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:2 )"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/json )"
+
+USE_RUBY=ruby18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
+USE_RUBY=ruby19 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
+USE_RUBY=ree18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die "Unable to remove bundler."
+ rm Gemfile || die "Unable to remove bundler Gemfile."
+
+ # Remove simplecov support since we only care about the test results
+ # and this avoids another dependency.
+ sed -i -e '/[Ss]imple[Cc]ov/d' spec/helper.rb || die
+
+ # Provide version otherwise provided by bundler.
+ sed -i -e "s/#{MultiJson::VERSION}/${PV}/" Rakefile || die
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove best default spec since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
+}