summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Brabec <utx@gentoo.org>2003-04-23 17:23:35 +0000
committerStanislav Brabec <utx@gentoo.org>2003-04-23 17:23:35 +0000
commit8327ddef955050eafc27032b439ba25adbba1fd0 (patch)
treef45a4f54c139b1b1712f439d941938e4f31aedcf /dev-tcltk
parentfixed for tcl/tk 8.4 (diff)
downloadhistorical-8327ddef955050eafc27032b439ba25adbba1fd0.tar.gz
historical-8327ddef955050eafc27032b439ba25adbba1fd0.tar.bz2
historical-8327ddef955050eafc27032b439ba25adbba1fd0.zip
build against tcl/tk 8.4
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclx/ChangeLog11
-rw-r--r--dev-tcltk/tclx/files/digest-tclx-8.3-r13
-rw-r--r--dev-tcltk/tclx/tclx-8.3-r1.ebuild64
3 files changed, 75 insertions, 3 deletions
diff --git a/dev-tcltk/tclx/ChangeLog b/dev-tcltk/tclx/ChangeLog
index 956fd73a3d22..873a54d8d9de 100644
--- a/dev-tcltk/tclx/ChangeLog
+++ b/dev-tcltk/tclx/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for dev-tcltk/tclx
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/ChangeLog,v 1.5 2003/03/31 18:18:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/ChangeLog,v 1.6 2003/04/23 17:23:35 utx Exp $
- 13 Feb 2003; Mark Guertin <gerk@gentoo.org> tclx-8.3.ebuild :
- added ~ppc to keywords
+*tclx-8.3-r1 (23 Apr 2003)
+
+ 23 Apr 2003; Stanislav Brabec <utx@gentoo.org> tclx-8.3-r1.ebuild:
+ Added new ebuild, which builds tclx against tcl/tk 8.4.2 (bug #19555).
*tclx-8.3 (15 Aug 2002)
+ 13 Feb 2003; Mark Guertin <gerk@gentoo.org> tclx-8.3.ebuild :
+ added ~ppc to keywords
+
31 Mar 2003; Aron Griffis <agriffis@gentoo.org> tclx-8.3.ebuild:
Add -fPIC on alpha to close bug 10921
diff --git a/dev-tcltk/tclx/files/digest-tclx-8.3-r1 b/dev-tcltk/tclx/files/digest-tclx-8.3-r1
new file mode 100644
index 000000000000..277f453a4a6d
--- /dev/null
+++ b/dev-tcltk/tclx/files/digest-tclx-8.3-r1
@@ -0,0 +1,3 @@
+MD5 deb98c29eb8fc1b43cc60198105ce24b tclx8.3.tar.gz 450328
+MD5 4be55d8ebfcc9773407537445edd2ae1 tcl8.4.2-src.tar.gz 3330617
+MD5 04812fcdf6b50bfe89b7d44db3f33f19 tk8.4.2-src.tar.gz 3155987
diff --git a/dev-tcltk/tclx/tclx-8.3-r1.ebuild b/dev-tcltk/tclx/tclx-8.3-r1.ebuild
new file mode 100644
index 000000000000..6f2e1eae566a
--- /dev/null
+++ b/dev-tcltk/tclx/tclx-8.3-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3-r1.ebuild,v 1.1 2003/04/23 17:23:35 utx Exp $
+
+inherit flag-o-matic
+
+IUSE="X"
+
+DESCRIPTION="A set of extensions to TCL"
+HOMEPAGE="http://www.neosoft.com/TclX/"
+SRC_URI="ftp://ftp.slackware.com/pub/slackware/slackware-8.1/source/tcl/tclx/${PN}${PV}.tar.gz
+ ftp://ftp.scriptics.com/pub/tcl/tcl8_4/tcl8.4.2-src.tar.gz
+ ftp://ftp.scriptics.com/pub/tcl/tcl8_4/tk8.4.2-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha"
+
+DEPEND=">=dev-lang/tcl-8.4.2
+ X? >=dev-lang/tk-8.4.2"
+
+S=${WORKDIR}/${PN}${PV}
+
+[ $ARCH = alpha ] && append-flags -fPIC
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-makecfg.patch || die
+ patch -p1 < ${FILESDIR}/${P}-argv.patch || die
+ patch -p1 < ${FILESDIR}/${P}-varinit.patch || die
+}
+
+src_compile() {
+ # we have to configure and build tcl before we can do tclx
+ cd ${WORKDIR}/tcl8.4.2/unix
+ econf
+ emake CFLAGS="${CFLAGS}" || die "emake in tcl/unix failed"
+
+ local myconf="--with-tcl=${WORKDIR}/tcl8.4.2/unix --enable-shared"
+
+ if [ `use X` ] ; then
+ # configure and build tk
+ cd ${WORKDIR}/tk8.4.2/unix
+ econf
+ emake CFLAGS="${CFLAGS}" || die
+ myconf="${myconf} --with-tk=${WORKDIR}/tk8.4.2/unix"
+ else
+ myconf="${myconf} --enable-tk=no"
+ fi
+
+ # configure and build tclx
+ cd ${S}/unix
+ econf ${myconf}
+ make CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ echo "installing tclx"
+ cd ${S}/unix
+ make INSTALL_ROOT=${D} install
+ cd ${S}
+ dodoc CHANGES README TO-DO doc/CONVERSION-NOTES
+ doman doc/*.[n3]
+}