summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Bonazzola <sanchan@gentoo.org>2006-01-22 09:20:35 +0000
committerSandro Bonazzola <sanchan@gentoo.org>2006-01-22 09:20:35 +0000
commit7e9b5a65579dcb4464baecdd3b4dd686caad4cf0 (patch)
tree0433a0d2a7b886423d0a0d4277d70b6a83dfa1e4 /dev-tinyos
parentStable on ppc64 (diff)
downloadhistorical-7e9b5a65579dcb4464baecdd3b4dd686caad4cf0.tar.gz
historical-7e9b5a65579dcb4464baecdd3b4dd686caad4cf0.tar.bz2
historical-7e9b5a65579dcb4464baecdd3b4dd686caad4cf0.zip
Initial import of tos ebuild for TinyOS
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'dev-tinyos')
-rw-r--r--dev-tinyos/nesc/Manifest4
-rw-r--r--dev-tinyos/tos/ChangeLog12
-rw-r--r--dev-tinyos/tos/Manifest6
-rw-r--r--dev-tinyos/tos/files/99tinyos2
-rw-r--r--dev-tinyos/tos/files/digest-tos-1.1.151
-rw-r--r--dev-tinyos/tos/files/tos-1.1.15-system-AMStandard-Control.patch29
-rw-r--r--dev-tinyos/tos/metadata.xml13
-rw-r--r--dev-tinyos/tos/tos-1.1.15.ebuild89
8 files changed, 156 insertions, 0 deletions
diff --git a/dev-tinyos/nesc/Manifest b/dev-tinyos/nesc/Manifest
new file mode 100644
index 000000000000..f545ec400f9f
--- /dev/null
+++ b/dev-tinyos/nesc/Manifest
@@ -0,0 +1,4 @@
+MD5 1b0a65c4ed98f55a1a85ae37bcf296a7 ChangeLog 422
+MD5 78f3d0c976b53eed528a108fc7b9fd6a files/digest-nesc-1.2.1 63
+MD5 632afbbaf09dda242cbd6cd6869b58c4 metadata.xml 507
+MD5 d2d89af97629592a4280df83439b3fea nesc-1.2.1.ebuild 1367
diff --git a/dev-tinyos/tos/ChangeLog b/dev-tinyos/tos/ChangeLog
new file mode 100644
index 000000000000..8e2122eae766
--- /dev/null
+++ b/dev-tinyos/tos/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-tinyos/tos
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/tos/ChangeLog,v 1.1 2006/01/22 09:20:35 sanchan Exp $
+
+*tos-1.1.15 (22 Jan 2006)
+
+ 22 Jan 2006; Sandro Bonazzola <sanchan@gentoo.org> +files/99tinyos,
+ +files/tos-1.1.15-system-AMStandard-Control.patch, +metadata.xml,
+ +tos-1.1.15.ebuild:
+ New ebuild, thanks to Johannes Ballé, Daniel Black, MT, Wouter Horré,
+ Aurélien Francillon. See bug# 78908 for their contribution.
+
diff --git a/dev-tinyos/tos/Manifest b/dev-tinyos/tos/Manifest
new file mode 100644
index 000000000000..6830a73d094f
--- /dev/null
+++ b/dev-tinyos/tos/Manifest
@@ -0,0 +1,6 @@
+MD5 b37534f217349eb852f641750e617bab ChangeLog 527
+MD5 ee24973a00e138fd2eca95bd9fab4a03 files/99tinyos 63
+MD5 4dc70773e9fed2b077c03fbbfbfab313 files/digest-tos-1.1.15 77
+MD5 fd8fe27c1335153ae750f7aed6d8cb1d files/tos-1.1.15-system-AMStandard-Control.patch 866
+MD5 cfea867833b0cdee3cee8444a4054f4d metadata.xml 551
+MD5 7c49f50477edca2e85fcf4078baa5028 tos-1.1.15.ebuild 2543
diff --git a/dev-tinyos/tos/files/99tinyos b/dev-tinyos/tos/files/99tinyos
new file mode 100644
index 000000000000..fb1301bed136
--- /dev/null
+++ b/dev-tinyos/tos/files/99tinyos
@@ -0,0 +1,2 @@
+TOSROOT="/usr/src/tinyos-1.x"
+TOSDIR="/usr/src/tinyos-1.x/tos"
diff --git a/dev-tinyos/tos/files/digest-tos-1.1.15 b/dev-tinyos/tos/files/digest-tos-1.1.15
new file mode 100644
index 000000000000..050688065436
--- /dev/null
+++ b/dev-tinyos/tos/files/digest-tos-1.1.15
@@ -0,0 +1 @@
+MD5 4e9535229eab02ee1f198b244c04bcd6 tinyos-1.1.15Dec2005cvs.tar.gz 10273122
diff --git a/dev-tinyos/tos/files/tos-1.1.15-system-AMStandard-Control.patch b/dev-tinyos/tos/files/tos-1.1.15-system-AMStandard-Control.patch
new file mode 100644
index 000000000000..82de745e4217
--- /dev/null
+++ b/dev-tinyos/tos/files/tos-1.1.15-system-AMStandard-Control.patch
@@ -0,0 +1,29 @@
+--- tos/system/AMStandard.nc-old 2006-01-10 22:32:15.000000000 +0100
++++ tos/system/AMStandard.nc 2006-01-10 22:32:43.000000000 +0100
+@@ -84,7 +84,7 @@
+ uint16_t counter;
+
+ // Initialization of this component
+- command bool Control.init() {
++ command result_t Control.init() {
+ result_t ok1, ok2;
+
+ call TimerControl.init();
+@@ -100,7 +100,7 @@
+ }
+
+ // Command to be used for power managment
+- command bool Control.start() {
++ command result_t Control.start() {
+ result_t ok0 = call TimerControl.start();
+ result_t ok1 = call UARTControl.start();
+ result_t ok2 = call RadioControl.start();
+@@ -116,7 +116,7 @@
+ }
+
+
+- command bool Control.stop() {
++ command result_t Control.stop() {
+ result_t ok1 = call UARTControl.stop();
+ result_t ok2 = call RadioControl.stop();
+ result_t ok3 = call ActivityTimer.stop();
diff --git a/dev-tinyos/tos/metadata.xml b/dev-tinyos/tos/metadata.xml
new file mode 100644
index 000000000000..f5aad5e920cd
--- /dev/null
+++ b/dev-tinyos/tos/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+<maintainer>
+ <email>sanchan@gentoo.org</email>
+</maintainer>
+ <longdescription>
+ TinyOS is a small operating system written in NesC language for embedded system like wireless sensor.
+ This package provides the sources of the tos directory of the TinyOS distribution, which contains the core
+ system, and the doc directory with the TinyOS documentation.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-tinyos/tos/tos-1.1.15.ebuild b/dev-tinyos/tos/tos-1.1.15.ebuild
new file mode 100644
index 000000000000..c466a7c139de
--- /dev/null
+++ b/dev-tinyos/tos/tos-1.1.15.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/tos/tos-1.1.15.ebuild,v 1.1 2006/01/22 09:20:35 sanchan Exp $
+inherit eutils
+
+CVS_MONTH="Dec"
+CVS_YEAR="2005"
+MY_PN="tinyos"
+MY_P=${MY_PN}-${PV}${CVS_MONTH}${CVS_YEAR}cvs
+
+DESCRIPTION="TinyOS: an open-source OS designed for wireless embedded sensor networks"
+HOMEPAGE="http://www.tinyos.net/"
+SRC_URI="http://www.tinyos.net/dist-1.1.0/tinyos/source/${MY_P}.tar.gz"
+LICENSE="Intel"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+#Ready to support doc regeneration when bug #113024 and #98029 will be resolved
+#DEPEND="doc? ( sys-devel/m4
+# virtual/tetex
+# dev-tex/latex2html )"
+
+DEPEND=""
+RDEPEND=""
+
+#Required to do anything useful. Could not be a RDEPEND since portage try to emerge nesc before tos.
+PDEPEND="dev-tinyos/nesc"
+
+S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/tos-1.1.15-system-AMStandard-Control.patch
+ sed -i -e "s:psfig:epsfig:" ${S}/doc/schemadocsrc/tinyschema.tex \
+ || die "Error while updating tex sources."
+ einfo "removing CVS dirs"
+ for i in `find . -name CVS`; do
+ rm -rf "${i}"
+ done
+}
+
+src_compile() {
+#Ready to support doc when bug #113024 and #98029 will be fixed
+# if use doc
+# then
+# cd ${WORKDIR}/tinyos-1.x/doc
+# make && make install-snapshots.html || die "Make error in tinyos-1.x/doc"
+# cd ${WORKDIR}/tinyos-1.x/doc/tex
+# make || die "Unable to make docs from tex sources"
+# cd ${WORKDIR}/tinyos-1.x/doc/schemadocsrc
+# make || die "Unable to make docs from tex sources"
+# make tinyschema.html || die "Unable to make docs from tex sources"
+# else
+ einfo "Nothing to compile."
+# fi
+}
+
+src_install() {
+ insinto /usr/src/tinyos-1.x
+ doins -r tos
+
+ # root group name doesn't exist on Mac OS X
+ #NOTE: do not use fowners, as its not recursive ...
+ # einfo "Fixing permissions ..."
+ chown -R root:0 "${D}"
+
+ # Note: should not die here or running in userpriv mode fill fail
+ # portage autochanges ownership from portage to root.
+ # chmod -R u=rwX,go=rX "${D}"
+ # || die "correcting file modes failed"
+ dodoc ChangeLog
+ if use doc
+ then
+ #once tetex works, tex could be removed.
+ dohtml -A pdf,gif,tex -r doc/*
+ dodoc doc/*.txt
+ fi
+ doenvd ${FILESDIR}/99tinyos
+}
+
+pkg_postinst() {
+ einfo "If you want to use TinyOS on real hardware you need a cross compiler."
+ einfo "You should emerge sys-devel/crossdev and compile any toolchain you need"
+ einfo "Example: for Mica2 and Mica2 Dot: crossdev --target avr"
+ ebeep 5
+ epause 5
+}
+