summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-05 01:28:46 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-05 01:28:46 +0000
commit3c2446f2756132533f9cea1f7c0060530ba38a5c (patch)
tree7e6bb02356fdba7efb6d6f27d45535225cc75536 /dev-util/gnustep-base
parentNew version (diff)
downloadhistorical-3c2446f2756132533f9cea1f7c0060530ba38a5c.tar.gz
historical-3c2446f2756132533f9cea1f7c0060530ba38a5c.tar.bz2
historical-3c2446f2756132533f9cea1f7c0060530ba38a5c.zip
gnustep-base is finally in portage. woot!
Diffstat (limited to 'dev-util/gnustep-base')
-rw-r--r--dev-util/gnustep-base/ChangeLog17
-rw-r--r--dev-util/gnustep-base/files/digest-gnustep-base-1.3.31
-rw-r--r--dev-util/gnustep-base/gnustep-base-1.1.0.ebuild19
-rw-r--r--dev-util/gnustep-base/gnustep-base-1.3.3.ebuild136
4 files changed, 173 insertions, 0 deletions
diff --git a/dev-util/gnustep-base/ChangeLog b/dev-util/gnustep-base/ChangeLog
new file mode 100644
index 000000000000..334537cf42d0
--- /dev/null
+++ b/dev-util/gnustep-base/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# Author Nick Hadaway <raker@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-base/ChangeLog,v 1.1 2002/07/05 01:28:46 raker Exp $
+
+#gentoo-base-1.3.3 (04 Jul 2002)
+
+ 04 Jul 2002; Nick Hadaway <raker@gentoo.org> gentoo-base-1.3.3.ebuild:
+
+ Updated to the 1.3.3 package.
+
+*gentoo-base-1.1.0 (04 Jul 2002)
+
+ 04 Jul 2002; Nick Hadaway <raker@gentoo.org> gentoo-base-1.1.0.ebuild:
+
+ This is the first ebuild for this package. The GNUstep base package.
+
diff --git a/dev-util/gnustep-base/files/digest-gnustep-base-1.3.3 b/dev-util/gnustep-base/files/digest-gnustep-base-1.3.3
new file mode 100644
index 000000000000..d791d25ad00c
--- /dev/null
+++ b/dev-util/gnustep-base/files/digest-gnustep-base-1.3.3
@@ -0,0 +1 @@
+MD5 c798af7cd14752670e40ccc7aad7b4bf gnustep-base-1.3.3.tar.gz 1540637
diff --git a/dev-util/gnustep-base/gnustep-base-1.1.0.ebuild b/dev-util/gnustep-base/gnustep-base-1.1.0.ebuild
new file mode 100644
index 000000000000..347a84705b5d
--- /dev/null
+++ b/dev-util/gnustep-base/gnustep-base-1.1.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Nick Hadaway <raker@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-base/gnustep-base-1.1.0.ebuild,v 1.1 2002/07/05 01:28:46 raker Exp $
+
+DESCRIPTION="GNUstep base package"
+HOMEPAGE="http://www.gnustep.org"
+LICENSE="LGPL"
+DEPEND=">=dev-util/gnustep-make-1.2.1"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+}
diff --git a/dev-util/gnustep-base/gnustep-base-1.3.3.ebuild b/dev-util/gnustep-base/gnustep-base-1.3.3.ebuild
new file mode 100644
index 000000000000..c84922063ede
--- /dev/null
+++ b/dev-util/gnustep-base/gnustep-base-1.3.3.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Nick Hadaway <raker@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-base/gnustep-base-1.3.3.ebuild,v 1.1 2002/07/05 01:28:46 raker Exp $
+
+DESCRIPTION="GNUstep base package"
+HOMEPAGE="http://www.gnustep.org"
+LICENSE="LGPL"
+DEPEND=">=dev-util/gnustep-make-1.3.3"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+src_compile() {
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ --with-xml-prefix=/usr \
+ --with-gmp-include=/usr/include \
+ --with-gmp-library=/usr/lib || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ mkdir -p ${D}/usr/GNUstep/System/Makefiles/Additional
+ insinto /usr/GNUstep/System/Makefiles/Additional
+ doins base.make
+
+ mkdir -p ${D}/usr/GNUstep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu
+ cd ${WORKDIR}/${P}/Source/shared_obj/ix86/linux-gnu/gnu-gnu-gnu
+ insinto /usr/GNUstep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu
+ doins libgnustep-base.so.1.3.3
+ dosym /usr/GNUstep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu/libgnustep-base.so.1.3.3 \
+ /usr/GNUstep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu/libgnustep-base.so.1
+ dosym /usr/GNUstep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu/libgnustep-base.so.1 \
+ /usr/GNUstep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu/libgnustep-base.so
+
+ mkdir -p ${D}/usr/GNUstep/System/Headers/Foundation
+ cd ${WORKDIR}/${P}/Headers/gnustep/base
+ insinto /usr/GNUstep/System/Headers/Foundation
+ doins Foundation.h NSByteOrder.h NSConcreteNumber.h \
+ NSPathUtilities.h NSSerialization.h NSUtilities.h GSMime.h \
+ GSXML.h NSArchiver.h NSArray.h NSAttributedString.h \
+ NSAutoreleasePool.h NSBitmapCharSet.h NSBundle.h \
+ NSCalendarDate.h NSCharacterSet.h NSClassDescription.h \
+ NSCoder.h NSConnection.h NSData.h NSDate.h NSDateFormatter.h \
+ NSDebug.h NSDecimal.h NSDecimalNumber.h NSDictionary.h \
+ NSDistantObject.h NSDistributedLock.h \
+ NSDistributedNotificationCenter.h NSEnumerator.h \
+ NSException.h NSFileHandle.h NSFileManager.h NSFormatter.h \
+ NSGeometry.h NSHashTable.h NSHost.h NSInvocation.h \
+ NSKeyValueCoding.h NSLock.h NSMapTable.h NSMethodSignature.h \
+ NSNotification.h NSNotificationQueue.h NSNull.h \
+ NSNumberFormatter.h NSObjCRuntime.h NSObject.h NSPort.h \
+ NSPortCoder.h NSPortMessage.h NSPortNameServer.h \
+ NSProcessInfo.h NSProtocolChecker.h NSProxy.h NSRange.h \
+ NSRunLoop.h NSScanner.h NSSet.h NSString.h NSTask.h \
+ NSThread.h NSTimeZone.h NSTimer.h NSURL.h NSURLHandle.h \
+ NSUndoManager.h NSUserDefaults.h NSValue.h NSZone.h \
+ objc-load.h
+
+ mkdir -p ${D}/usr/GNUstep/System/Headers/gnustep/base
+ cd ${WORKDIR}/${P}/Headers/gnustep/base
+ insinto /usr/GNUstep/System/Headers/gnustep/base
+ doins DistributedObjects.h GSLocale.h GSUnion.h GSIArray.h \
+ GSIMap.h Unicode.h UnixFileHandle.h behavior.h numbers.h \
+ objc-gnu2next.h preface.h
+
+ mkdir -p ${D}/usr/GNUstep/System/Headers/gnustep/unicode
+ cd ${WORKDIR}/${P}/Headers/gnustep/unicode
+ insinto /usr/GNUstep/System/Headers/gnustep/unicode
+ doins caseconv.h cop.h cyrillic.h latin2.h decomp.h nextstep.h
+
+ mkdir -p ${D}/usr/GNUstep/System/Headers/ix86/linux-gnu
+ cd ${WORKDIR}/${P}/Source/ix86/linux-gnu
+ insinto /usr/GNUstep/System/Headers/ix86/linux-gnu
+ doins GSConfig.h mframe.h
+
+ #These lines are already in /etc/services
+ #gdomap 538/tcp # GNUstep distrib objects
+ #gdomap 538/udp # GNUstep distrib objects
+
+ cd ${WORKDIR}/${P}/SSL
+ mkdir -p ${D}/usr/GNUstep/System/Library/Bundles
+ rm -f .tmp.gnustep.exclude
+ echo "SSL.bundle/Contents/Resources" > .tmp.gnustep.exclude
+ tar chfX - .tmp.gnustep.exclude SSL.bundle \
+ | (cd ${D}/usr/GNUstep/System/Library/Bundles; tar xf -)
+ rm -f .tmp.gnustep.exclude
+ cd ${D}/usr/GNUstep/System/Library/Bundles/SSL.bundle/Contents
+ rm -rf Resources
+ ln -s ../Resources .
+
+ cd ${WORKDIR}/${P}/Tools/shared_obj/ix86/linux-gnu/gnu-gnu-gnu
+ insinto /usr/GNUstep/System/Tools/ix86/linux-gnu/gnu-gnu-gnu
+ insopts -m 0755
+ doins autogsdoc cvtenc gdnc gsdoc defaults plmerge plparse \
+ sfparse pldes plser pl2link HTMLLinker
+
+ insinto /usr/GNUstep/System/Tools/ix86/linux-gnu
+ insopts -m 04755
+ doins gdomap
+
+ cd ${WORKDIR}/${P}/Tools/make_strings/shared_obj/ix86/linux-gnu/gnu-gnu-gnu
+ insinto /usr/GNUstep/System/Tools/ix86/linux-gnu/gnu-gnu-gnu
+ insopts -m 0755
+ doins make_strings
+
+ mkdir -p ${D}/usr/GNUstep/System/Libraries/Resources/NSCharacterServer
+ cd ${WORKDIR}/${P}/NSCharacterSets
+ insinto /usr/GNUstep/System/Libraries/Resources/NSCharacterSets
+ insopts -m 0644
+ doins alphanumericCharSet.dat controlCharSet.dat \
+ decimalDigitCharSet.dat decomposableCharSet.dat \
+ illegalCharSet.dat letterCharSet.dat \
+ lowercaseLetterCharSet.dat nonBaseCharSet.dat \
+ punctuationCharSet.dat symbolAndOperatorCharSet.dat \
+ uppercaseLetterCharSet.dat whitespaceAndNlCharSet.dat \
+ whitespaceCharSet.dat README.CharSet
+
+ mkdir -p ${D}/usr/GNUstep/System/Libraries/Resources
+ cd ${WORKDIR}/${P}/NSTimeZones
+ insinto /usr/GNUstep/System/Libraries/Resources
+ doins NSTimeZones.tar
+ cd ${D}/usr/GNUstep/System/Libraries/Resources
+ tar -xf NSTimeZones.tar
+ rm -f NSTimeZones.tar
+
+ cd ${WORKDIR}/${P}/Resources/Languages
+ mkdir -p ${D}/usr/GNUstep/System/Libraries/Resources/Languages
+ insinto /usr/GNUstep/System/Libraries/Resources/Languages
+ doins Dutch English French German Italian Russian Slovak \
+ UkraineRussian Locale.aliases
+}