summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-02-12 00:20:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-02-12 00:20:54 +0000
commitdc48a0888a431a0f05f0b11d5776b9e426162920 (patch)
treeef5428829be5d1d439a8452a97ac468a3bc3a576 /eclass/autotools.eclass
parentMarked stable on PPC64 as requested by Dirkjan "djc" Ochtman in bug #386089. ... (diff)
downloadhistorical-dc48a0888a431a0f05f0b11d5776b9e426162920.tar.gz
historical-dc48a0888a431a0f05f0b11d5776b9e426162920.tar.bz2
historical-dc48a0888a431a0f05f0b11d5776b9e426162920.zip
Provide a way to run eautoreconf without automake by using WANT_AUTOMAKE=none.
Diffstat (limited to 'eclass/autotools.eclass')
-rw-r--r--eclass/autotools.eclass10
1 files changed, 8 insertions, 2 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 62662fd74b71..1949b9f32439 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.118 2012/01/06 21:06:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.119 2012/02/12 00:20:54 robbat2 Exp $
# @ECLASS: autotools.eclass
# @MAINTAINER:
@@ -254,6 +254,12 @@ eautomake() {
local extra_opts
local makefile_name
+ # Some packages might need to skip automake
+ # OpenLDAP is a good example. It does not use automake (all the .in files are
+ # handwritten), but it does AM_INIT_AUTOMAKE in configure.in, for all the
+ # other macros involved
+ [[ ${WANT_AUTOMAKE} == "none" ]] && return 0
+
# Run automake if:
# - a Makefile.am type file exists
# - the configure script is using the AM_INIT_AUTOMAKE directive