summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-11-02 22:55:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-11-02 22:55:56 +0000
commit52a0cc1d5bc6213e3a4562bc577060e4a96dde29 (patch)
treee887e4c3d069a4bc7cd658c869e638a2b63efc1d /eclass/bsdmk.eclass
parentClean up ebuild, and use enewgroup instead of groupadd. (diff)
downloadhistorical-52a0cc1d5bc6213e3a4562bc577060e4a96dde29.tar.gz
historical-52a0cc1d5bc6213e3a4562bc577060e4a96dde29.tar.bz2
historical-52a0cc1d5bc6213e3a4562bc577060e4a96dde29.zip
add some checks for the existence of directories/makefiles to dummy_mk
Diffstat (limited to 'eclass/bsdmk.eclass')
-rw-r--r--eclass/bsdmk.eclass4
1 files changed, 3 insertions, 1 deletions
diff --git a/eclass/bsdmk.eclass b/eclass/bsdmk.eclass
index d46a76bc825a..57cf32c50658 100644
--- a/eclass/bsdmk.eclass
+++ b/eclass/bsdmk.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/bsdmk.eclass,v 1.9 2008/08/08 21:16:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/bsdmk.eclass,v 1.10 2011/11/02 22:55:56 aballier Exp $
# @ECLASS: bsdmk.eclass
# @MAINTAINER:
@@ -64,6 +64,8 @@ mkinstall() {
# useful to remove the need for "minimal" patches
dummy_mk() {
for dir in $@; do
+ [ -d ${dir} ] || ewarn "dummy_mk called on a non-existing directory: $dir"
+ [ -f ${dir}/Makefile ] || ewarn "dummy_mk called on a directory without Makefile: $dir"
echo ".include <bsd.lib.mk>" > ${dir}/Makefile
done
}