summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-11 15:08:07 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-11 15:08:07 +0000
commita18b8c502d697dde5b46e9fa54867d99d8528c63 (patch)
tree5e3d3675e2764dc2b1589043df9a5864c250ca17 /eclass/gst-plugins.eclass
parentUpdate to support selinux USE flag (blame spb). (diff)
downloadhistorical-a18b8c502d697dde5b46e9fa54867d99d8528c63.tar.gz
historical-a18b8c502d697dde5b46e9fa54867d99d8528c63.tar.bz2
historical-a18b8c502d697dde5b46e9fa54867d99d8528c63.zip
QA: Apply whitespace checks from repoman to eclasses.
Diffstat (limited to 'eclass/gst-plugins.eclass')
-rw-r--r--eclass/gst-plugins.eclass16
1 files changed, 8 insertions, 8 deletions
diff --git a/eclass/gst-plugins.eclass b/eclass/gst-plugins.eclass
index 687c4031f9ce..9b1eeae56773 100644
--- a/eclass/gst-plugins.eclass
+++ b/eclass/gst-plugins.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins.eclass,v 1.27 2005/07/06 20:23:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins.eclass,v 1.28 2005/07/11 15:08:06 swegener Exp $
# Author : foser <foser@gentoo.org>
@@ -9,9 +9,9 @@
# eclass to make external gst-plugins emergable on a per-plugin basis
# to solve the problem with gst-plugins generating far too much unneeded deps
#
-# 3rd party applications using gstreamer now should depend on a set of plugins as
-# defined in the source, in case of spider usage obtain recommended plugins to use from
-# Gentoo developers responsible for gstreamer <gnome@gentoo.org>, the application developer
+# 3rd party applications using gstreamer now should depend on a set of plugins as
+# defined in the source, in case of spider usage obtain recommended plugins to use from
+# Gentoo developers responsible for gstreamer <gnome@gentoo.org>, the application developer
# or the gstreamer team.
inherit eutils
@@ -30,7 +30,7 @@ MY_P=gst-plugins-${PV}
# All relevant configure options for gst-plugins
# need a better way to extract these
# gstreamer 0.6
-my_gst_plugins="dxr3 oss qcam v4l v4l2 vcd vga cdrom xvideo a52dec aalib aalibtest alsa arts artstest artsc audiofile avifile cdparanoia dvdread dvdnav esd esdtest flac ffmpeg gnome_vfs gsm hermes http jack jpeg ladspa lame lcs libdv libfame libfametest libpng mad mikmod libmikmodtest mjpegtools mpeg2dec openquicktime raw1394 rtp sdl sdltest shout shout2 shout2test sidplay smoothwave snapshot swfdec tarkin vorbis vorbistest xmms libmmx atomic tests examples"
+my_gst_plugins="dxr3 oss qcam v4l v4l2 vcd vga cdrom xvideo a52dec aalib aalibtest alsa arts artstest artsc audiofile avifile cdparanoia dvdread dvdnav esd esdtest flac ffmpeg gnome_vfs gsm hermes http jack jpeg ladspa lame lcs libdv libfame libfametest libpng mad mikmod libmikmodtest mjpegtools mpeg2dec openquicktime raw1394 rtp sdl sdltest shout shout2 shout2test sidplay smoothwave snapshot swfdec tarkin vorbis vorbistest xmms libmmx atomic tests examples"
# gstreamer 0.8
my_gst_plugins="${my_gst_plugins} divx faad gdk_pixbuf ogg sndfile x pango speex xvid mpeg2enc mplex musicbrainz nas librfb libcaca ivorbis faac theora kio osx_audio osx_video sunaudio artsc dts libvisual dirac libmng opengl gst_v4l gst_v4l2 libmms musepack directfb polyp cairo spc wavpack cdio amrnb"
@@ -42,7 +42,7 @@ GST_PLUGINS_BUILD=${PN/gst-plugins-/}
# Actual build dir, is the same as the configure switch name most of the time
GST_PLUGINS_BUILD_DIR=${PN/gst-plugins-/}
-# general common gst-plugins ebuild entries
+# general common gst-plugins ebuild entries
DESCRIPTION="${BUILD_GST_PLUGINS} plugin for gstreamer"
HOMEPAGE="http://gstreamer.freedesktop.org/modules/gst-plugins.html"
LICENSE="GPL-2"
@@ -82,7 +82,7 @@ gst-plugins_find_plugin_dir() {
###
gst-plugins_src_configure() {
-
+
# disable any external plugin besides the plugin we want
local plugin gst_conf
@@ -146,7 +146,7 @@ gst-plugins_src_unpack() {
makefiles="Makefile sys/Makefile sys/${GST_PLUGINS_BUILD_DIR}/Makefile"
elif [ -d "${S}/ext/${GST_PLUGINS_BUILD_DIR}" ]; then
makefiles="Makefile ext/Makefile ext/${GST_PLUGINS_BUILD_DIR}/Makefile"
- fi
+ fi
sed -e "s:ac_config_files=.*:ac_config_files='${makefiles}':" \
-i ${S}/configure