summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-02-11 00:55:34 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-02-11 00:55:34 +0000
commitaab54f1111aa376fbe225efa1961fcf44ea73d94 (patch)
tree67a9e8528ad4c6200bace528e218b31ee9a7f83b /games-action/descent3-demo
parentAdded sys-libs/glibc to RDEPEND. (diff)
downloadhistorical-aab54f1111aa376fbe225efa1961fcf44ea73d94.tar.gz
historical-aab54f1111aa376fbe225efa1961fcf44ea73d94.tar.bz2
historical-aab54f1111aa376fbe225efa1961fcf44ea73d94.zip
Initial import. Ebuild by Paul Bredbury <brebs@sent.com>. Closing bug #120371.
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'games-action/descent3-demo')
-rw-r--r--games-action/descent3-demo/ChangeLog11
-rw-r--r--games-action/descent3-demo/descent3-demo-1.4.0a.ebuild72
-rw-r--r--games-action/descent3-demo/files/digest-descent3-demo-1.4.0a3
-rw-r--r--games-action/descent3-demo/metadata.xml16
4 files changed, 102 insertions, 0 deletions
diff --git a/games-action/descent3-demo/ChangeLog b/games-action/descent3-demo/ChangeLog
new file mode 100644
index 000000000000..ad5beb4e9280
--- /dev/null
+++ b/games-action/descent3-demo/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-action/descent3-demo
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent3-demo/ChangeLog,v 1.1 2006/02/11 00:55:34 wolf31o2 Exp $
+
+*descent3-demo-1.4.0a (11 Feb 2006)
+
+ 11 Feb 2006; Chris Gianelloni <wolf31o2@gentoo.org> +metadata.xml,
+ +descent3-demo-1.4.0a.ebuild:
+ Initial import. Ebuild by Paul Bredbury <brebs@sent.com>. Closing bug
+ #120371.
+
diff --git a/games-action/descent3-demo/descent3-demo-1.4.0a.ebuild b/games-action/descent3-demo/descent3-demo-1.4.0a.ebuild
new file mode 100644
index 000000000000..aa014344e465
--- /dev/null
+++ b/games-action/descent3-demo/descent3-demo-1.4.0a.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent3-demo/descent3-demo-1.4.0a.ebuild,v 1.1 2006/02/11 00:55:34 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Indoor/outdoor 3D combat with evil robotic mining spacecraft"
+HOMEPAGE="http://www.lokigames.com/products/descent3/"
+SRC_URI="mirror://lokigames/loki_demos/${PN}.run"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="nostrip"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="sys-libs/glibc
+ virtual/opengl
+ x86? (
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXext )
+ virtual/x11 )
+ =media-libs/libsdl-1.2* )
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-compat
+ app-emulation/emul-linux-x86-sdl
+ >=sys-libs/lib-compat-loki-0.2 )"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+ local demo="data/demos/descent3_demo"
+ local exe="descent3_demo.x86"
+
+ loki_patch patch.dat data/ || die "loki patch failed"
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doins -r "${demo}"/* || die "doins failed"
+ doexe "${demo}/${exe}" || die "doexe failed"
+
+ # Required directory
+ keepdir "${dir}"/missions
+
+ games_make_wrapper ${PN} "./${exe}" "${dir}"
+ newicon "${demo}"/launch/box.png ${PN}.png || die "newicon failed"
+ make_desktop_entry ${PN} "Descent 3 (Demo)" ${PN}.png
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "To play the game run:"
+ einfo " descent3-demo"
+ echo
+ einfo "If the game appears blank, then run it windowed with:"
+ einfo " descent3-demo -w"
+ echo
+
+ games_pkg_postinst
+}
+
diff --git a/games-action/descent3-demo/files/digest-descent3-demo-1.4.0a b/games-action/descent3-demo/files/digest-descent3-demo-1.4.0a
new file mode 100644
index 000000000000..7a36e758293f
--- /dev/null
+++ b/games-action/descent3-demo/files/digest-descent3-demo-1.4.0a
@@ -0,0 +1,3 @@
+MD5 9a746e5e7fc33ab177ca68a0cd13fb04 descent3-demo.run 45118289
+RMD160 5af291e72b33777d5c12faae0b4df8de2004c021 descent3-demo.run 45118289
+SHA256 9304dff200a062bb5bd1fa69517b5cc6c19db0a63c06b2084f05c98c9eca786c descent3-demo.run 45118289
diff --git a/games-action/descent3-demo/metadata.xml b/games-action/descent3-demo/metadata.xml
new file mode 100644
index 000000000000..88c7359adffa
--- /dev/null
+++ b/games-action/descent3-demo/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>wolf31o2@gentoo.org</email>
+ <name>Chris Gianelloni</name>
+</maintainer>
+<longdescription>
+Descent 3 is a first-person 3-D action flight-sim which takes place in both
+indoor and outdoor arenas. The game was ported to Linux by the now defunct Loki
+Entertainment and is commercial software. You can still pick up a copy from
+Tuxgames (http://www.tuxgames.com), but supplies are limited, as the publisher
+is no longer in business. This is the free demo version of the full game.
+</longdescription>
+</pkgmetadata>