summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-01-28 21:19:11 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-01-28 21:19:11 +0000
commit86d4b84a588733ba9eff5d03e899cf9d522d0392 (patch)
treed6f7ff0f73b0f09900b3d2b76231c2d113f1c5a3 /games-action/xblast
parentStable on x86; bug #120489 (diff)
downloadhistorical-86d4b84a588733ba9eff5d03e899cf9d522d0392.tar.gz
historical-86d4b84a588733ba9eff5d03e899cf9d522d0392.tar.bz2
historical-86d4b84a588733ba9eff5d03e899cf9d522d0392.zip
Fix dependencies for modular X.
Package-Manager: portage-2.1_pre4
Diffstat (limited to 'games-action/xblast')
-rw-r--r--games-action/xblast/ChangeLog8
-rw-r--r--games-action/xblast/xblast-2.10.0.ebuild10
-rw-r--r--games-action/xblast/xblast-2.10.2.ebuild10
3 files changed, 20 insertions, 8 deletions
diff --git a/games-action/xblast/ChangeLog b/games-action/xblast/ChangeLog
index dfde146ca04a..defea8fe1b84 100644
--- a/games-action/xblast/ChangeLog
+++ b/games-action/xblast/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/xblast
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/ChangeLog,v 1.9 2005/08/23 19:23:37 wolf31o2 Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/ChangeLog,v 1.10 2006/01/28 21:19:10 joshuabaergen Exp $
+
+ 28 Jan 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ xblast-2.10.0.ebuild, xblast-2.10.2.ebuild:
+ Add modular X dependencies.
23 Aug 2005; Chris Gianelloni <wolf31o2@gentoo.org> xblast-2.10.2.ebuild:
cp -dpR -> cp -pPR for bug #103487.
diff --git a/games-action/xblast/xblast-2.10.0.ebuild b/games-action/xblast/xblast-2.10.0.ebuild
index 780ff985cc7b..29867624cc2e 100644
--- a/games-action/xblast/xblast-2.10.0.ebuild
+++ b/games-action/xblast/xblast-2.10.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/xblast-2.10.0.ebuild,v 1.1 2005/02/02 07:30:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/xblast-2.10.0.ebuild,v 1.2 2006/01/28 21:19:10 joshuabaergen Exp $
inherit eutils games
@@ -13,8 +13,12 @@ SLOT="0"
KEYWORDS="~amd64 ppc x86"
IUSE=""
-DEPEND="virtual/x11
+RDEPEND="|| ( ( x11-libs/libICE
+ x11-libs/libX11 )
+ virtual/x11 )
media-libs/libpng"
+DEPEND="${RDEPEND}
+ || ( x11-libs/libXt virtual/x11 )"
src_unpack() {
unpack ${A}
diff --git a/games-action/xblast/xblast-2.10.2.ebuild b/games-action/xblast/xblast-2.10.2.ebuild
index 9b308c25af87..89345ab8a9b1 100644
--- a/games-action/xblast/xblast-2.10.2.ebuild
+++ b/games-action/xblast/xblast-2.10.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/xblast-2.10.2.ebuild,v 1.4 2005/08/23 19:23:37 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/xblast-2.10.2.ebuild,v 1.5 2006/01/28 21:19:10 joshuabaergen Exp $
inherit games
@@ -25,8 +25,12 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="virtual/x11
+RDEPEND="|| ( ( x11-libs/libICE
+ x11-libs/libX11 )
+ virtual/x11 )
media-libs/libpng"
+DEPEND="${RDEPEND}
+ || ( x11-libs/libXt virtual/x11 )"
src_compile() {
export MY_DATADIR="${GAMES_DATADIR}/${PN}"