summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-09 04:21:47 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-09 04:21:47 +0000
commit061d6fdb59100d1d8925f41d6c8e5cccb8594b4c (patch)
treec97ec34a624f5f630e4aef706a3634cdc8d28b5a /games-arcade/frozen-bubble
parentUpdate patch to work with both sdl-perl-1.x and sdl-perl-2.x and fix up the e... (diff)
downloadhistorical-061d6fdb59100d1d8925f41d6c8e5cccb8594b4c.tar.gz
historical-061d6fdb59100d1d8925f41d6c8e5cccb8594b4c.tar.bz2
historical-061d6fdb59100d1d8925f41d6c8e5cccb8594b4c.zip
split the sdl-perl-2 patch so it can be reused with the client addon
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'games-arcade/frozen-bubble')
-rw-r--r--games-arcade/frozen-bubble/Manifest5
-rw-r--r--games-arcade/frozen-bubble/files/frozen-bubble-1.0.0-editor-sdl-perl-2.patch67
-rw-r--r--games-arcade/frozen-bubble/files/frozen-bubble-1.0.0-sdl-perl-2.patch59
-rw-r--r--games-arcade/frozen-bubble/frozen-bubble-1.0.0-r5.ebuild4
4 files changed, 72 insertions, 63 deletions
diff --git a/games-arcade/frozen-bubble/Manifest b/games-arcade/frozen-bubble/Manifest
index a59762810858..f6d9ab9768ed 100644
--- a/games-arcade/frozen-bubble/Manifest
+++ b/games-arcade/frozen-bubble/Manifest
@@ -1,7 +1,8 @@
MD5 056de77ebfb1a8dd44fdc1dd9e415435 ChangeLog 5473
MD5 ed81470e0a1698d713b04ecb69d5a9e0 metadata.xml 449
-MD5 e611d4bfae801c9af654f8bbc19625fa frozen-bubble-1.0.0-r5.ebuild 2784
-MD5 3681057b08edce6c08aa3d63808ddd55 files/frozen-bubble-1.0.0-sdl-perl-2.patch 5833
+MD5 7fd6e2497efb929cea7335d706c04fe5 frozen-bubble-1.0.0-r5.ebuild 2794
+MD5 5c883c8dd838b13190b3115a7649333d files/frozen-bubble-1.0.0-sdl-perl-2.patch 3919
MD5 9a77f057ee51c039f467c20fa822159d files/digest-frozen-bubble-1.0.0-r5 228
MD5 c30d59b06b6112e4d3ca9ba2117c3202 files/1.0.0-no-chainreaction.patch 357
+MD5 2c95df6273ce7e60321c8f004aa0af1e files/frozen-bubble-1.0.0-editor-sdl-perl-2.patch 2111
MD5 411c7217cb8bf93cdedbb0ef0640ed2f files/frozen-bubble-1.0.0-makefile.patch 1053
diff --git a/games-arcade/frozen-bubble/files/frozen-bubble-1.0.0-editor-sdl-perl-2.patch b/games-arcade/frozen-bubble/files/frozen-bubble-1.0.0-editor-sdl-perl-2.patch
new file mode 100644
index 000000000000..e67043cf3f8a
--- /dev/null
+++ b/games-arcade/frozen-bubble/files/frozen-bubble-1.0.0-editor-sdl-perl-2.patch
@@ -0,0 +1,67 @@
+Based on upstream patch:
+http://www.frozen-bubble.org/perl-SDL.patch
+
+To fix:
+http://bugs.gentoo.org/show_bug.cgi?id=74844
+http://bugs.gentoo.org/show_bug.cgi?id=87502
+
+This version of the patch works with both sdl-perl-1.x and sdl-perl-2.x
+
+--- c_stuff/lib/FBLE.pm
++++ c_stuff/lib/FBLE.pm
+@@ -86,6 +86,25 @@
+
+ #- ----------- bubbles processing/drawing -----------------------------------------
+
++sub surf {
++ my ($surface) = @_;
++ if (ref($surface) eq 'HASH') {
++ return $surface->{-surface};
++ } else {
++ return $$surface;
++ }
++}
++
++sub rect {
++ my ($rect) = @_;
++ if (ref($rect) eq 'HASH') {
++ return $rect->{-rect};
++ } else {
++ return $$rect;
++ }
++}
++
++
+ # subroutine to calculate the left corner x of the given bubble option column (based on 0 start)
+ sub bubble_optionx {
+ my ($col) = @_;
+@@ -1094,11 +1113,11 @@
+ $rect{screenshot} = SDL::Rect->new(-x => $POS_1P{p1}{left_limit} - 40, '-y' => 0,
+ -width => $POS_1P{p1}{right_limit} - $POS_1P{p1}{left_limit} + 80,
+ -height => $POS_1P{bottom_limit} - $POS_1P{init_top_limit} + 190);
+- fb_c_stuff::shrink($app->{-surface},
+- $file_browser_screenshots[$list_browser_highlight_offset]->display_format()->{-surface},
++ fb_c_stuff::shrink(surf($app),
++ surf($file_browser_screenshots[$list_browser_highlight_offset]->display_format()),
+ $rect{middle}->x + $rect{middle}->width - $rect{screenshot}->width/4 - 12,
+ $rect{middle}->y + $rect{middle}->height/2 - $rect{screenshot}->height/8 - 3,
+- $rect{screenshot}{-rect}, 4);
++ rect($rect{screenshot}), 4);
+ }
+
+
+@@ -1366,6 +1366,14 @@
+ print_dialog_list_arrow($do_highlight, 'up');
+ }
+
++sub SDL_TEXTWIDTH {
++ if (defined(&SDL::App::SDL_TEXTWIDTH)) {
++ SDL::App::SDL_TEXTWIDTH(@_); # perl-sdl-1.x
++ } else {
++ SDL::SFont::SDL_TEXTWIDTH(@_); # perl-sdl-2.x
++ }
++}
++
+ # subroutine to print out the levelset name at the top of the screen
+ sub print_levelset_name {
+ $rect{ls_name_erase} = SDL::Rect->new(-x => 195, '-y' => 0, -width => 445-195, -height => 35);
diff --git a/games-arcade/frozen-bubble/files/frozen-bubble-1.0.0-sdl-perl-2.patch b/games-arcade/frozen-bubble/files/frozen-bubble-1.0.0-sdl-perl-2.patch
index d2960b6b331f..be8dfb058f85 100644
--- a/games-arcade/frozen-bubble/files/frozen-bubble-1.0.0-sdl-perl-2.patch
+++ b/games-arcade/frozen-bubble/files/frozen-bubble-1.0.0-sdl-perl-2.patch
@@ -3,7 +3,6 @@ http://www.frozen-bubble.org/perl-SDL.patch
To fix:
http://bugs.gentoo.org/show_bug.cgi?id=74844
-http://bugs.gentoo.org/show_bug.cgi?id=87502
This version of the patch works with both sdl-perl-1.x and sdl-perl-2.x
@@ -127,61 +126,3 @@ This version of the patch works with both sdl-perl-1.x and sdl-perl-2.x
}
$display_on_app_disabled = 0;
---- c_stuff/lib/FBLE.pm
-+++ c_stuff/lib/FBLE.pm
-@@ -86,6 +86,25 @@
-
- #- ----------- bubbles processing/drawing -----------------------------------------
-
-+sub surf {
-+ my ($surface) = @_;
-+ if (ref($surface) eq 'HASH') {
-+ return $surface->{-surface};
-+ } else {
-+ return $$surface;
-+ }
-+}
-+
-+sub rect {
-+ my ($rect) = @_;
-+ if (ref($rect) eq 'HASH') {
-+ return $rect->{-rect};
-+ } else {
-+ return $$rect;
-+ }
-+}
-+
-+
- # subroutine to calculate the left corner x of the given bubble option column (based on 0 start)
- sub bubble_optionx {
- my ($col) = @_;
-@@ -1094,11 +1113,11 @@
- $rect{screenshot} = SDL::Rect->new(-x => $POS_1P{p1}{left_limit} - 40, '-y' => 0,
- -width => $POS_1P{p1}{right_limit} - $POS_1P{p1}{left_limit} + 80,
- -height => $POS_1P{bottom_limit} - $POS_1P{init_top_limit} + 190);
-- fb_c_stuff::shrink($app->{-surface},
-- $file_browser_screenshots[$list_browser_highlight_offset]->display_format()->{-surface},
-+ fb_c_stuff::shrink(surf($app),
-+ surf($file_browser_screenshots[$list_browser_highlight_offset]->display_format()),
- $rect{middle}->x + $rect{middle}->width - $rect{screenshot}->width/4 - 12,
- $rect{middle}->y + $rect{middle}->height/2 - $rect{screenshot}->height/8 - 3,
-- $rect{screenshot}{-rect}, 4);
-+ rect($rect{screenshot}), 4);
- }
-
-
-@@ -1366,6 +1366,14 @@
- print_dialog_list_arrow($do_highlight, 'up');
- }
-
-+sub SDL_TEXTWIDTH {
-+ if (defined(&SDL::App::SDL_TEXTWIDTH)) {
-+ SDL::App::SDL_TEXTWIDTH(@_); # perl-sdl-1.x
-+ } else {
-+ SDL::SFont::SDL_TEXTWIDTH(@_); # perl-sdl-2.x
-+ }
-+}
-+
- # subroutine to print out the levelset name at the top of the screen
- sub print_levelset_name {
- $rect{ls_name_erase} = SDL::Rect->new(-x => 195, '-y' => 0, -width => 445-195, -height => 35);
diff --git a/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r5.ebuild b/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r5.ebuild
index 4cf44d3b4b34..ed28f27f534e 100644
--- a/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r5.ebuild
+++ b/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r5.ebuild,v 1.1 2005/05/09 04:19:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r5.ebuild,v 1.2 2005/05/09 04:21:47 vapier Exp $
inherit eutils perl-module games
@@ -30,7 +30,7 @@ src_unpack() {
# main package
epatch "${FILESDIR}"/${P}-makefile.patch
epatch "${FILESDIR}"/${PV}-no-chainreaction.patch
- epatch "${FILESDIR}"/${P}-sdl-perl-2.patch
+ epatch "${FILESDIR}"/${P}-{editor-,}sdl-perl-2.patch
sed -i \
-e 's:INSTALLDIRS=.*:PREFIX=${D}/usr:' \
c_stuff/Makefile \