summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-02 01:12:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-02 01:12:36 +0000
commite248ddf245f06242ae9d151886f8329a5c64a64e (patch)
tree80189eb17a4b4144b909df3074639bb94d8258c3 /games-arcade/insaneodyssey
parentarm KEYWORDS (diff)
downloadhistorical-e248ddf245f06242ae9d151886f8329a5c64a64e.tar.gz
historical-e248ddf245f06242ae9d151886f8329a5c64a64e.tar.bz2
historical-e248ddf245f06242ae9d151886f8329a5c64a64e.zip
initial commit - ebuild and patch from Alexandru Toma via bug #52697
Diffstat (limited to 'games-arcade/insaneodyssey')
-rw-r--r--games-arcade/insaneodyssey/ChangeLog11
-rw-r--r--games-arcade/insaneodyssey/Manifest5
-rw-r--r--games-arcade/insaneodyssey/files/digest-insaneodyssey-0003111
-rw-r--r--games-arcade/insaneodyssey/files/insaneodyssey-000311-datafiles.patch42
-rw-r--r--games-arcade/insaneodyssey/insaneodyssey-000311.ebuild58
-rw-r--r--games-arcade/insaneodyssey/metadata.xml5
6 files changed, 122 insertions, 0 deletions
diff --git a/games-arcade/insaneodyssey/ChangeLog b/games-arcade/insaneodyssey/ChangeLog
new file mode 100644
index 000000000000..7ec98f7a6837
--- /dev/null
+++ b/games-arcade/insaneodyssey/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-arcade/insaneodyssey
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/insaneodyssey/ChangeLog,v 1.1 2004/06/02 01:12:36 mr_bones_ Exp $
+
+*insaneodyssey-000311 (01 Jun 2004)
+
+ 01 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ insaneodyssey-000311.ebuild, metadata.xml,
+ files/insaneodyssey-000311-datafiles.patch:
+ initial commit - ebuild and patch from Alexandru Toma via bug #52697
+
diff --git a/games-arcade/insaneodyssey/Manifest b/games-arcade/insaneodyssey/Manifest
new file mode 100644
index 000000000000..d184157aca64
--- /dev/null
+++ b/games-arcade/insaneodyssey/Manifest
@@ -0,0 +1,5 @@
+MD5 01707d1c6c92a9c7a4229f93d24d2956 insaneodyssey-000311.ebuild 1615
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 fa121828e28f3dc4f8b647e364dc4145 ChangeLog 492
+MD5 08e2a908098df8856a600aa9cd2bdef3 files/digest-insaneodyssey-000311 60
+MD5 2ee185c3f8a9f1f6a56e88704bf63484 files/insaneodyssey-000311-datafiles.patch 1209
diff --git a/games-arcade/insaneodyssey/files/digest-insaneodyssey-000311 b/games-arcade/insaneodyssey/files/digest-insaneodyssey-000311
new file mode 100644
index 000000000000..661868ca78b4
--- /dev/null
+++ b/games-arcade/insaneodyssey/files/digest-insaneodyssey-000311
@@ -0,0 +1 @@
+MD5 3c75a29bf64b57efaf092bffbbac3af0 io000311.tar.gz 839950
diff --git a/games-arcade/insaneodyssey/files/insaneodyssey-000311-datafiles.patch b/games-arcade/insaneodyssey/files/insaneodyssey-000311-datafiles.patch
new file mode 100644
index 000000000000..4be3d0f12934
--- /dev/null
+++ b/games-arcade/insaneodyssey/files/insaneodyssey-000311-datafiles.patch
@@ -0,0 +1,42 @@
+--- io.cpp.orig 2004-06-01 19:11:16.000000000 +0300
++++ io.cpp 2004-06-01 19:21:14.000000000 +0300
+@@ -42,7 +42,11 @@
+ {
+ SDL_Surface *image, *surface;
+
+- image = IMG_Load(datafile);
++ char data_path[100];
++ strcpy(data_path, "/usr/share/games/insaneodyssey/");
++ strcat(data_path, datafile);
++
++ image = IMG_Load(data_path);
+ if ( image == NULL ) {
+ fprintf(stderr, "Couldn't load image %s\n",
+ datafile);
+@@ -67,7 +71,11 @@
+ {
+ SDL_Surface *image, *surface;
+
+- image = IMG_Load(datafile);
++ char data_path[100];
++ strcpy(data_path, "/usr/share/games/insaneodyssey/");
++ strcat(data_path, datafile);
++
++ image = IMG_Load(data_path);
+ if ( image == NULL ) {
+ fprintf(stderr, "Couldn't load image %s\n", datafile);
+ return(NULL);
+@@ -87,8 +95,12 @@
+ {
+ SDL_Surface *image;
+
++ char data_path[100];
++ strcpy(data_path, "/usr/share/games/insaneodyssey/");
++ strcat(data_path, datafile);
++
+ /* Load the BMP file into a surface */
+- image = IMG_Load(datafile);
++ image = IMG_Load(data_path);
+ if ( image == NULL ) {
+ fprintf(stderr, "Couldn't load %s: %s\n", datafile,
+ SDL_GetError());
diff --git a/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild b/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild
new file mode 100644
index 000000000000..a83846925eba
--- /dev/null
+++ b/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild,v 1.1 2004/06/02 01:12:36 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Help West Muldune escape from a futuristic mental hospital"
+HOMEPAGE="http://members.fortunecity.com/rivalentertainment/iox.html"
+# Upstream has download issues.
+#SRC_URI="http://members.fortunecity.com/rivalentertainment/io${PV}.tar.gz"
+SRC_URI="mirror://gentoo/io${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-mixer-1.2.5
+ >=media-libs/sdl-image-1.2.3"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}"
+
+DEST_DIR="${GAMES_DATADIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/${PN}"
+
+ # Modify data load code and paths to game data
+ epatch "${FILESDIR}/${P}-datafiles.patch"
+ sed -i \
+ -e "/lvl/s:^:${DEST_DIR}/:" \
+ -e "s:night:${DEST_DIR}/night:" \
+ levels.dat || die "sed levels.dat failed"
+ sed -i \
+ -e "s:tiles.dat:${DEST_DIR}/tiles.dat:" \
+ -e "s:sprites.dat:${DEST_DIR}/sprites.dat:" \
+ -e "s:levels.dat:${DEST_DIR}/levels.dat:" \
+ -e "s:IO_T:${DEST_DIR}/IO_T:" \
+ -e "s:tiles.att:${DEST_DIR}/tiles.att:" \
+ -e "s:shot:${DEST_DIR}/shot:" \
+ io.cpp || die "sed io.cpp failed"
+ sed -i \
+ -e 's:\[32:[100:' \
+ io.h || die "sed io.h failed"
+}
+
+src_install() {
+ cd ${PN}
+ dogamesbin insaneodyssey || die "dogamesbin failed"
+ insinto "${DEST_DIR}"
+ doins *bmp *png *dat *att *lvl *wav *mod *IT || die "doins failed"
+ prepgamesdirs
+}
diff --git a/games-arcade/insaneodyssey/metadata.xml b/games-arcade/insaneodyssey/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/insaneodyssey/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>