summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-02-27 20:56:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-02-27 20:56:09 +0000
commit9719e7cf6e169462009d43c06bc5a4b4b6770975 (patch)
treec51b26f8ec03bb82c2b0b697ee7fbdf658b4ac27 /games-emulation/dosbox-cvs
parentAdd IUSE (diff)
downloadhistorical-9719e7cf6e169462009d43c06bc5a4b4b6770975.tar.gz
historical-9719e7cf6e169462009d43c06bc5a4b4b6770975.tar.bz2
historical-9719e7cf6e169462009d43c06bc5a4b4b6770975.zip
alsa is actually a hard dep.
Package-Manager: portage-2.1_pre5-r1
Diffstat (limited to 'games-emulation/dosbox-cvs')
-rw-r--r--games-emulation/dosbox-cvs/ChangeLog6
-rw-r--r--games-emulation/dosbox-cvs/Manifest12
-rw-r--r--games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild14
3 files changed, 19 insertions, 13 deletions
diff --git a/games-emulation/dosbox-cvs/ChangeLog b/games-emulation/dosbox-cvs/ChangeLog
index e849b54d5d8f..2500167aecb4 100644
--- a/games-emulation/dosbox-cvs/ChangeLog
+++ b/games-emulation/dosbox-cvs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/dosbox-cvs
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox-cvs/ChangeLog,v 1.11 2006/02/07 03:45:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox-cvs/ChangeLog,v 1.12 2006/02/27 20:56:09 mr_bones_ Exp $
+
+ 27 Feb 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ dosbox-cvs-20030809.ebuild:
+ alsa is actually a hard dep. configure.in automagically detects it otherwise.
05 Feb 2006; Michael Sterrett <mr_bones_@gentoo.org>
dosbox-cvs-20030809.ebuild:
diff --git a/games-emulation/dosbox-cvs/Manifest b/games-emulation/dosbox-cvs/Manifest
index cb811e81f62a..9885a78887ad 100644
--- a/games-emulation/dosbox-cvs/Manifest
+++ b/games-emulation/dosbox-cvs/Manifest
@@ -1,4 +1,12 @@
-MD5 55564603285903d34da9337d341eea8e ChangeLog 1387
-MD5 866205dcbdd88b29b32b637ccc17d6f1 dosbox-cvs-20030809.ebuild 1377
+MD5 e75fc25f85c43b59b3999aa85c56d5da ChangeLog 1554
+RMD160 58e336efd630259740913de151a8aef8e53e119d ChangeLog 1554
+SHA256 ab14633718f240f89ae7e7c831f26876a140ed3e24184e783c0d4eb889f7f347 ChangeLog 1554
+MD5 f87d2e6e2c1f9ffe5c41d100e5da4e9a dosbox-cvs-20030809.ebuild 1228
+RMD160 f139e1554f0b3931124e41b61c80e8f3b4438b74 dosbox-cvs-20030809.ebuild 1228
+SHA256 64475ba546a728c5e42b591f3a9aac1f5e1d3455bec501bc45ab397728fb9900 dosbox-cvs-20030809.ebuild 1228
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-dosbox-cvs-20030809 0
+RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 files/digest-dosbox-cvs-20030809 0
+SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855 files/digest-dosbox-cvs-20030809 0
MD5 95e2b5bfd7767aeae061c77f7e1a055e metadata.xml 221
+RMD160 617e2d275f39c937dfdc8ae1ebc0b4fac331d0a9 metadata.xml 221
+SHA256 80c34a967b80bba5f0f27215677fdad5b1ed739678287b62db1f6c345cf69811 metadata.xml 221
diff --git a/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild b/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild
index 537c82a222af..1526ebc3ddcf 100644
--- a/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild
+++ b/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild,v 1.13 2006/02/07 03:45:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild,v 1.14 2006/02/27 20:56:09 mr_bones_ Exp $
inherit games cvs
@@ -10,9 +10,9 @@ HOMEPAGE="http://dosbox.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE="alsa opengl debug"
+IUSE="opengl debug"
-DEPEND="alsa? ( media-libs/alsa-lib )
+DEPEND="media-libs/alsa-lib
opengl? ( virtual/opengl )
>=media-libs/libsdl-1.2.0
sys-libs/zlib
@@ -27,18 +27,12 @@ ECVS_TOP_DIR=${DISTDIR}/cvs-src/${PN}
S=${WORKDIR}/${ECVS_MODULE}
src_compile() {
- local myconf
-
- if ! use alsa ; then
- myconf="--without-alsa-prefix --without-alsa-inc-prefix --disable-alsatest"
- fi
./autogen.sh || die "autogen.sh failed"
egamesconf \
--disable-dependency-tracking \
$(use_enable debug debug heavy) \
- ${myconf} \
$(use_enable opengl) \
- || die
+ || die
emake || die "emake failed"
}