summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-23 22:58:23 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-23 22:58:23 +0000
commitd10c473de72aea0a6afd3881e91b9f432abfc6d9 (patch)
tree0306734505088f5c560022e272e8c4ccf1a1de01 /games-fps/quake3-matrix/quake3-matrix-2.4_beta-r1.ebuild
parentadding patch re bug#152353 to fix use flags (diff)
downloadhistorical-d10c473de72aea0a6afd3881e91b9f432abfc6d9.tar.gz
historical-d10c473de72aea0a6afd3881e91b9f432abfc6d9.tar.bz2
historical-d10c473de72aea0a6afd3881e91b9f432abfc6d9.zip
Added new revision for testing which uses the brand-spankin-new games-mods.eclass to reduce ebuild code.
Package-Manager: portage-2.1.2_pre3-r5
Diffstat (limited to 'games-fps/quake3-matrix/quake3-matrix-2.4_beta-r1.ebuild')
-rw-r--r--games-fps/quake3-matrix/quake3-matrix-2.4_beta-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-fps/quake3-matrix/quake3-matrix-2.4_beta-r1.ebuild b/games-fps/quake3-matrix/quake3-matrix-2.4_beta-r1.ebuild
new file mode 100644
index 000000000000..27789e6d0196
--- /dev/null
+++ b/games-fps/quake3-matrix/quake3-matrix-2.4_beta-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-matrix/quake3-matrix-2.4_beta-r1.ebuild,v 1.1 2006/10/23 22:58:23 wolf31o2 Exp $
+
+MOD_DESC="Matrix conversion mod"
+MOD_NAME="matrix"
+MOD_DIR="matrix"
+
+inherit games games-mods
+
+# All other HOMEPAGE have disappeared
+HOMEPAGE="http://mods.moddb.com/3388/matrix-quake-3/"
+SRC_URI="matrix24.zip"
+
+LICENSE="freedist"
+RESTRICT="strip fetch"
+
+KEYWORDS="-* ~amd64 ~ppc ~x86"
+
+RDEPEND="ppc? ( games-fps/${GAME} )
+ !ppc? (
+ || (
+ games-fps/${GAME}
+ games-fps/${GAME}-bin ) )"
+
+pkg_nofetch() {
+ einfo "Download the following files from FilePlanet and put them in"
+ einfo "${DISTDIR}"
+ einfo
+ einfo "http://www.fileplanet.com/download.aspx?f=110838"
+}
+
+src_unpack() {
+ games-mods_src_unpack
+ mkdir -p ${S}/matrix
+ mv *.pk3 *.txt matrix
+}