summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-05-31 23:27:18 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-05-31 23:27:18 +0000
commit8edc9bdf978b07d0c4c6216ae3f53e7f81b5cac7 (patch)
tree881244df38d02544070b55fe4bf24d7a3d284131 /games-fps
parentStable on hppa. (diff)
downloadhistorical-8edc9bdf978b07d0c4c6216ae3f53e7f81b5cac7.tar.gz
historical-8edc9bdf978b07d0c4c6216ae3f53e7f81b5cac7.tar.bz2
historical-8edc9bdf978b07d0c4c6216ae3f53e7f81b5cac7.zip
Version bump. This resolves bug #128690 from the games team's end.
Package-Manager: portage-2.1_rc3-r2
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doomsday/ChangeLog12
-rw-r--r--games-fps/doomsday/doomsday-1.9.0_beta4.ebuild51
-rw-r--r--games-fps/doomsday/files/digest-doomsday-1.9.0_beta43
-rw-r--r--games-fps/doomsday/files/doomsday-1.9.0_beta4-configure.patch16
-rw-r--r--games-fps/doomsday/files/doomsday-1.9.0_beta4-music-driver.patch21
5 files changed, 102 insertions, 1 deletions
diff --git a/games-fps/doomsday/ChangeLog b/games-fps/doomsday/ChangeLog
index 125c7d41bed5..f2cac222c2e2 100644
--- a/games-fps/doomsday/ChangeLog
+++ b/games-fps/doomsday/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for games-fps/doomsday
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/ChangeLog,v 1.13 2006/04/22 06:12:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/ChangeLog,v 1.14 2006/05/31 23:27:18 wolf31o2 Exp $
+
+*doomsday-1.9.0_beta4 (31 May 2006)
+
+ 31 May 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ -files/doomsday-1.8.6-music-driver.patch,
+ +files/doomsday-1.9.0_beta4-configure.patch,
+ +files/doomsday-1.9.0_beta4-music-driver.patch, -doomsday-1.8.6.ebuild,
+ -doomsday-1.8.6-r1.ebuild, -doomsday-1.9.0_beta3.ebuild,
+ +doomsday-1.9.0_beta4.ebuild:
+ Version bump. This resolves bug #128690 from the games team's end.
*doomsday-1.9.0_beta3 (22 Apr 2006)
diff --git a/games-fps/doomsday/doomsday-1.9.0_beta4.ebuild b/games-fps/doomsday/doomsday-1.9.0_beta4.ebuild
new file mode 100644
index 000000000000..731ba49c5935
--- /dev/null
+++ b/games-fps/doomsday/doomsday-1.9.0_beta4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/doomsday-1.9.0_beta4.ebuild,v 1.1 2006/05/31 23:27:18 wolf31o2 Exp $
+
+inherit eutils games
+
+MY_PV=${PV/_/-}
+DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
+HOMEPAGE="http://www.doomsdayhq.com/"
+SRC_URI="mirror://sourceforge/deng/deng-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="openal"
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-net
+ media-libs/libpng
+ || ( x11-libs/libXext virtual/x11 )
+ openal? ( media-libs/openal )"
+
+S=${WORKDIR}/deng-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-music-driver.patch \
+ "${FILESDIR}"/${P}-configure.patch
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ rmdir "${D}/${GAMES_PREFIX}/include"
+ mv "${D}/${GAMES_DATADIR}/"{deng/Data/jDoom,doom-data}
+ dosym "${GAMES_DATADIR}"/doom-data "${GAMES_DATADIR}"/deng/Data/jDoom
+
+ local game
+ for game in jdoom jheretic jhexen ; do
+ newgamesbin "${FILESDIR}"/wrapper ${game}
+ sed -i \
+ -e "s:GAME:${game}:" "${D}"/${GAMES_BINDIR}/${game} \
+ || die "sed ${GAMES_BINDIR}/${game} failed"
+ done
+
+ dodoc Doc/*.txt Doc/*/*.txt README
+ prepgamesdirs
+}
diff --git a/games-fps/doomsday/files/digest-doomsday-1.9.0_beta4 b/games-fps/doomsday/files/digest-doomsday-1.9.0_beta4
new file mode 100644
index 000000000000..934f7796a87d
--- /dev/null
+++ b/games-fps/doomsday/files/digest-doomsday-1.9.0_beta4
@@ -0,0 +1,3 @@
+MD5 b2bec9a475eee1438f55ebde00b3d13f deng-1.9.0-beta4.tar.gz 4433485
+RMD160 5bd03b90dbbdc88fe1a4e128912c9be8dd91c93a deng-1.9.0-beta4.tar.gz 4433485
+SHA256 643fbd1a5be0db8ca1884ee389e111f2a7cfa61a2ee3acb4ed0f08a1b38660ae deng-1.9.0-beta4.tar.gz 4433485
diff --git a/games-fps/doomsday/files/doomsday-1.9.0_beta4-configure.patch b/games-fps/doomsday/files/doomsday-1.9.0_beta4-configure.patch
new file mode 100644
index 000000000000..47ace496ea0a
--- /dev/null
+++ b/games-fps/doomsday/files/doomsday-1.9.0_beta4-configure.patch
@@ -0,0 +1,16 @@
+diff -urN deng-1.9.0-beta4.orig/configure deng-1.9.0-beta4/configure
+--- deng-1.9.0-beta4.orig/configure 2006-05-28 13:54:06.000000000 -0400
++++ deng-1.9.0-beta4/configure 2006-05-31 12:13:39.000000000 -0400
+@@ -21001,10 +21001,10 @@
+ ac_config_files="$ac_config_files Makefile Src/Makefile Src/drOpenGL/Makefile Src/jDoom/Makefile Src/jHeretic/Makefile Src/jHexen/Makefile Src/dpDehRead/Makefile Src/dpMapLoad/Makefile Src/dsSDLMixer/Makefile Src/dsOpenAL/Makefile"
+
+
+-cd ..
++#cd ..
+ rm -f ./Data/Doomsday.pk3
+ zip -v -0 ./Data/Doomsday.pk3 ./Data/Graphics/* ./Data/Fonts/* ./Data/KeyMaps/*
+-cd Build
++#cd Build
+
+ #cd ..
+ #python ./Scripts/makedmt.py < ./Include/mapdata.hs
diff --git a/games-fps/doomsday/files/doomsday-1.9.0_beta4-music-driver.patch b/games-fps/doomsday/files/doomsday-1.9.0_beta4-music-driver.patch
new file mode 100644
index 000000000000..3165933ee1a0
--- /dev/null
+++ b/games-fps/doomsday/files/doomsday-1.9.0_beta4-music-driver.patch
@@ -0,0 +1,21 @@
+diff -burN Src.orig/s_mus.c Src/s_mus.c
+--- Src.orig/s_mus.c 2006-05-31 11:30:58.000000000 -0400
++++ Src/s_mus.c 2006-05-31 11:32:04.000000000 -0400
+@@ -122,7 +122,7 @@
+ #endif
+ #ifdef UNIX
+ // The available interfaces have already been loaded.
+- if(musd_loaded.Init())
++ if(musd_loaded.Init && musd_loaded.Init())
+ {
+ imus = (musd_loaded_imus.gen.Init ? &musd_loaded_imus : 0);
+ iext = (musd_loaded_iext.gen.Init ? &musd_loaded_iext : 0);
+@@ -174,7 +174,7 @@
+ musd_win.Shutdown();
+ #endif
+ #ifdef UNIX
+- musd_loaded.Shutdown();
++ if (musd_loaded.Shutdown) musd_loaded.Shutdown();
+ #endif
+
+ // No more interfaces.