summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-12 21:19:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-12 21:19:24 +0000
commit4770ac32d1ff64700fc254c0200474f3e4fa010b (patch)
tree8ad5353f24a969456c8abad437a950898db66fd4 /games-puzzle/xwelltris
parentEventually an openoffice that builds fine on ppc (~ppc) (diff)
downloadhistorical-4770ac32d1ff64700fc254c0200474f3e4fa010b.tar.gz
historical-4770ac32d1ff64700fc254c0200474f3e4fa010b.tar.bz2
historical-4770ac32d1ff64700fc254c0200474f3e4fa010b.zip
add media-libs/sdl-image for bug 33322; need sed >= 4; more error checking/messages
Diffstat (limited to 'games-puzzle/xwelltris')
-rw-r--r--games-puzzle/xwelltris/ChangeLog6
-rw-r--r--games-puzzle/xwelltris/Manifest4
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1.ebuild19
3 files changed, 19 insertions, 10 deletions
diff --git a/games-puzzle/xwelltris/ChangeLog b/games-puzzle/xwelltris/ChangeLog
index 3be8f7d8d129..968c7bdd3126 100644
--- a/games-puzzle/xwelltris/ChangeLog
+++ b/games-puzzle/xwelltris/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/xwelltris
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/ChangeLog,v 1.2 2003/09/10 15:48:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/ChangeLog,v 1.3 2003/11/12 21:19:21 mr_bones_ Exp $
+
+ 12 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> xwelltris-1.0.1.ebuild:
+ add media-libs/sdl-image for bug 33322; need sed >= 4; more error
+ checking/messages
*xwelltris-1.0.1 (12 Jul 2003)
diff --git a/games-puzzle/xwelltris/Manifest b/games-puzzle/xwelltris/Manifest
index 918d27e27e83..99d4f11d3c05 100644
--- a/games-puzzle/xwelltris/Manifest
+++ b/games-puzzle/xwelltris/Manifest
@@ -1,4 +1,4 @@
-MD5 3a962f37458bc73e234569a81146f8e8 ChangeLog 365
-MD5 76ca725fcfbc7abde08c7b1f7235bc7f xwelltris-1.0.1.ebuild 957
+MD5 fa2133b1436cebe52a4637854708c2c7 ChangeLog 536
+MD5 816834bc3c256385e26995d7dbb3c06f xwelltris-1.0.1.ebuild 1139
MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
MD5 f7cce601c76be9bc02185c11ee24bbb5 files/digest-xwelltris-1.0.1 71
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
index 12c1acf3236b..de3d7cce0a4c 100644
--- a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.1 2003/09/10 06:36:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.2 2003/11/12 21:19:21 mr_bones_ Exp $
inherit games
@@ -13,16 +13,21 @@ SLOT="0"
KEYWORDS="x86"
IUSE="sdl"
-DEPEND="|| (
- sdl? ( media-libs/libsdl )
+RDEPEND="|| (
+ sdl? ( media-libs/libsdl media-libs/sdl-image )
virtual/x11
)"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
src_compile() {
# configure/build process is pretty messed up
egamesconf `use_with sdl` || die
- sed -i "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" src/include/globals.h
- emake || die
+ sed -i \
+ -e "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
+ src/include/globals.h || \
+ die "sed src/include/globals.h failed"
+ emake || die "emake failed"
}
src_install() {
@@ -31,7 +36,7 @@ src_install() {
INSTDIR=${D}/${GAMES_BINDIR} \
INSTLIB=${D}/${GAMES_DATADIR}/${PN} \
INSTMAN=/usr/share/man \
- || die
- dodoc AUTHORS Changelog README*
+ || die "make install failed"
+ dodoc AUTHORS Changelog README* || die "dodoc failed"
prepgamesdirs
}