summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 04:59:58 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 04:59:58 +0000
commit0bb76cbaabcb2e024867417795e8c6b19786b020 (patch)
tree2a0f2a2466549809e3b960bb8cde4777773230e0 /games-roguelike/angband
parentrepoman: fix leading whitespace (diff)
downloadhistorical-0bb76cbaabcb2e024867417795e8c6b19786b020.tar.gz
historical-0bb76cbaabcb2e024867417795e8c6b19786b020.tar.bz2
historical-0bb76cbaabcb2e024867417795e8c6b19786b020.zip
hello rogues
Diffstat (limited to 'games-roguelike/angband')
-rw-r--r--games-roguelike/angband/ChangeLog25
-rw-r--r--games-roguelike/angband/Manifest3
-rw-r--r--games-roguelike/angband/angband-3.0.3.ebuild42
-rw-r--r--games-roguelike/angband/files/digest-angband-3.0.31
4 files changed, 71 insertions, 0 deletions
diff --git a/games-roguelike/angband/ChangeLog b/games-roguelike/angband/ChangeLog
new file mode 100644
index 000000000000..86b6b7e62314
--- /dev/null
+++ b/games-roguelike/angband/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for app-games/angband
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/ChangeLog,v 1.1 2003/09/10 04:59:58 vapier Exp $
+
+ 09 Jun 2003; <msterret@gentoo.org> angband-3.0.3.ebuild:
+ don't mangle myconf when USE=-X; removed DOCDIR (unused)
+
+ 09 Jun 2003; <msterret@gentoo.org> angband-3.0.3.ebuild:
+ DEPEND on sed >= 4; check sed return value
+
+*angband-3.0.3 (19 May 2003)
+
+ 19 May 2003; Martin Holzer <mholzer@gentoo.org> angband-3.0.3.ebuild:
+ Version bumped. Closes #21048
+
+*angband-3.0.1 (06 Nov 2002)
+
+ 06 Nov 2002; Ryan Phillips <rphillips@gentoo.org> angband-3.0.1.ebuild :
+ New version
+
+*angband-3.0.0 (15 Jul 2002)
+
+ 15 Jul 2002; J. Alberto S. L. <bass@gentoo.org> angband-3.0.0.ebuild:
+ First relase
+
diff --git a/games-roguelike/angband/Manifest b/games-roguelike/angband/Manifest
new file mode 100644
index 000000000000..07406b846c50
--- /dev/null
+++ b/games-roguelike/angband/Manifest
@@ -0,0 +1,3 @@
+MD5 166bf6a071476d096a14cc12f5c634f9 files/digest-angband-3.0.3 66
+MD5 34844b84a0c5a39960ef8380ba9583c4 angband-3.0.3.ebuild 1104
+MD5 59b8a6d7bac1cc0c334664e5634f3bac ChangeLog 822
diff --git a/games-roguelike/angband/angband-3.0.3.ebuild b/games-roguelike/angband/angband-3.0.3.ebuild
new file mode 100644
index 000000000000..9e26f92222c7
--- /dev/null
+++ b/games-roguelike/angband/angband-3.0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/angband-3.0.3.ebuild,v 1.1 2003/09/10 04:59:58 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A Roguelike adventure game"
+HOMEPAGE="http://thangorodrim.net/"
+SRC_URI="ftp://clockwork.dementia.org/${PN}/Source/${P}.tar.gz"
+
+LICENSE="Moria | GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="X"
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4
+ >=sys-libs/ncurses-5
+ X? ( >=x11-base/xfree-4.0 )"
+
+src_compile() {
+ local myconf="--bindir=/usr/games/bin --with-setgid=games"
+ myconf="${myconf} `use_with X x`"
+ sed -i "s:/games/:/:" configure || die "sed configure failed"
+ chmod +x configure
+ egamesconf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+pkg_preinst() {
+ rm ${D}/usr/share/games/angband/lib/apex/scores.raw
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING THANKS TODO changes.txt compile.txt readme.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ chmod -R g+w /usr/share/games/angband/lib/{apex,save,user}
+}
diff --git a/games-roguelike/angband/files/digest-angband-3.0.3 b/games-roguelike/angband/files/digest-angband-3.0.3
new file mode 100644
index 000000000000..3d34906aca29
--- /dev/null
+++ b/games-roguelike/angband/files/digest-angband-3.0.3
@@ -0,0 +1 @@
+MD5 5a2796eca8faffe25a519770e7029388 angband-3.0.3.tar.gz 1374750