summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-29 09:56:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-29 09:56:57 +0000
commit4542cdcd776d44f9eb577fa046678e442f5d4d3f (patch)
tree9785dd2235ea1d2db9123ac7511d34253624f038 /games-rpg/daimonin-client
parentMarked stable on sparc and mips. (diff)
downloadhistorical-4542cdcd776d44f9eb577fa046678e442f5d4d3f.tar.gz
historical-4542cdcd776d44f9eb577fa046678e442f5d4d3f.tar.bz2
historical-4542cdcd776d44f9eb577fa046678e442f5d4d3f.zip
version bump (bug #52180) - ebuild and patch thanks to Alexander Sandbu
Diffstat (limited to 'games-rpg/daimonin-client')
-rw-r--r--games-rpg/daimonin-client/ChangeLog8
-rw-r--r--games-rpg/daimonin-client/Manifest7
-rw-r--r--games-rpg/daimonin-client/daimonin-client-0.96a_beta2.ebuild55
-rw-r--r--games-rpg/daimonin-client/files/0.96a_beta2-gentoo-paths.patch102
-rw-r--r--games-rpg/daimonin-client/files/digest-daimonin-client-0.96a_beta21
5 files changed, 170 insertions, 3 deletions
diff --git a/games-rpg/daimonin-client/ChangeLog b/games-rpg/daimonin-client/ChangeLog
index 1f285a2f161e..1dd5fb7a6554 100644
--- a/games-rpg/daimonin-client/ChangeLog
+++ b/games-rpg/daimonin-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/daimonin-client
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.5 2004/06/24 23:15:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.6 2004/06/29 09:56:57 mr_bones_ Exp $
+
+*daimonin-client-0.96a_beta2 (29 Jun 2004)
+
+ 29 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.96a_beta2-gentoo-paths.patch, +daimonin-client-0.96a_beta2.ebuild:
+ version bump (bug #52180) - ebuild and patch thanks to Alexander Sandbu
16 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
daimonin-client-0.95b.ebuild:
diff --git a/games-rpg/daimonin-client/Manifest b/games-rpg/daimonin-client/Manifest
index e64337b56ec8..58f76a197383 100644
--- a/games-rpg/daimonin-client/Manifest
+++ b/games-rpg/daimonin-client/Manifest
@@ -1,6 +1,9 @@
-MD5 7d6247711b2e09655745a36d2606c00c daimonin-client-0.95b-r2.ebuild 1134
-MD5 ae88ce5c4d5f0ba3f0e7cc2a78ba1e7b ChangeLog 726
+MD5 a4c2e28f93e60d93e77da2ca72dfaf84 ChangeLog 979
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 7d6247711b2e09655745a36d2606c00c daimonin-client-0.95b-r2.ebuild 1134
+MD5 63cdab72c258d766a3ef9a0ffddbd856 daimonin-client-0.96a_beta2.ebuild 1508
MD5 f0fea0494c9b50a88620443df60a150e files/0.95b-gcc3.patch 1664
MD5 49fc669e5a92e2d43091dbcb3f5afec2 files/0.95b-gentoo-paths.patch 2948
MD5 b7f58f6b5220a09dedb532eb977bd227 files/digest-daimonin-client-0.95b-r2 69
+MD5 fff92cef909650f347db6cebfd2973dd files/digest-daimonin-client-0.96a_beta2 81
+MD5 8a41290909b2aa9cf1835f6aac36c738 files/0.96a_beta2-gentoo-paths.patch 3172
diff --git a/games-rpg/daimonin-client/daimonin-client-0.96a_beta2.ebuild b/games-rpg/daimonin-client/daimonin-client-0.96a_beta2.ebuild
new file mode 100644
index 000000000000..a43fa7cb1513
--- /dev/null
+++ b/games-rpg/daimonin-client/daimonin-client-0.96a_beta2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/daimonin-client-0.96a_beta2.ebuild,v 1.1 2004/06/29 09:56:57 mr_bones_ Exp $
+
+inherit eutils flag-o-matic games
+
+MY_PV=${PV/_beta*}
+MY_PV=${MY_PV/.}
+DESCRIPTION="MMORPG with 2D isometric tiles grafik, true color and alpha blending effects"
+HOMEPAGE="http://daimonin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/daimonin/daimonin_client_src-BETA2-${MY_PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ virtual/x11"
+
+S="${WORKDIR}/daimonin/client"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${PV}-gentoo-paths.patch"
+ cd make/linux
+ chmod a+x ./configure
+}
+
+src_compile() {
+ append-flags \
+ -DGENTOO_DATADIR="'\"${GAMES_DATADIR}/${PN}\"'" \
+ -DGENTOO_STATEDIR="'\"${GAMES_STATEDIR}/${PN}\"'"
+
+ cd make/linux
+ egamesconf || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/daimonin || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}" "${GAMES_STATEDIR}/${PN}"
+ cp -r bitmaps icons media sfx "${D}/${GAMES_DATADIR}/${PN}/" \
+ || die "cp failed"
+ cp -r cache gfx_user srv_files "${D}/${GAMES_STATEDIR}/${PN}/" \
+ || die "cp failed"
+ insinto "${GAMES_STATEDIR}/${PN}"
+ doins *.{dat,p0} || die "doins failed"
+ prepgamesdirs
+ find "${D}/${GAMES_STATEDIR}/${PN}/" -type d -print0 | xargs -0 \
+ chmod g+w
+}
diff --git a/games-rpg/daimonin-client/files/0.96a_beta2-gentoo-paths.patch b/games-rpg/daimonin-client/files/0.96a_beta2-gentoo-paths.patch
new file mode 100644
index 000000000000..94022939b3a9
--- /dev/null
+++ b/games-rpg/daimonin-client/files/0.96a_beta2-gentoo-paths.patch
@@ -0,0 +1,102 @@
+diff -urN client/src/include/config.h client-new/src/include/config.h
+--- client/src/include/config.h 2004-05-13 19:14:52.000000000 +0100
++++ client-new/src/include/config.h 2004-06-13 13:23:55.408837640 +0100
+@@ -26,11 +26,11 @@
+ #define VERSION_CS 991016
+ #define VERSION_SC 991016
+
+-#define KEYBIND_FILE "./keys.dat"
+-#define OPTION_FILE "./options.dat"
+-#define ARCHDEF_FILE "./archdef.dat"
++#define KEYBIND_FILE GENTOO_STATEDIR "/keys.dat"
++#define OPTION_FILE GENTOO_STATEDIR "/options.dat"
++#define ARCHDEF_FILE GENTOO_STATEDIR "/archdef.dat"
+
+-#define LOG_FILE "./client.log"
++#define LOG_FILE GENTOO_STATEDIR "/client.log"
+
+ #define CLIENT_ICON_NAME "icon.png"
+
+diff -urN client/src/include/main.h client-new/src/include/main.h
+--- client/src/include/main.h 2004-05-13 19:14:52.000000000 +0100
++++ client-new/src/include/main.h 2004-06-13 13:33:36.773456784 +0100
+@@ -103,16 +103,16 @@
+
+ extern int bmaptype_table_size;
+
+-#define FILE_DAIMONIN_P0 "./daimonin.p0"
+-#define FILE_BMAPS_P0 "./bmaps.p0"
+-#define FILE_BMAPS_TMP "./srv_files/bmaps.tmp"
+-#define FILE_ANIMS_TMP "./srv_files/anims.tmp"
+-
+-#define FILE_CLIENT_SPELLS "./srv_files/client_spells"
+-#define FILE_CLIENT_SKILLS "./srv_files/client_skills"
+-#define FILE_CLIENT_SETTINGS "./srv_files/client_settings"
+-#define FILE_CLIENT_BMAPS "./srv_files/client_bmap"
+-#define FILE_CLIENT_ANIMS "./srv_files/client_anims"
++#define FILE_DAIMONIN_P0 GENTOO_STATEDIR "/daimonin.p0"
++#define FILE_BMAPS_P0 GENTOO_STATEDIR "/bmaps.p0"
++#define FILE_BMAPS_TMP GENTOO_STATEDIR "/srv_files/bmaps.tmp"
++#define FILE_ANIMS_TMP GENTOO_STATEDIR "/srv_files/anims.tmp"
++
++#define FILE_CLIENT_SPELLS GENTOO_STATEDIR "/srv_files/client_spells"
++#define FILE_CLIENT_SKILLS GENTOO_STATEDIR "/srv_files/client_skills"
++#define FILE_CLIENT_SETTINGS GENTOO_STATEDIR "/srv_files/client_settings"
++#define FILE_CLIENT_BMAPS GENTOO_STATEDIR "/srv_files/client_bmap"
++#define FILE_CLIENT_ANIMS GENTOO_STATEDIR "/srv_files/client_anims"
+
+ enum {
+ SRV_CLIENT_SKILLS,
+diff -urN client/src/wrapper.c client-new/src/wrapper.c
+--- client/src/wrapper.c 2004-05-13 19:14:52.000000000 +0100
++++ client-new/src/wrapper.c 2004-06-13 13:45:34.944278224 +0100
+@@ -84,35 +84,35 @@
+ char * GetBitmapDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./bitmaps/");
++ return(GENTOO_DATADIR "/bitmaps/");
+ #endif
+ }
+
+ char * GetIconDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./icons/");
++ return(GENTOO_DATADIR "/icons/");
+ #endif
+ }
+
+ char * GetSfxDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./sfx/");
++ return(GENTOO_DATADIR "/sfx/");
+ #endif
+ }
+
+ char * GetCacheDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./cache/");
++ return(GENTOO_STATEDIR "/cache/");
+ #endif
+ }
+
+ char * GetGfxUserDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./gfx_user/");
++ return(GENTOO_STATEDIR "/gfx_user/");
+ #endif
+ }
+
+@@ -120,7 +120,7 @@
+ char * GetMediaDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./media/");
++ return(GENTOO_DATADIR "/media/");
+ #endif
+ }
+
diff --git a/games-rpg/daimonin-client/files/digest-daimonin-client-0.96a_beta2 b/games-rpg/daimonin-client/files/digest-daimonin-client-0.96a_beta2
new file mode 100644
index 000000000000..8ac38d806f94
--- /dev/null
+++ b/games-rpg/daimonin-client/files/digest-daimonin-client-0.96a_beta2
@@ -0,0 +1 @@
+MD5 ee0f3f4da694a2c2d980acc47c3039ad daimonin_client_src-BETA2-096a.zip 14274863