summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-12-26 20:38:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-12-26 20:38:51 +0000
commit32ad593adb8e7b4a129645c2392869ab812d6b86 (patch)
tree71a3437690b72e9447c84b1e03064975da31c8c9 /games-rpg
parentmoving the has_multilib_profile call to pkg_config, this time for real (diff)
downloadhistorical-32ad593adb8e7b4a129645c2392869ab812d6b86.tar.gz
historical-32ad593adb8e7b4a129645c2392869ab812d6b86.tar.bz2
historical-32ad593adb8e7b4a129645c2392869ab812d6b86.zip
version bump
Package-Manager: portage-2.0.53
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/tmw/ChangeLog7
-rw-r--r--games-rpg/tmw/Manifest10
-rw-r--r--games-rpg/tmw/files/digest-tmw-0.0.182
-rw-r--r--games-rpg/tmw/tmw-0.0.18.ebuild53
4 files changed, 67 insertions, 5 deletions
diff --git a/games-rpg/tmw/ChangeLog b/games-rpg/tmw/ChangeLog
index 780896487be8..8a88f23a8650 100644
--- a/games-rpg/tmw/ChangeLog
+++ b/games-rpg/tmw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/tmw
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.11 2005/10/12 23:44:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.12 2005/12/26 20:38:51 mr_bones_ Exp $
+
+*tmw-0.0.18 (26 Dec 2005)
+
+ 26 Dec 2005; Michael Sterrett <mr_bones_@gentoo.org> +tmw-0.0.18.ebuild:
+ version bump
*tmw-0.0.17 (12 Oct 2005)
diff --git a/games-rpg/tmw/Manifest b/games-rpg/tmw/Manifest
index bf036b714e7b..6f9397687efc 100644
--- a/games-rpg/tmw/Manifest
+++ b/games-rpg/tmw/Manifest
@@ -1,7 +1,9 @@
+MD5 4ac03e497c28015b3e3e88292e4a1807 ChangeLog 1851
+MD5 a933813e8f649c13b231f99f5639b421 files/digest-tmw-0.0.16-r1 127
+MD5 e49ce75b0ee692a5348fa56fbda9648b files/digest-tmw-0.0.17 127
+MD5 efc42bf65c43c7eb6eb700337dcf2104 files/digest-tmw-0.0.18 127
+MD5 6e873b44081c25fa618a3bd28d74f86c files/tmw-0.0.12-desktop.patch 757
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 f64825736e53be2ee93876dd3cec6056 tmw-0.0.16-r1.ebuild 1415
-MD5 5fbd471b6adf37768789e9b34f435121 ChangeLog 1730
MD5 629f3b5d9b44aafc605d5d0489a82985 tmw-0.0.17.ebuild 1435
-MD5 e49ce75b0ee692a5348fa56fbda9648b files/digest-tmw-0.0.17 127
-MD5 a933813e8f649c13b231f99f5639b421 files/digest-tmw-0.0.16-r1 127
-MD5 6e873b44081c25fa618a3bd28d74f86c files/tmw-0.0.12-desktop.patch 757
+MD5 35d27458d55183ed7e6aaaff610265a4 tmw-0.0.18.ebuild 1430
diff --git a/games-rpg/tmw/files/digest-tmw-0.0.18 b/games-rpg/tmw/files/digest-tmw-0.0.18
new file mode 100644
index 000000000000..5a048012acd6
--- /dev/null
+++ b/games-rpg/tmw/files/digest-tmw-0.0.18
@@ -0,0 +1,2 @@
+MD5 742d6291d5e43f52b9e38d042176fa56 tmw-0.0.18.tar.gz 2329550
+MD5 54ccc5d114eeb70d2bcb866e1e686c25 tmw-Magick-Real.ogg 840811
diff --git a/games-rpg/tmw/tmw-0.0.18.ebuild b/games-rpg/tmw/tmw-0.0.18.ebuild
new file mode 100644
index 000000000000..7ac997b8b595
--- /dev/null
+++ b/games-rpg/tmw/tmw-0.0.18.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.0.18.ebuild,v 1.1 2005/12/26 20:38:51 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A fully free and open source MMORPG game with the looks of \"old-fashioned\" 2D RPG"
+HOMEPAGE="http://themanaworld.org/"
+SRC_URI="mirror://sourceforge/themanaworld/${P}.tar.gz
+ mirror://gentoo/tmw-Magick-Real.ogg"
+# http://riekale.com/~rotonen/tmw/data/music/Magick%20-%20Real.ogg"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opengl"
+
+DEPEND=">=dev-games/physfs-1.0.0
+ opengl? ( virtual/opengl )
+ dev-libs/libxml2
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-net
+ net-misc/curl
+ >=dev-games/guichan-0.4.0"
+
+pkg_setup() {
+ if ! built_with_use dev-games/guichan sdl ; then
+ eerror "dev-games/guichan needs to be built with USE=sdl"
+ die "please re-emerge guichan with USE=sdl"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cp "${DISTDIR}"/tmw-Magick-Real.ogg . || die
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.0.12-desktop.patch
+}
+
+src_compile() {
+ egamesconf $(use_with opengl) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ insinto "${GAMES_DATADIR}"/${PN}/data/music
+ newins "${WORKDIR}"/tmw-Magick-Real.ogg "Magick - Real.ogg" || die
+ dodoc AUTHORS ChangeLog NEWS README
+ prepgamesdirs
+}