summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-11 12:22:49 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-11 12:22:49 +0000
commit0a66313722aa914ebab9c10951f6eebfec37cedc (patch)
tree99b4f3ae29b1a59ea05a34efa7cb32a0265c9e82 /games-simulation/cannonsmash
parentfix dvdr support (diff)
downloadhistorical-0a66313722aa914ebab9c10951f6eebfec37cedc.tar.gz
historical-0a66313722aa914ebab9c10951f6eebfec37cedc.tar.bz2
historical-0a66313722aa914ebab9c10951f6eebfec37cedc.zip
simulation type games
Diffstat (limited to 'games-simulation/cannonsmash')
-rw-r--r--games-simulation/cannonsmash/ChangeLog29
-rw-r--r--games-simulation/cannonsmash/Manifest4
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.5.ebuild56
-rw-r--r--games-simulation/cannonsmash/files/0.6.5-loadparts.patch15
-rw-r--r--games-simulation/cannonsmash/files/digest-cannonsmash-0.6.52
5 files changed, 106 insertions, 0 deletions
diff --git a/games-simulation/cannonsmash/ChangeLog b/games-simulation/cannonsmash/ChangeLog
new file mode 100644
index 000000000000..211f23112f0b
--- /dev/null
+++ b/games-simulation/cannonsmash/ChangeLog
@@ -0,0 +1,29 @@
+# ChangeLog for app-games/cannonsmash
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.1 2003/09/11 12:22:49 vapier Exp $
+
+*cannonsmash-0.6.5 (05 Mar 2003)
+
+ 12 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added optional ogg file for theme music #21070.
+
+ 09 Mar 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added patch for #16903.
+
+ 05 Mar 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #12662.
+
+*cannonsmash-0.6.4.2-r1 (26 May 2002)
+
+ 18 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> cannonsmash-0.6.4.2-r1.ebuild :
+ Updated to mirror://sourceforge in SRC_URI.
+
+ 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> cannonsmash-0.6.4.2-r1.ebuild :
+ Added LICENSE, KEYWORDS.
+ Added sdl-mixer to deps, so sound finally works, and made ebuild
+ nls-aware.
+
+*cannonsmash-0.6.4.2 (18 May 2002)
+
+ 18 May 2002; Bart Verwilst <verwilst@gentoo.org> Changelog :
+ Initial ebuild
diff --git a/games-simulation/cannonsmash/Manifest b/games-simulation/cannonsmash/Manifest
new file mode 100644
index 000000000000..8adfa4a3ba4c
--- /dev/null
+++ b/games-simulation/cannonsmash/Manifest
@@ -0,0 +1,4 @@
+MD5 fbc7d2161999a96e4c8cd035592ba8d5 files/digest-cannonsmash-0.6.5 134
+MD5 2ca70e3856451ca1226bb3461a653895 files/0.6.5-loadparts.patch 348
+MD5 6e4829bba16b891bc87b60a34396f493 cannonsmash-0.6.5.ebuild 1348
+MD5 aeef24cb5f7a553df70b9643bb2e2ab1 ChangeLog 999
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.5.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.5.ebuild
new file mode 100644
index 000000000000..c33ac280b4eb
--- /dev/null
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.5.ebuild,v 1.1 2003/09/11 12:22:49 vapier Exp $
+
+inherit eutils games
+
+MY_OGG=danslatristesse2-48.ogg
+DESCRIPTION="3D tabletennis game"
+SRC_URI="mirror://sourceforge/cannonsmash/csmash-${PV}.tar.gz
+ oggvorbis? ( http://nan.p.utmc.or.jp/${MY_OGG} )"
+HOMEPAGE="http://cannonsmash.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="oggvorbis nls"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ virtual/opengl
+ >=media-libs/libsdl-1.2.4
+ >=media-libs/sdl-mixer-1.2.3
+ >=media-libs/sdl-image-1.2.2
+ =x11-libs/gtk+-1.2*"
+
+S=${WORKDIR}/csmash-${PV}
+
+src_unpack() {
+ unpack csmash-${PV}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-loadparts.patch
+ if [ `use oggvorbis` ] ; then
+ cp ${DISTDIR}/${MY_OGG} ${S}/ || die "unpacking ogg"
+ sed -i "s:${MY_OGG}:${GAMES_DATADIR}/csmash/${MY_OGG}:" ttinc.h || die "setting ogg loc"
+ fi
+}
+
+src_compile() {
+ egamesconf \
+ `use_enable nls` \
+ --datadir=${GAMES_DATADIR_BASE} \
+ || die
+ emake || die
+}
+
+src_install() {
+ egamesinstall \
+ datadir=${D}/${GAMES_DATADIR_BASE} \
+ || die
+ if [ `use oggvorbis` ] ; then
+ insinto ${GAMES_DATADIR}/csmash
+ doins ${MY_OGG}
+ fi
+ dodoc AUTHORS CREDITS NEWS README*
+ prepgamesdirs
+}
diff --git a/games-simulation/cannonsmash/files/0.6.5-loadparts.patch b/games-simulation/cannonsmash/files/0.6.5-loadparts.patch
new file mode 100644
index 000000000000..be5bf56aed32
--- /dev/null
+++ b/games-simulation/cannonsmash/files/0.6.5-loadparts.patch
@@ -0,0 +1,15 @@
+--- loadparts.cpp.orig 2003-03-09 20:35:34.000000000 -0500
++++ loadparts.cpp 2003-03-09 20:35:48.000000000 -0500
+@@ -429,9 +429,9 @@
+ ++i;
+ }
+ }
+- if (!i) {
+- printf("%d: %s is empty object\n", lineno, object->name);
+- }
++// if (!i) {
++// printf("%d: %s is empty object\n", lineno, object->name);
++// }
+ return true;
+ }
+
diff --git a/games-simulation/cannonsmash/files/digest-cannonsmash-0.6.5 b/games-simulation/cannonsmash/files/digest-cannonsmash-0.6.5
new file mode 100644
index 000000000000..bb1d55418d6b
--- /dev/null
+++ b/games-simulation/cannonsmash/files/digest-cannonsmash-0.6.5
@@ -0,0 +1,2 @@
+MD5 969d5e5455f885e7cd6c24fdfafd5474 csmash-0.6.5.tar.gz 1469892
+MD5 d574b304d427a9b3c6d775af95ecbe8d danslatristesse2-48.ogg 1070787